Setting OAuth to login using Facebook

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Ideas Centre
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
User avatar
JimA
Community Team Leader
Community Team Leader
Posts: 7796
Joined: Thu Jul 31, 2008 5:54 am
Location: The Netherlands
Name: Jim Mossing Holsteyn
Contact:

Re: Setting OAuth to login using Facebook

Post by JimA »

mr.ruf wrote:is realy confuse !!! :shock:
If you have a question regarding any of this, please open your own topic in the 3.1 Support forum.
Thank you. :)
Jim Mossing Holsteyn - Community Team Leader
Knowledge Base | Documentation | Board rules

If you're having any questions about the rules/customs of this website, feel free to drop me a PM.
User avatar
mr.ruf
Registered User
Posts: 136
Joined: Thu Apr 04, 2013 11:12 pm
Location: PuErTo RiCo
Name: Harold
Contact:

Re: Setting OAuth to login using Facebook

Post by mr.ruf »

good I'll do my question, as this process is done? some of us do not understand how, but this seems ridiculous to be true. for example, I go straight to the link and once on facebook lose me.
I understand that it can be annoying to some, no offense, but honestly as I know that many do not understand anything about it. and the sad thing is that every day is more important to be able to link our forums we love with facebook.
There is some video tutorial? but I can not look anything like
rAdic
Registered User
Posts: 426
Joined: Mon Apr 25, 2005 11:32 pm
Contact:

Re: Setting OAuth to login using Facebook

Post by rAdic »

Is there a way you can allow the person to REGISTER with their Facebook account? I don't mean LOGIN as I see that works now but I see they still have to go through the normal slow process to register, it would be great if they could register by using their facebook etc login and then once they have done that we can ask them for more details. This is how other websites do it, if this is not already able to be done then I would highly recommend the developers consider this feature for the future as I'm sure it will eventually become standard at some stage so might as well do it soon. Thanks very much. :)

Also, another idea is to improve the "facebook" login button as it's not that easy to see, I would prefer it has the usually Facebook blue color and logo so visitors can easy recognize it instead of the boring grey submit button.
The Australian Forums - Australia Discussion Forum - Discuss Australia topics or generally anything
User avatar
JimA
Community Team Leader
Community Team Leader
Posts: 7796
Joined: Thu Jul 31, 2008 5:54 am
Location: The Netherlands
Name: Jim Mossing Holsteyn
Contact:

Re: Setting OAuth to login using Facebook

Post by JimA »

Registering with your social media account isn't possible in phpBB by default, only the OAuth option of logging in with an existing account as described in this topic, so you'd need an extension for that.

There does seem to be an off-site Social Login extension that claims to do this. Just keep in mind that since this extension is not released anywhere here on phpBB.com, there is no support for it on here. You could try it of course and see whether you like it, but you do so at your own risk. ;)
Jim Mossing Holsteyn - Community Team Leader
Knowledge Base | Documentation | Board rules

If you're having any questions about the rules/customs of this website, feel free to drop me a PM.
rAdic
Registered User
Posts: 426
Joined: Mon Apr 25, 2005 11:32 pm
Contact:

Re: Setting OAuth to login using Facebook

Post by rAdic »

JimA wrote:Registering with your social media account isn't possible in phpBB by default, only the OAuth option of logging in with an existing account as described in this topic, so you'd need an extension for that.

. ;)
ok, I think I will stick with the login for now as I want to avoid extensions if possible but I will consider it though in the near future if this is not implemented in the next release.

I have my fb login working, but Google is extremely difficult as the phpbb docs are outdated. will make a new thread for that now....
The Australian Forums - Australia Discussion Forum - Discuss Australia topics or generally anything
rAdic
Registered User
Posts: 426
Joined: Mon Apr 25, 2005 11:32 pm
Contact:

Re: Setting OAuth to login using Facebook

Post by rAdic »

So I got everything running by the looks for 2 X forums today but heck it took all day just to get Facebook, Google and Bitly login for 2 forums. it is much harder than you think as the documentation here is mostly outdated and not very detailed but I do appreciate only volunteers are doing this.

BUT when I thought it was all finished, i tried my 3nd website with the facebook login and I set it up exactly as the other forum which works although just with the other domain name.

but when I run the facebook login from that forum I get this one heck of an error and I have no idea what is going on, please help....

Code: Select all

Fatal error: Uncaught exception 'OAuth\Common\Http\Exception\TokenResponseException' with message 'Failed to request resource.' in /home/product1/public_html/vendor/lusitanian/oauth/src/OAuth/Common/Http/Client/StreamClient.php:68 Stack trace: #0 /home/product1/public_html/vendor/lusitanian/oauth/src/OAuth/OAuth2/Service/AbstractService.php(100): OAuth\Common\Http\Client\StreamClient->retrieveResponse(Object(OAuth\Common\Http\Uri\Uri), Array, Array) #1 /home/product1/public_html/phpbb/auth/provider/oauth/service/facebook.php(69): OAuth\OAuth2\Service\AbstractService->requestAccessToken('AQA-GjKjztUY08b...') #2 /home/product1/public_html/phpbb/auth/provider/oauth/oauth.php(198): phpbb\auth\provider\oauth\service\facebook->perform_auth_login() #3 /home/product1/public_html/phpbb/auth/auth.php(938): phpbb\auth\provider\oauth\oauth->login('', '') #4 /home/product1/public_html/includes/functions.php(2896): phpbb\auth\auth->login('', '', false, 1, 0) #5 /home/product1/public_html/ucp.php(84): login_box('index.php') #6 {main} in /home/product1/public_html/vendor/lusitanian/oauth/src/OAuth/Common/Http/Client/StreamClient.php on line 68
i must sleep soon, been at this for over 13 hours ... but I hope someone will reply and help, thanks...
The Australian Forums - Australia Discussion Forum - Discuss Australia topics or generally anything
rAdic
Registered User
Posts: 426
Joined: Mon Apr 25, 2005 11:32 pm
Contact:

Re: Setting OAuth to login using Facebook

Post by rAdic »

no feeback damn,, i might have to look at using the oneal plugin as this is giving me a headache and now I see the google login is not working on one forum i just checked..
The Australian Forums - Australia Discussion Forum - Discuss Australia topics or generally anything
rAdic
Registered User
Posts: 426
Joined: Mon Apr 25, 2005 11:32 pm
Contact:

Re: Setting OAuth to login using Facebook

Post by rAdic »

OK, I think I just needed a fresh start as it spent too much time on it yesterday. The error was because I had acidently put in the wrong url in google Authorized redirect URIs . I was also able to get them all working and I just had to also include the 3 urls in the Authorized redirect URIs again but witht the www.

:)
The Australian Forums - Australia Discussion Forum - Discuss Australia topics or generally anything
User avatar
Sypher187
Registered User
Posts: 49
Joined: Fri Feb 27, 2015 12:47 pm
Location: South Africa
Name: Erik Thiart
Contact:

Re: Setting OAuth to login using Facebook

Post by Sypher187 »

Does this allow them to register using Facebook or is this only for existing users to login with Facebook after they have registered?
rAdic
Registered User
Posts: 426
Joined: Mon Apr 25, 2005 11:32 pm
Contact:

Re: Setting OAuth to login using Facebook

Post by rAdic »

it looks like logging into social media accounts is still not smooth which is disappointing in this age with it very much a big part of peoples lives in 2017 whether you like it or not.
The Australian Forums - Australia Discussion Forum - Discuss Australia topics or generally anything
Locked

Return to “[3.1.x] Support Forum”