SQL problem

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
Bug78
Registered User
Posts: 3
Joined: Sun Oct 17, 2004 9:17 pm
Location: NL
Contact:

SQL problem

Post by Bug78 » Sun Oct 17, 2004 9:20 pm

Today in dit-upgraded my Debianbox.
Php and MySQL were upgraded and now phpBB comes up with the following output:

Code: Select all

phpBB : Critical Error

Could not query database for theme info

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 3
anyone knows what to do?

User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Post by A_Jelly_Doughnut » Sun Oct 17, 2004 9:32 pm

Usually this error means you are using a theme without a name, or you are missing a .cfg file in one of the template directories.
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish

Bug78
Registered User
Posts: 3
Joined: Sun Oct 17, 2004 9:17 pm
Location: NL
Contact:

Post by Bug78 » Sun Oct 17, 2004 10:29 pm

can`t be the problem

and everything worked fine before i upgraded.

User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Post by A_Jelly_Doughnut » Sun Oct 17, 2004 11:49 pm

Are the rows in the phpbb_themes and phpbb_themes_name tables in the database intact?
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish

Bug78
Registered User
Posts: 3
Joined: Sun Oct 17, 2004 9:17 pm
Location: NL
Contact:

Post by Bug78 » Mon Oct 18, 2004 1:57 pm

solved it.

the table: phpbb_config was dammaged (couldn`t find out how), replaced it from a backup and now everything is fine.

thanks for the advice!!

ReidarAxl
Registered User
Posts: 13
Joined: Wed Nov 24, 2004 1:56 pm

Post by ReidarAxl » Wed Nov 24, 2004 2:39 pm

I have the same problem, but where can I find phpbb_config?

User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Post by A_Jelly_Doughnut » Wed Nov 24, 2004 3:55 pm

You can view the config table with a tool like phpMyAdmin, which most web hosts provide. Look for it in your control panel ;)
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish

ReidarAxl
Registered User
Posts: 13
Joined: Wed Nov 24, 2004 1:56 pm

Post by ReidarAxl » Wed Nov 24, 2004 4:52 pm

Okey.. I've found it, but what i'm I looking for? I'm a newbee! :)

I don't know what wrong or how too fix it

Locked

Return to “2.0.x Support Forum”