Emails blocked due to X-priority header

Get help with installation and running phpBB 3.0.x here. Please do not post bug reports, feature requests, or MOD-related questions here.
Anti-Spam Guide
Forum rules
END OF SUPPORT: 1 January 2017 (announcement)
Locked
Ndr123
Registered User
Posts: 4
Joined: Tue Feb 09, 2016 4:41 pm

Emails blocked due to X-priority header

Post by Ndr123 »

The mails from my forum to the users stopped working after I moved my forum to another server. My board did not show any errors. I tryed all the wiki and doc answers out there (setting email package to "0", checking cron, comment flush cron, no queue.php etc etc) nothing worked.

But after contacting my host it seemed like my mails were blocked by their spam-check. Apparently the widespread used "SpamAssassin" gives penalty points for mails that have an "X-priority and X-MSMail-Priority" in the header. After deleting the "X-priority", "X-MSMail-Priority" and "X-MimeOLE" from the header in functions_messenger.php my mails were not blocked anymore.

Why do I seem the only one with this problem? Why is PHPBB sending these if spam-filters give penalty points for it? I have to say I also had penalty points because my domain has exactly 12 letters.
User avatar
Lumpy Burgertushie
Registered User
Posts: 67999
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Emails blocked due to X-priority header

Post by Lumpy Burgertushie »

sounds like a worthless host to me. If it was becoming standards for the hosting companies you would think we would have been hearing about it a lot.

have no idea what you are talking about with the penalty points for a domain with 12 letters.

what are penalty points? who is giving them to you?


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
User avatar
AmigoJack
Registered User
Posts: 5758
Joined: Tue Jun 15, 2010 11:33 am
Location: グリーン ヒル ゾーン
Contact:

Re: Emails blocked due to X-priority header

Post by AmigoJack »

Lumpy Burgertushie wrote:what are penalty points? who is giving them to you?
SpamAssassin reviews incoming e-mails and gives them points. For each spam-like indication an amout of points is given (high indicator? many points. low indicator? few points). The overall sum is then compared to a threshold: too many points? E-mail is spam.
Ndr123 wrote:Why is PHPBB sending these if spam-filters give penalty points for it?
SpamAssassin (that one, not all spam filters in general) shouldn't do that. And the original intention was that all the Microsoft clients did not respect the X-Priority header. Anyway, ask for a (or 2-3) full SpamAssassin reports on your e-mail(s) - then we can talk about how to solve this issue or even others as well.
Ndr123 wrote:I also had penalty points because my domain has exactly 12 letters
Issuing spamassassin domain 12 letters as search keywords I get Weirdest thing yet about spam filtering: be suspicious of the number 12 and more - really seems that 12 letter domains (only letters, without hyphens and numbers) are prone to send spam. I understand how you feel about that and I didn't knew about this either, but in long terms using a new domain will help you most - you will never manage to contact each possible recipient maintainer to whitelist your domain.
The worst thing about censorship is ███████████
Affin wrote:
Tue Nov 20, 2018 9:51 am
The problem is probably not my English but you do not want to understand correctly.
...
We will not come anybody anyway, nevertheless, it's best to shit this.
Ndr123
Registered User
Posts: 4
Joined: Tue Feb 09, 2016 4:41 pm

Re: Emails blocked due to X-priority header

Post by Ndr123 »

My score was just over 5 points and therefore labeled as spam. Most people wont have these problems because they stay under the 5 points even though they get penalized for the "X-priority". Our domain is 12 letters and therefore I got 2 more penalty points, pushing me over the limit. Although I am not 100% sure I am the only one with this problem. A quick search over the internet got me a lot of hits about email problems, were almost 50% is not solved yet.

The score mainly came from these items:
  • T_FROM_12LTRDOM: 2 points
  • STATIC_XPRIO_OLE: 2.7 points
  • XPRIO: 3.5 points
The highest problem is the "X-priority" after removing that I lost 3.5 penalty points. To be sure I also deleted the "X-MSMail-Priority" and "X-MimeOLE" so I would be as safe as possible. So I am not 100% sure that it would not allow "X-MSMail-Priority" and "X-MimeOLE" but I am sure that the "X-priority" is a problem in this spamfilter.

Changing a domain on a website/forum with thousands unique visitors every month is not an option as you can imagine.
User avatar
AmigoJack
Registered User
Posts: 5758
Joined: Tue Jun 15, 2010 11:33 am
Location: グリーン ヒル ゾーン
Contact:

Re: Emails blocked due to X-priority header

Post by AmigoJack »

Ndr123 wrote:STATIC_XPRIO_OLE: 2.7 points
XPRIO: 3.5 points
I wasn't aware SpamAssassin is even penalting the existence of those without checking their values (normal priority should be the same as no priority at all) - and I'm also unable to find a documentation about such a rule.

Since the only time phpBB ever actively sets something else than 3 (or Normal) is when using ACP mass e-mail and its priority setting, the best option is (as you did) to eliminate those three lines of code (containing X-Priority, X-MSMail-Priority and X-MimeOLE). Or to make them conditional, so those headers are only added when not having a normal priority.
The worst thing about censorship is ███████████
Affin wrote:
Tue Nov 20, 2018 9:51 am
The problem is probably not my English but you do not want to understand correctly.
...
We will not come anybody anyway, nevertheless, it's best to shit this.
Ndr123
Registered User
Posts: 4
Joined: Tue Feb 09, 2016 4:41 pm

Re: Emails blocked due to X-priority header

Post by Ndr123 »

I removed the lines as stated in my first post, wich did the trick for me. But I also found it strange that it happened. I am sure the prio was set as normal, so that was not the problem. It seems like SpamAssassin is just overacting. But I guess there is nothing to do about it. Maybe the host is using an old version of Spamassassin? Searching google on Xprio and SpamAssassing gives alot of the same problems.
Locked

Return to “[3.0.x] Support Forum”