Tried upgrading from 3.0.11 to 3.1 and can't update getting errors

Get help with installation and running phpBB 3.1.x here. Please do not post bug reports, feature requests, or extension related questions here.
Anti-Spam Guide
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: phpBB 3.1.x is at its End of Life stage and support will NOT be provided after July 1st, 2018.
menz01
Registered User
Posts: 113
Joined: Thu Oct 27, 2016 4:45 pm

Tried upgrading from 3.0.11 to 3.1 and can't update getting errors

Post by menz01 » Thu Oct 27, 2016 4:58 pm

Hello,
i am trying to upgrade from 3.0.11 to 3.1 and i followed the direction found https://www.phpbb.com/support/docs/en/3 ... /upgrade3/ but when i run the database upgrade link i am getting this:

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/content/27/7278227/html/forums/install/database_update.php on line 56

Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/content/27/7278227/html/forums/install/database_update.php on line 56

Parse error: syntax error, unexpected T_STRING in /home/content/27/7278227/html/forums/install/database_update.php on line 56

can anyone help me???

menz01
Registered User
Posts: 113
Joined: Thu Oct 27, 2016 4:45 pm

Re: Tried upgrading from 3.0.11 to 3.1 and can't update getting errors

Post by menz01 » Thu Oct 27, 2016 5:02 pm

so very sorry... i missed the part where posts need to be moderated and double posted.

the password part is now gone now it is just the errors i am getting

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49479
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Tried upgrading from 3.0.11 to 3.1 and can't update getting errors

Post by stevemaury » Thu Oct 27, 2016 5:07 pm

Paste here the exact text you are posting in the browser address box to call install/database_update.php. Also, a link to your board, please.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

menz01
Registered User
Posts: 113
Joined: Thu Oct 27, 2016 4:45 pm

Re: Tried upgrading from 3.0.11 to 3.1 and can't update getting errors

Post by menz01 » Thu Oct 27, 2016 5:08 pm


User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49479
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Tried upgrading from 3.0.11 to 3.1 and can't update getting errors

Post by stevemaury » Thu Oct 27, 2016 5:12 pm

Attach your /install/database_update.php file here, but first change the extension to .txt.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

menz01
Registered User
Posts: 113
Joined: Thu Oct 27, 2016 4:45 pm

Re: Tried upgrading from 3.0.11 to 3.1 and can't update getting errors

Post by menz01 » Thu Oct 27, 2016 5:15 pm

ok. here it is
Attachments
database_update.txt
(7.54 KiB) Downloaded 6 times

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49479
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Tried upgrading from 3.0.11 to 3.1 and can't update getting errors

Post by stevemaury » Thu Oct 27, 2016 6:21 pm

You are running php v 5.2.x. phpBB v 3.1.x requires at least php v 5.3.3, but less than 7.0. You should be able to upgrade in your host's cPanel.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

menz01
Registered User
Posts: 113
Joined: Thu Oct 27, 2016 4:45 pm

Re: Tried upgrading from 3.0.11 to 3.1 and can't update getting errors

Post by menz01 » Thu Oct 27, 2016 6:30 pm

my host will not upgrade unless i pay for an upgrade. do i have any other options? if not, i did take backups, can i just put my files back as is and will i be back to the way i was?

menz01
Registered User
Posts: 113
Joined: Thu Oct 27, 2016 4:45 pm

Re: Tried upgrading from 3.0.11 to 3.1 and can't update getting errors

Post by menz01 » Thu Oct 27, 2016 6:48 pm

OK I called my host back and was able to get them to upgrade me to 5.4. They said it will take 20 min to complete the upgrade. When they are done, do I just try the database update link again? Or do I have to do something else?

User avatar
canonknipser
Registered User
Posts: 1598
Joined: Thu Sep 08, 2011 4:16 am
Location: Germany
Name: Frank Jakobs
Contact:

Re: Tried upgrading from 3.0.11 to 3.1 and can't update getting errors

Post by canonknipser » Thu Oct 27, 2016 7:12 pm

menz01 wrote: Or do I have to do something else?
You should think about changing your host, because 5.4 had it's EOL more than 1 year ago, so there will be now more fixes for security. See the EOL-Table at php.net
Greetings, Frank
phpbb.de support team member
English is not my native language - no support via PM or mail
New arrival - Extensions and scripts for phpBB

menz01
Registered User
Posts: 113
Joined: Thu Oct 27, 2016 4:45 pm

Re: Tried upgrading from 3.0.11 to 3.1 and can't update getting errors

Post by menz01 » Thu Oct 27, 2016 7:43 pm

so my linux is now 5.4 and i tried the update database link again and now i am getting this:

Fatal error: Uncaught exception 'InvalidArgumentException' with message 'The file "services.yml" does not exist (in: ).' in /home/content/27/7278227/html/forums/vendor/symfony/config/Symfony/Component/Config/FileLocator.php:69 Stack trace: #0 /home/content/27/7278227/html/forums/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Loader/YamlFileLoader.php(41): Symfony\Component\Config\FileLocator->locate('services.yml') #1 /home/content/27/7278227/html/forums/phpbb/di/extension/core.php(53): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->load('services.yml') #2 /home/content/27/7278227/html/forums/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Compiler/MergeExtensionConfigurationPass.php(50): phpbb\di\extension\core->load(Array, Object(Symfony\Component\DependencyInjection\ContainerBuilder)) #3 /home/content/27/7278227/html/forums/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Compiler/Compiler.php(105): Symfony\Component\DependencyI in /home/content/27/7278227/html/forums/vendor/symfony/config/Symfony/Component/Config/FileLocator.php on line 69


can anyone assist please?

menz01
Registered User
Posts: 113
Joined: Thu Oct 27, 2016 4:45 pm

Re: Tried upgrading from 3.0.11 to 3.1 and can't update getting errors

Post by menz01 » Thu Oct 27, 2016 9:20 pm

so... i reversed my steps and restored my backups. i can access my forums again but now can no longer access my admin control panel. i get caught in a loop. i put in my creds and it accepts them (sort of) and i get to the page where it says i am granted access but at the top of the page are lot of scripts messages, then the page refreshes and tells me i cannot access the page because i was not granted access.

i do not know what to do now?? can anyone help?

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49479
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Tried upgrading from 3.0.11 to 3.1 and can't update getting errors

Post by stevemaury » Fri Oct 28, 2016 3:36 am

Why do we not try to get you upgraded instead of helping you revert to something that will be EOL in 2 months? Is the file the error message says is missing, in fact missing?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

menz01
Registered User
Posts: 113
Joined: Thu Oct 27, 2016 4:45 pm

Re: Tried upgrading from 3.0.11 to 3.1 and can't update getting errors

Post by menz01 » Fri Oct 28, 2016 12:49 pm

stevemaury wrote:Why do we not try to get you upgraded instead of helping you revert to something that will be EOL in 2 months? Is the file the error message says is missing, in fact missing?

i would really prefer to get up to date as you suggest. before i put back my backup files, i drilled down through the file system and found the file it says was missing. so i am really unsure what to do at this point?

menz01
Registered User
Posts: 113
Joined: Thu Oct 27, 2016 4:45 pm

Re: Tried upgrading from 3.0.11 to 3.1 and can't update getting errors

Post by menz01 » Fri Oct 28, 2016 4:13 pm

any suggestions before i try again?

Locked

Return to “[3.1.x] Support Forum”

Who is online

Users browsing this forum: No registered users and 7 guests