Discuss: phpBB 3.2 Rhea Feature Release Published

Do not post support requests, bug reports or feature requests. Discuss phpBB here. Non-phpBB related discussion goes in General Discussion!
Scam Warning
User avatar
P_I
Registered User
Posts: 930
Joined: Tue Mar 01, 2011 8:35 pm
Location: Calgary
Contact:

Re: Discuss: phpBB 3.2 Rhea Feature Release Published

Post by P_I » Sat Jan 28, 2017 3:43 pm

Marc wrote:
Sat Jan 07, 2017 8:05 pm
Discuss the announcement here.
Marc, might I suggest one addition/improvement to the Features of phpBB® page.

The Launch page hightlights Improved Notifications, but the Features - Notifications section doesn't indicate anything new for 3.2, which seems somewhat contradictory.

I think there at least two things worth mentioning.
  1. The improved visual of notifications
    Improved visual notifications.PNG
    Improved visual notifications.PNG (1.94 KiB) Viewed 1884 times
  2. resolution of [PHPBB3-11967] Notification settings are not respected
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams

User avatar
P_I
Registered User
Posts: 930
Joined: Tue Mar 01, 2011 8:35 pm
Location: Calgary
Contact:

Re: Discuss: phpBB 3.2 Rhea Feature Release Published

Post by P_I » Sun Jan 29, 2017 3:45 pm

Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams

Albert Wiersch
Registered User
Posts: 145
Joined: Sat Dec 11, 2004 6:00 pm
Location: Dallas, TX
Name: Albert Wiersch
Contact:

Re: Discuss: phpBB 3.2 Rhea Feature Release Published

Post by Albert Wiersch » Wed Feb 01, 2017 8:08 pm

Happy to hear about the new release!

I'm still running 3.1.9.

Is it "safe" to go ahead and upgrade to 3.2 or should I wait until 3.2.1? I usually like to make sure they get more bugs out. :D

Also really looking forward to being able to upgrade to PHP 7 which I will be able to do with 3.2.

Happy_Dan
Registered User
Posts: 23
Joined: Thu Apr 23, 2015 11:58 pm

Re: Discuss: phpBB 3.2 Rhea Feature Release Published

Post by Happy_Dan » Thu Feb 02, 2017 4:25 pm

Greetings. I am not really technically inclined and I use a hosting service. I run a very small, private board.

I asked the hosting service about the requirements to install and this was his answer.

Hi Dan,
These are our current versions. We may update within the year, but upgrading 5.3 to a newer version is a bit of a jump that may affect current customers

PHP 5.3.3
mysql Ver 14.14 Distrib 5.1.73
apache 2.2.16


Does this prevent me from upgrading from 3.1.10 to 3.2.0 and what if I don't upgrade?
I don't want to miss any security updates but I don't need any new features either.
Just looking for advice from those of you in the know. I am a car guy not a software guy. ;)

Thanks
Dan

User avatar
JimA
Community Team Leader
Community Team Leader
Posts: 7631
Joined: Thu Jul 31, 2008 5:54 am
Location: The Netherlands
Name: Jim Mossing Holsteyn
Contact:

Re: Discuss: phpBB 3.2 Rhea Feature Release Published

Post by JimA » Thu Feb 02, 2017 4:42 pm

With that PHP version, you won't be able to upgrade to phpBB 3.2 as it requires a minimum PHP version of at least 5.4.0. However, staying at 3.1 is not a problem for now, it will still be receiving security updates until at least the end of this year, see this schedule for more information on that. :)

I do want to add a note of caution that while you're in the clear with security support for phpBB, PHP 5.3 (which your host is still running) has long gone beyond its own expiration date for security support.
Image Jim Mossing Holsteyn - Community Team Leader
Knowledge Base | Documentation | Board rules

If you're having any questions about the rules/customs of this website, feel free to drop me a PM.

User avatar
janus_zonstraal
Registered User
Posts: 3442
Joined: Sat Aug 30, 2014 1:30 pm

Re: Discuss: phpBB 3.2 Rhea Feature Release Published

Post by janus_zonstraal » Thu Feb 02, 2017 4:46 pm

php5.3 was released
5.3.0

Released: 30 June 2009
See https://secure.php.net/releases/

I think you better change your hosting ;)
Sorry! My English is bat ;) !!!

User avatar
P_I
Registered User
Posts: 930
Joined: Tue Mar 01, 2011 8:35 pm
Location: Calgary
Contact:

Re: Discuss: phpBB 3.2 Rhea Feature Release Published

Post by P_I » Thu Feb 02, 2017 4:51 pm

Happy_Dan wrote:
Thu Feb 02, 2017 4:25 pm
Hi Dan,
These are our current versions. We may update within the year, but upgrading 5.3 to a newer version is a bit of a jump that may affect current customers
I posted this elsewhere to answer someone else's query about the same PHP version issue.
P_I wrote:
Tue Jan 31, 2017 3:46 pm
I'd strongly recommend pushing back with your hosting provider. Per PHP: Supported Versions and PHP: Unsupported Branches, PHP 5.3.x reached end of life in August 2014, 2 years, 5 months ago!

phpBB 3.2's minimum requirement for PHP 5.6 puts it just inside the "Security fixes only" window of PHP versions.
Sorry, if you hosting provider isn't willing to provide a supported version of PHP, then I'd suggest it's time to consider changing hosting providers to someone who will.
Happy_Dan wrote:
Thu Feb 02, 2017 4:25 pm
Does this prevent me from upgrading from 3.1.10 to 3.2.0 and what if I don't upgrade?
Your current PHP version doesn't meeting the phpBB 3.2 minimum requirements so you cannot upgrade. Not to worry, phpBB 3.1 is still a supported release, so you don't need to upgrade right now.
Marc wrote:
Tue Jan 17, 2017 1:22 pm
I'd just like to point out that this has been further extended as follows:
  • End of Maintenance (EOM): June 2017 (June 30th 2017)
  • End of Life (EOL): December 2017 (December 31st 2017)
Please also take a look at our Release process page for an explanation on the meaning of End of Maintenance (EOM) and End of Life (EOL).

Thank you,
The phpBB Team
Added: I see two people typed faster than I. :lol:
Last edited by P_I on Thu Feb 02, 2017 4:52 pm, edited 1 time in total.
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams

Happy_Dan
Registered User
Posts: 23
Joined: Thu Apr 23, 2015 11:58 pm

Re: Discuss: phpBB 3.2 Rhea Feature Release Published

Post by Happy_Dan » Thu Feb 02, 2017 4:51 pm

Thank you kindly.

koraldon
Registered User
Posts: 509
Joined: Sat Jun 30, 2007 12:42 pm

Re: Discuss: phpBB 3.2 Rhea Feature Release Published

Post by koraldon » Thu Feb 02, 2017 6:39 pm

In any case 5.3.3 is old and not secure, I would recommend the host to update to the last version of 5.3. ASAP...

Happy_Dan
Registered User
Posts: 23
Joined: Thu Apr 23, 2015 11:58 pm

Re: Discuss: phpBB 3.2 Rhea Feature Release Published

Post by Happy_Dan » Thu Feb 02, 2017 6:44 pm

I am suggesting it and also exploring different host possibilities. Thanks for the input.

Albert Wiersch
Registered User
Posts: 145
Joined: Sat Dec 11, 2004 6:00 pm
Location: Dallas, TX
Name: Albert Wiersch
Contact:

Re: Discuss: phpBB 3.2 Rhea Feature Release Published

Post by Albert Wiersch » Thu Feb 09, 2017 4:20 pm

Albert Wiersch wrote:
Wed Feb 01, 2017 8:08 pm
Happy to hear about the new release!

I'm still running 3.1.9.

Is it "safe" to go ahead and upgrade to 3.2 or should I wait until 3.2.1? I usually like to make sure they get more bugs out. :D

Also really looking forward to being able to upgrade to PHP 7 which I will be able to do with 3.2.
OK, I bit the bullet and upgraded to 3.2.0 from 3.1.9 and from PHP 5.6 to PHP 7.1.1. It went smoothly. No major issues.

I did have to make this change:
viewtopic.php?f=556&t=2399941#p14598836

And re-edit some CSS to get my logo back but no big deal.

I'm glad to be running PHP 7.x now due to the significant performance increases over 5.6 but it's hard to tell any speed difference since my server was already overpowered... now it's just more overpowered. :)

So I'm sending a 'thanks' to the phpBB developers. Thanks!

UPDATE: Is there a way to donate to phpBB to support future development? I looked and couldn't find one.

User avatar
MGadAllah
Registered User
Posts: 1055
Joined: Sat Sep 01, 2007 6:50 pm
Location: EGYPT - Cairo
Name: Mohamed GadAllah
Contact:

Re: Discuss: phpBB 3.2 Rhea Feature Release Published

Post by MGadAllah » Thu Feb 23, 2017 6:50 am

Very nice indeed!
Does https://www.phpbb.com/community/ running it as well?
Would you like to know more about ISLAM ?

User avatar
JimA
Community Team Leader
Community Team Leader
Posts: 7631
Joined: Thu Jul 31, 2008 5:54 am
Location: The Netherlands
Name: Jim Mossing Holsteyn
Contact:

Re: Discuss: phpBB 3.2 Rhea Feature Release Published

Post by JimA » Thu Feb 23, 2017 9:54 am

MGadAllah wrote:
Thu Feb 23, 2017 6:50 am
Very nice indeed!
Does https://www.phpbb.com/community/ running it as well?
We certainly are. :)
This board is always running the latest stable version of phpBB.
Image Jim Mossing Holsteyn - Community Team Leader
Knowledge Base | Documentation | Board rules

If you're having any questions about the rules/customs of this website, feel free to drop me a PM.

User avatar
MGadAllah
Registered User
Posts: 1055
Joined: Sat Sep 01, 2007 6:50 pm
Location: EGYPT - Cairo
Name: Mohamed GadAllah
Contact:

Re: Discuss: phpBB 3.2 Rhea Feature Release Published

Post by MGadAllah » Thu Feb 23, 2017 10:11 am

JimA wrote:
Thu Feb 23, 2017 9:54 am
MGadAllah wrote:
Thu Feb 23, 2017 6:50 am
Very nice indeed!
Does https://www.phpbb.com/community/ running it as well?
We certainly are. :)
This board is always running the latest stable version of phpBB.
:geek: :P :D
Would you like to know more about ISLAM ?

TomFranssen
Registered User
Posts: 14
Joined: Sun Feb 26, 2017 7:53 am

Re: Discuss: phpBB 3.2 Rhea Feature Release Published

Post by TomFranssen » Thu Mar 09, 2017 9:09 pm

We are almost releasing this upgrade to our forum from 3.0.7-PL1 to 3.2.0.
Yes it was a long time since the last upgrade I know :-)

There is one nagging issue that is bugging us when trying to install an extension, we get these errors:
Something went wrong during the request and an exception was thrown. The changes made before the error occurred were reversed to the best of our abilities, but you should check the board for errors.
A required module does not exist: ACP_PAGES


This occurs when trying to install multiple addons, see screen shots:
http://prnt.sc/ei0nc7
&
http://prnt.sc/ei0nib

Does anyone have an idea what this could be? It's driving us nut's.
Last edited by TomFranssen on Thu Mar 09, 2017 9:12 pm, edited 1 time in total.

Post Reply

Return to “phpBB Discussion”