3.2 upgrade problem

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
whatnot
Registered User
Posts: 12
Joined: Wed Jul 09, 2014 3:46 am

3.2 upgrade problem

Post by whatnot »

I updated from 3.1 to 3.2 and everything seems to be working except the notifications at the top of the screen. If clicking on any new notifications, I get this error. Usually I can fix most problems using the search here but not sure what I did this time.

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/vendor/symfony/dependency-injection/ContainerBuilder.php on line 445: strtolower() expects parameter 1 to be string, array given

Fatal error: Uncaught exception 'Symfony\Component\DependencyInjection\Exception\ServiceNotFoundException' with message 'You have requested a non-existent service "".' in /home/boilerforums/outdoorboilerforums.com/forum/vendor/symfony/dependency-injection/ContainerBuilder.php:816 

Stack trace: 
#0 /home/boilerforums/outdoorboilerforums.com/forum/vendor/symfony/dependency-injection/ContainerBuilder.php(456): Symfony\Component\DependencyInjection\ContainerBuilder->getDefinition(NULL) 
#1 /home/boilerforums/outdoorboilerforums.com/forum/phpbb/notification/manager.php(881): Symfony\Component\DependencyInjection\ContainerBuilder->get(Array) 
#2 /home/boilerforums/outdoorboilerforums.com/forum/phpbb/notification/manager.php(870): phpbb\notification\manager->load_object(Array) 
#3 /home/boilerforums/outdoorboilerforums.com/forum/phpbb/notification/manager.php(115): phpbb\notification\manager->get_method_class(Array) 
#4 /home/boilerforums/outdoorboilerforums.com/forum/index.php(49): phpbb\notification\manager->load_notifications(Array in /home/boilerforums/outdoorboilerforums.com/forum/vendor/symfony/dependency-injection/ContainerBuilder.php on line 816

whatnot
Registered User
Posts: 12
Joined: Wed Jul 09, 2014 3:46 am

Re: 3.2 upgrade problem

Post by whatnot »

Any ideas on what is the problem?

User avatar
Lumpy Burgertushie
Registered User
Posts: 67210
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: 3.2 upgrade problem

Post by Lumpy Burgertushie »

what upgrade method did you use?

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?

whatnot
Registered User
Posts: 12
Joined: Wed Jul 09, 2014 3:46 am

Re: 3.2 upgrade problem

Post by whatnot »

I tried to follow the directions here: https://www.phpbb.com/support/docs/en/3 ... upgrade31/

User avatar
P_I
Registered User
Posts: 1029
Joined: Tue Mar 01, 2011 8:35 pm
Location: Calgary
Contact:

Re: 3.2 upgrade problem

Post by P_I »

Are you perhaps using the Board Rules extension? If so, make sure you've updated to the phpBB 3.2.0 compatible version (v2.0.0).

I was having problems with Notification settings that got resolved with updating the Board Rules extension.
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams

whatnot
Registered User
Posts: 12
Joined: Wed Jul 09, 2014 3:46 am

Re: 3.2 upgrade problem

Post by whatnot »

No, not using that extension.
I tried disabling all the extensions and it didn't make a difference.

whatnot
Registered User
Posts: 12
Joined: Wed Jul 09, 2014 3:46 am

Re: 3.2 upgrade problem

Post by whatnot »

I had Filezilla set to auto instead of binary. Would that have screwed something up?

User avatar
3Di
Former Team Member
Posts: 14794
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: 3.2 upgrade problem

Post by 3Di »

whatnot wrote:
Mon Feb 06, 2017 11:43 pm
I had Filezilla set to auto instead of binary. Would that have screwed something up?
Filezilla must be sat to binary, old school. Yes, could be.

WinSCP for the winner.. :)
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
:studio_microphone: Premium extensions @ The Studio

whatnot
Registered User
Posts: 12
Joined: Wed Jul 09, 2014 3:46 am

Re: 3.2 upgrade problem

Post by whatnot »

If that did cause the issue, will just re-uploading the new files from the upgrade fix it?

User avatar
Lumpy Burgertushie
Registered User
Posts: 67210
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: 3.2 upgrade problem

Post by Lumpy Burgertushie »

the main problem with filezilla is that it treats files with no extension as ascii instead of binary.

the main problem with that is when transferring all the attachment files in the "files" folder. it will corrupt any and all images if transferred in ascii instead of binary.

therefore, you have to tweak that specific setting in filezilla.

having said all that, it is best to just set any ftp program to upload all files in binary. in the old days it was necessary to transfer text based files in ascii but now days you can transfer everything in binary without problem.



robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?

whatnot
Registered User
Posts: 12
Joined: Wed Jul 09, 2014 3:46 am

Re: 3.2 upgrade problem

Post by whatnot »

I finally got it fixed. It was a filezilla setting that caused it.

Post Reply

Return to “[3.2.x] Support Forum”