ERR_SSL_PROTOCOL_ERROR

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
hughesb6
Registered User
Posts: 9
Joined: Mon Jan 30, 2017 6:46 pm

ERR_SSL_PROTOCOL_ERROR

Post by hughesb6 »

I got the ssl going yesterday with the help of some kind folks here, but now the I am getting this error message when trying to login. Does anyone know what has happened?

"This site can’t provide a secure connection

www.bidshaul.com sent an invalid response.
Try running Windows Network Diagnostics.
ERR_SSL_PROTOCOL_ERROR"
User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 52783
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve

Re: ERR_SSL_PROTOCOL_ERROR

Post by stevemaury »

That is a server error so perhaps your host knows.
I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)
hughesb6
Registered User
Posts: 9
Joined: Mon Jan 30, 2017 6:46 pm

Re: ERR_SSL_PROTOCOL_ERROR

Post by hughesb6 »

I thought about that, but I am only having the issue with the phpbb forums, and not with the rest of the hosted site that has the same SSL.
hughesb6
Registered User
Posts: 9
Joined: Mon Jan 30, 2017 6:46 pm

Re: ERR_SSL_PROTOCOL_ERROR

Post by hughesb6 »

I think I just stumbled onto something. I removed the redirect from the root htaccess but left it in the forum htaccess. Now everything show secure and is working. I wonder if the 2 were conflicting with each other some how. We will see and I will report back as to if that did in fact result in a permanent fix. Thank you for getting my brain thinking in that direction.
hughesb6
Registered User
Posts: 9
Joined: Mon Jan 30, 2017 6:46 pm

Re: ERR_SSL_PROTOCOL_ERROR

Post by hughesb6 »

nope that didn't do it. It is giving the error message again, and I cannot get into the ACP. Below is what the htaccess looks like.

Code: Select all

<IfModule mod_rewrite.c>
RewriteEngine on

#
# Uncomment the statement below if URL rewriting doesn't
# work properly. If you installed phpBB in a subdirectory
# of your site, properly set the argument for the statement.
# e.g.: if your domain is test.com and you installed phpBB
# in http://www.test.com/phpBB/index.php you have to set
# the statement RewriteBase /phpBB/
#
#RewriteBase /

#
# Uncomment the statement below if you want to make use of
# HTTP authentication and it does not already work.
# This could be required if you are for example using PHP via Apache CGI.
#
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
#
# The following 3 lines will rewrite URLs passed through the front controller
# to not require app.php in the actual URL. In other words, a controller is
# by default accessed at /app.php/my/controller, but can also be accessed at
# /my/controller
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ app.php [QSA,L]

#
# If symbolic links are not already being followed,
# uncomment the line below.
# http://anothersysadmin.wordpress.com/2008/06/10/mod_rewrite-forbidden-403-with-apache-228/
#
#Options +FollowSymLinks
</IfModule>

# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_host.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
	<IfVersion < 2.4>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfVersion>
	<IfVersion >= 2.4>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfVersion>
</IfModule>
<IfModule !mod_version.c>
	<IfModule !mod_authz_core.c>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfModule>
	<IfModule mod_authz_core.c>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfModule>
</IfModule>
Last edited by JimA on Sun Feb 26, 2017 10:20 pm, edited 1 time in total.
Reason: Code tags added for readibility reasons. Please use those when posting large code segments.
balooski
Registered User
Posts: 4
Joined: Tue Apr 25, 2017 12:00 pm

Re: ERR_SSL_PROTOCOL_ERROR

Post by balooski »

Same error here. Any help? Suport Template below:

Support Request Template
What version of phpBB are you using? phpBB 3.2.0
What is your board's URL? http://soliens.com.br/forum
Who do you host your board with? godaddy shared hosting linux cpanel
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What extensions do you have installed? AddUser - https://github.com/phpbbmodders/phpBB-3.1-ext-adduser 1.0.4
What styles do you currently have installed? flatstyle green
What language(s) is your board currently using? PT-BR
Which database type/version are you using? MySQL 5
What is your level of experience? New to PHP and phpBB
What username can be used to view this issue? phpsupport
What password can be used to view this issue? phpbbhelp
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Converted from HTTP to HTTPS
Please describe your problem. Hosting with godaddy.com added ssl from letsencrypt.com to the domains www.soliens.com.br and soliens.com.br. Ssl working across website. Only user authentication broken. Following error presented when trying to log in:

"This site can???t provide a secure connection
soliens.com.br sent an invalid response.
ERR_SSL_PROTOCOL_ERROR"
Generated by SRT Generator
balooski
Registered User
Posts: 4
Joined: Tue Apr 25, 2017 12:00 pm

Re: ERR_SSL_PROTOCOL_ERROR

Post by balooski »

So, my website went down yesterday, and I thought it might be the forum somehow, and decided to login with the suport credentials mentioned above. It was only then I noticed the credit line was not appearing for normal users. When I log in to my admin account, it shows up normally. I am aware that we only get support if the credit line is present. I shall make it work, and I'm sorry for the inconvenience. This is my first forum. Still learning. Thank you!
balooski
Registered User
Posts: 4
Joined: Tue Apr 25, 2017 12:00 pm

Re: ERR_SSL_PROTOCOL_ERROR

Post by balooski »

As an update for future reference. I solved the problem by changing the server port to 443 instead of 80.

Login to the ACP. If you get the error, just replace the ":80" after the domain with ":443"

Go to server settings, and in server port, replace 80 with 443. That should do it.
hypersaw
Registered User
Posts: 57
Joined: Tue May 03, 2016 12:08 pm

Re: ERR_SSL_PROTOCOL_ERROR

Post by hypersaw »

balooski wrote: Mon May 15, 2017 2:05 pm As an update for future reference. I solved the problem by changing the server port to 443 instead of 80.

Login to the ACP. If you get the error, just replace the ":80" after the domain with ":443"

Go to server settings, and in server port, replace 80 with 443. That should do it.
Thank you very much. This helped me!

Return to “[3.2.x] Support Forum”