Enable Super Globals on phpBB 3.2

Need some custom code changes to the phpBB core simple enough that you feel doesn't require an extension? Then post your request here so that community members can provide some assistance.

NOTE: NO OFFICIAL SUPPORT IS PROVIDED IN THIS SUB-FORUM
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

NOTE: NO OFFICIAL SUPPORT IS PROVIDED IN THIS SUB-FORUM
Post Reply
TPW
Registered User
Posts: 12
Joined: Sun Jul 30, 2017 9:15 pm

Enable Super Globals on phpBB 3.2

Post by TPW »

I am trying to use $_SERVER in a PHP file which is used by my phpBB forum. Because of the limitations of my setup, I need to enable superglobals to resolve this message but I cannot figure out how to do it with phpBB 3.2. With phpBB 3.1, I was able to change the value of "core.disable_super_globals" in the "/config/default/container/parameters.yml" file, but my attempt at doing that here does not seem to be working.

Code: Select all

Illegal use of $_SERVER. You must use the request class to access input data. Found in C:\inetpub\wwwroot\aphpfile.php on line 21. This error message was generated by deactivated_super_global.

TPW
Registered User
Posts: 12
Joined: Sun Jul 30, 2017 9:15 pm

Re: Enable Super Globals on phpBB 3.2

Post by TPW »

I figured out the solution to this on my own. Purging the cache after changing the setting solved the issue. I do not remember doing that the last time I needed to enable super globals, but I suppose I did.

Post Reply

Return to “phpBB Custom Coding”