SOLVED viewtopic.php blank after 3.0 upgrade

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
mb-fl
Registered User
Posts: 21
Joined: Wed Mar 07, 2018 2:33 pm

SOLVED viewtopic.php blank after 3.0 upgrade

Post by mb-fl » Wed Mar 07, 2018 3:40 pm

I upgraded our board from 3.0.14 to 3.1.12 and to 3.2.2. In both cases, the board appears functional: You can view all the forums and the topic lists and the ACP works perfectly. However, clicking on any topic results in a blank page. Inspection using curl shows "Content-Length: 0". I put in several debug statements throughout the PHP file, and those get printed, but the topic never shows up. It's like the templating system is not printing the template out. I tried poking at the output buffering code to no avail.

There are no mods and no styles installed. I've run the STK before to clean up the database. MariaDB 5.5+, PHP 5.4+ (json and xml installed)

I saved the config.php, files/, images/, and store/ when upgrading. Used the full package. Ran the database updater (no errors) and everything works fine... except for viewtopic.php.

Thing's I've tried or checked:
  • Checking the following in php.ini:
    • mbstring.http_output set to pass
    • output_buffering turned on, off, or set to 4096
    • zlib.output_compression on or off
    • output_handler set to empty
  • Turned mod_deflate on and off in Apache
  • Checked the PHP error log, set it to E_ALL (no errors)
  • Checked the phpBB error log
  • Changed the acm_type in config.php from 'file' to 'phpbb\\cache\\driver\\file'
  • Flipped DEBUG and DEBUG_EXTRA on
  • Nuked the cache from the ACP and from the filesystem
  • Installed another supported style (prosilver SE)
  • Turning SELinux to permissive, setting the proper context
  • Setting permissions to 777 or just rwx to the apache user/group
I'm out of things to search for and try, so I thought I'd create an account and post.
Last edited by mb-fl on Fri Mar 16, 2018 11:23 am, edited 1 time in total.

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50488
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: viewtopic.php blank after 3.0 upgrade

Post by stevemaury » Wed Mar 07, 2018 5:46 pm

What instructions did you follow to do these upgrades?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

mb-fl
Registered User
Posts: 21
Joined: Wed Mar 07, 2018 2:33 pm

Re: viewtopic.php blank after 3.0 upgrade

Post by mb-fl » Wed Mar 07, 2018 5:57 pm


User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50488
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: viewtopic.php blank after 3.0 upgrade

Post by stevemaury » Wed Mar 07, 2018 6:19 pm

Well, that can't be right, because there is nothing in there about going to 3.1.x first. So what instructions did you follow for each upgrade?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

mb-fl
Registered User
Posts: 21
Joined: Wed Mar 07, 2018 2:33 pm

Re: viewtopic.php blank after 3.0 upgrade

Post by mb-fl » Wed Mar 07, 2018 7:58 pm


mb-fl
Registered User
Posts: 21
Joined: Wed Mar 07, 2018 2:33 pm

Re: viewtopic.php blank after 3.0 upgrade

Post by mb-fl » Fri Mar 09, 2018 2:38 pm

Nobody has any other ideas I should try?

User avatar
canonknipser
Registered User
Posts: 1995
Joined: Thu Sep 08, 2011 4:16 am
Location: Germany
Name: Frank Jakobs
Contact:

Re: viewtopic.php blank after 3.0 upgrade

Post by canonknipser » Fri Mar 09, 2018 2:56 pm

Did you check your server's error log? A "blank page" often is the result of a suppressed runtime error when your servers delivers nothing:
mb-fl wrote:
Wed Mar 07, 2018 3:40 pm
Content-Length: 0
.
Greetings, Frank
phpbb.de support team member
English is not my native language - no support via PM or mail
New arrival - Extensions and scripts for phpBB

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21127
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: viewtopic.php blank after 3.0 upgrade

Post by Mick » Fri Mar 09, 2018 2:59 pm

"The more connected we get the more alone we become" - Kyle Broflovski

mb-fl
Registered User
Posts: 21
Joined: Wed Mar 07, 2018 2:33 pm

Re: viewtopic.php blank after 3.0 upgrade

Post by mb-fl » Fri Mar 09, 2018 3:00 pm

I did all those things too.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21127
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: viewtopic.php blank after 3.0 upgrade

Post by Mick » Fri Mar 09, 2018 3:12 pm

Please fill out the Support Request Template and post it back here to enable us to assist you better.
"The more connected we get the more alone we become" - Kyle Broflovski

mb-fl
Registered User
Posts: 21
Joined: Wed Mar 07, 2018 2:33 pm

Re: viewtopic.php blank after 3.0 upgrade

Post by mb-fl » Sat Mar 10, 2018 4:27 pm

As you wish...

Support Request Template
What version of phpBB are you using? phpBB 3.1.12
What is your board's URL?
Who do you host your board with? self hosted
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? No
What version of phpBB3 did you update from? phpBB 3.0.14
What styles do you currently have installed? subsilver
What language(s) is your board currently using? en
Which database type/version are you using? MariaDB
What is your level of experience? Experienced with PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Point update for 3.0
Please describe your problem. viewtopic.php returns a zero-length page, everything else appears to work, including the ACP
Generated by SRT Generator

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50488
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: viewtopic.php blank after 3.0 upgrade

Post by stevemaury » Sat Mar 10, 2018 4:32 pm

Can we get a link to your board, please?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

mb-fl
Registered User
Posts: 21
Joined: Wed Mar 07, 2018 2:33 pm

Re: viewtopic.php blank after 3.0 upgrade

Post by mb-fl » Sat Mar 10, 2018 4:38 pm

  • I don't feel comfortable linking this support problem to the board
  • The board is not in the "broken" upgrade state at the moment (it's still at 3.0)
  • It's not clear to me how this helps

User avatar
canonknipser
Registered User
Posts: 1995
Joined: Thu Sep 08, 2011 4:16 am
Location: Germany
Name: Frank Jakobs
Contact:

Re: viewtopic.php blank after 3.0 upgrade

Post by canonknipser » Sat Mar 10, 2018 6:47 pm

quoting myself ...
canonknipser wrote:
Fri Mar 09, 2018 2:56 pm
Did you check your server's error log? A "blank page" often is the result of a suppressed runtime error when your servers delivers nothing:
mb-fl wrote:
Wed Mar 07, 2018 3:40 pm
Content-Length: 0
.
Greetings, Frank
phpbb.de support team member
English is not my native language - no support via PM or mail
New arrival - Extensions and scripts for phpBB

mb-fl
Registered User
Posts: 21
Joined: Wed Mar 07, 2018 2:33 pm

Re: viewtopic.php blank after 3.0 upgrade

Post by mb-fl » Sat Mar 10, 2018 6:55 pm

Yes
mb-fl wrote:
Wed Mar 07, 2018 3:40 pm

[*]Checked the PHP error log, set it to E_ALL (no errors)

Post Reply

Return to “[3.2.x] Support Forum”