No new post button?

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
mintaka
Registered User
Posts: 33
Joined: Sat Aug 04, 2018 6:05 pm

No new post button?

Post by mintaka » Mon Aug 13, 2018 6:17 am

I just installed a new theme and there's no button for creating a new post in any of the forums. The language is set to the default British English, and group/forum permissions are set at full access for the admin group. So I'm not sure where the problem lies. Any ideas?

User avatar
david63
Jr. Extension Validator
Posts: 14724
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: No new post button?

Post by david63 » Mon Aug 13, 2018 6:42 am

Is the button there in the default prosilver style? If it is then there is a problem with your style and you should seek support at the place where you got the style. If the button is not there in prosilver then you probably have a problem with your permissions.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

mintaka
Registered User
Posts: 33
Joined: Sat Aug 04, 2018 6:05 pm

Re: No new post button?

Post by mintaka » Sun Aug 19, 2018 11:43 am

Button's not there with the default style, any idea what permissions I should look at?

User avatar
david63
Jr. Extension Validator
Posts: 14724
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: No new post button?

Post by david63 » Sun Aug 19, 2018 12:06 pm

Probably "Can start new topics"
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49556
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: No new post button?

Post by stevemaury » Sun Aug 19, 2018 4:20 pm

Run the Forum-based Permissions MASK against your username for the problem forum and screenshot the output here.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

mintaka
Registered User
Posts: 33
Joined: Sat Aug 04, 2018 6:05 pm

Re: No new post button?

Post by mintaka » Sun Aug 19, 2018 4:28 pm

I checked with permissions > view forum based permissions > my username and it looks like there's a lot of things that don't line up with the permissions I've set. When I set permissions, I have the full access option selected for all forums, but when I'm viewing my username under forum based permissions, there's about a 60% discrepancy. The admin usergroup is shown as having all permissions but my admin account, which is in that usergroup, does not. How can I change things to match up?

janus_zonstraal
Registered User
Posts: 2667
Joined: Sat Aug 30, 2014 1:30 pm

Re: No new post button?

Post by janus_zonstraal » Sun Aug 19, 2018 4:35 pm

Don't work with "usernames" set the permissions for the groups, otherwise you can't remember it with 3000 members.
Sorry! My English is bat ;) !!!

mintaka
Registered User
Posts: 33
Joined: Sat Aug 04, 2018 6:05 pm

Re: No new post button?

Post by mintaka » Sun Aug 19, 2018 4:44 pm

janus_zonstraal wrote:
Sun Aug 19, 2018 4:35 pm
Don't work with "usernames" set the permissions for the groups, otherwise you can't remember it with 3000 members.
I did set the permissions for the groups, but the permissions for the username doesn't match the permissions for the groups.

User avatar
Lumpy Burgertushie
Registered User
Posts: 65031
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: No new post button?

Post by Lumpy Burgertushie » Sun Aug 19, 2018 4:45 pm

post a screenshot of those permissions.

robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

mintaka
Registered User
Posts: 33
Joined: Sat Aug 04, 2018 6:05 pm

Re: No new post button?

Post by mintaka » Sun Aug 19, 2018 4:53 pm

This is what the permissions for my account looks like, across the board. The admin usergroup has all permissions everywhere as shown here.

janus_zonstraal
Registered User
Posts: 2667
Joined: Sat Aug 30, 2014 1:30 pm

Re: No new post button?

Post by janus_zonstraal » Sun Aug 19, 2018 5:12 pm

Click on "post" under your username, not "actions"

Than click on the symbol on the left side "0=>"
Sorry! My English is bat ;) !!!

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49556
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: No new post button?

Post by stevemaury » Sun Aug 19, 2018 5:32 pm

You are using the MASK, correct? Not just looking at the permissions screen?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

mintaka
Registered User
Posts: 33
Joined: Sat Aug 04, 2018 6:05 pm

Re: No new post button?

Post by mintaka » Sun Aug 19, 2018 5:39 pm

janus_zonstraal wrote:
Sun Aug 19, 2018 5:12 pm
Click on "post" under your username, not "actions"

Than click on the symbol on the left side "0=>"
It says "The user’s permission for this forum is NO and the total value was set to NO so it defaults to NEVER." Where would I go to change those permissions?

stevemaury wrote:
Sun Aug 19, 2018 5:32 pm
You are using the MASK, correct? Not just looking at the permissions screen?
I am not sure, to be honest. I've never done this before and it seems that php seems to get me turned around easily.

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49556
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: No new post button?

Post by stevemaury » Sun Aug 19, 2018 5:43 pm

STOP using user permissions. For every user to whom you have given user permissions, go back and set the user permissions to All No. Then give the Registered users GROUP a Standard access permission role for all forums.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

mintaka
Registered User
Posts: 33
Joined: Sat Aug 04, 2018 6:05 pm

Re: No new post button?

Post by mintaka » Sun Aug 19, 2018 5:58 pm

stevemaury wrote:
Sun Aug 19, 2018 5:43 pm
STOP using user permissions. For every user to whom you have given user permissions, go back and set the user permissions to All No. Then give the Registered users GROUP a Standard access permission role for all forums.
The group already has access permissions. But the group permissions aren't affecting the account in that group.

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: Lumpy Burgertushie, Michael235, Mixlight and 121 guests