Converting vb 4.2.5 to phpbb, problem in start and special characters

Converting from other board software? Good decision! Need help? Have a question about a convertor? Wish to offer a convertor package? Post here.
Post Reply
wonder_wonder
Registered User
Posts: 24
Joined: Thu Feb 16, 2017 2:52 pm

Converting vb 4.2.5 to phpbb, problem in start and special characters

Post by wonder_wonder » Mon Dec 17, 2018 6:29 pm

Hello.
I have a vbulletin 4.2.5 and I want to convert to phpbb,
I search in the forum and the most current converter that I have found has been this: viewtopic.php?p=13252438#p13252438

After read this post and others, my first step was install phpbb 3.0.11 because, this converter its for phpbb 3.0.11 (if all finish good, then upgrade phpbb).

In the firsts moments, I was differents error, contact with my host, and reconfigure apache and php for solved this and have more resources.

Start the conversion and after a 2 or 3 or 4 minutes I have a Error 504 Gateway Timeout.
I try with differents configurations (I have a VPS host) but always, the first step in the conversion is this, error 504 Gateway Timeout.
If reload page or press enter, again, after 2,3 or 4 minutes again I have the same error.

In some times, before made some changes in host, I have this error:

Code: Select all

General Error
SQL ERROR [ mysqli ]

Table 'mydatabase_php30.userconv' doesn't exist [1146]

SQL

INSERT INTO userconv (user_id, username_clean) VALUES ('9007', 'pizzza_25'), ('9008', 'nosenikeponer'), ('9009', 'ppka'), ('9010', 'alfredse'), and here, more others users, but after conversion, the users are well in new phpbb forum...


BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 754
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysqli.php
LINE: 182
CALL: dbal->sql_error()

FILE: [ROOT]/includes/db/dbal.php
LINE: 550
CALL: dbal_mysqli->sql_query()

FILE: [ROOT]/install/convertors/functions_vb4.php
LINE: 1548
CALL: dbal->sql_multi_insert()

FILE: [ROOT]/install/install_convert.php(1003) : eval()'d code
LINE: 2
CALL: phpbb_check_username_collisions()

FILE: [ROOT]/install/install_convert.php
LINE: 1003
CALL: eval()

FILE: [ROOT]/install/install_convert.php
LINE: 203
CALL: install_convert->convert_data()

FILE: [ROOT]/install/index.php
LINE: 326
CALL: install_convert->main()

FILE: [ROOT]/install/index.php
LINE: 203
CALL: module->load()
Then, go to install page again, prompt if start new conversion or continue previous conversion, if select continue previous, then, continue with any error.
I need about 6-8 hours for made the convert (my forum its a large forum) but all continue with any error.

But when finish, I go to my forum php 3.0.11 and I have all special characters with error, I'm explain: Characters like á, ñ, é...appears wrong( My language is spanish). (I can attach a screenshot but appears like this phrase: Ã￾rea Empleo / Trabajo / Formación )

I try install a spanish language in my vb with UTF-8, after conversion, have the same error.

I try to defined english language to default language in my vb forum, after conversion, I have the same problem.

I don't know how solved this...

Also, for test, I try to upgrade phpbb 3.0.11 to 3.2.4, around 80% indicate a error mysql, but this, its other problem, first, I need fix the problem indicate in this thread.

I have different tests, configurations, editions ... about 10 or 15 days, but I can not find anything else to try.

Thanks in advance.

wonder_wonder
Registered User
Posts: 24
Joined: Thu Feb 16, 2017 2:52 pm

Re: Converting vb 4.2.5 to phpbb, problem in start and special characters

Post by wonder_wonder » Sat Dec 22, 2018 12:18 am

After some changes, now, I don't have the error indicate at first post.

But, when start conversion, after a few minutes I have a 504 Gateway Timeout.
I can't solved this.

If go back, and click en continue conversion, then, continue without any error.

When finish, I have the special characters bad, like indicate in first post: Ã￾rea Empleo / Trabajo / Formación (for example).

I don't know how solved this.

Anyone can help me?

Thanks and regards.

User avatar
AbaddonOrmuz
Registered User
Posts: 521
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo Ramos
Contact:

Re: Converting vb 4.2.5 to phpbb, problem in start and special characters

Post by AbaddonOrmuz » Sat Dec 22, 2018 12:55 am

You can try to change the collation of the tables and text fields (like phpbb_posts.post_text) to utf8_bin, which is the one phpBB uses.

I don't think is related, but also make sure the files are UTF-8 without BOM, you can do it with dos2unix or Vim (:set nobomb, can be run programmatically).
A proudly user of Arch Linux :: /r/sddm_themes

wonder_wonder
Registered User
Posts: 24
Joined: Thu Feb 16, 2017 2:52 pm

Re: Converting vb 4.2.5 to phpbb, problem in start and special characters

Post by wonder_wonder » Sun Dec 23, 2018 12:24 am

Hello.
In the first, thanks for your reply.
AbaddonOrmuz wrote:
Sat Dec 22, 2018 12:55 am
You can try to change the collation of the tables and text fields (like phpbb_posts.post_text) to utf8_bin, which is the one phpBB uses.
The first image attached is the table phpbb_post-post.text before convert was are in utf8_unicode_ci, I change to utf8_bin, but any change, any solved.
Also, I try to change table phpbb_post - post_subject also to utf8_bin, same result, any change in the site.
The second attach its my site after convert with this special characters.
After convert, if I create a new thread with special characters appears well, appears correctly.
1.jpg
Tables in urf8_bin
2.jpg
My site after convert
I have thought about many options because this problem happens, but I can not find the problem ...
My site is originally in Spanish, I have also set it to English and I have tried a conversion after this, the problem continues.
I don't think is related, but also make sure the files are UTF-8 without BOM, you can do it with dos2unix or Vim (:set nobomb, can be run programmatically).
You refer a convert files or all phpbb files?

Again, thanks and regards!

Post Reply

Return to “[3.2.x] Convertors”

Who is online

Users browsing this forum: No registered users and 8 guests