Not installed with PHP 7.3

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
Kovalets
Registered User
Posts: 12
Joined: Fri Jan 20, 2017 1:31 am

Not installed with PHP 7.3

Post by Kovalets »

Not installed with PHP 7.3 - Apache 2.4.6 - MariaDB 5.5.60

example.com/install/app.php/install

Code: Select all

[phpBB Debug] ""continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?" in file /home/admin/web/example.com/public_html/vendor/zendframework/zend-stdlib/src/ArrayObject.php on line 426
[phpBB Debug] ""continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?" in file /home/admin/web/example.com/public_html/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 272
[phpBB Debug] ""continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?" in file /home/admin/web/example.com/public_html/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 275
[phpBB Debug] ""continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?" in file /home/admin/web/example.com/public_html/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 281
[phpBB Debug] ""continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?" in file /home/admin/web/example.com/public_html/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 287
[phpBB Debug] ""continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?" in file /home/admin/web/example.com/public_html/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 296
[phpBB Debug] ""continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?" in file /home/admin/web/example.com/public_html/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 314
[phpBB Debug] ""continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?" in file /home/admin/web//public_html/vendor/zendframework/zend-code/src/Reflection/MethodReflection.php on line 319
User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21123
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr

Re: Not installed with PHP 7.3

Post by RMcGirr83 »

phpBB isn't validated to work on 7.3 use a lesser version of PHP.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions | My extensions are updated regularly on github
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored
User avatar
Kovalets
Registered User
Posts: 12
Joined: Fri Jan 20, 2017 1:31 am

Re: Not installed with PHP 7.3

Post by Kovalets »

phpBB and does not support the latest version. Actually it is sad. :( Excuse me.
User avatar
KevC
Support Team Member
Support Team Member
Posts: 69981
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Not installed with PHP 7.3

Post by KevC »

7.3 only came out 3 weeks ago you know. I doubt anything open source has updated quickly enough to be compatible with it.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"
User avatar
Mick
Support Team Member
Support Team Member
Posts: 22541
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Not installed with PHP 7.3

Post by Mick »

And what's the rush?
"The more connected we get the more alone we become" - Kyle Broflovski©
User avatar
Kovalets
Registered User
Posts: 12
Joined: Fri Jan 20, 2017 1:31 am

Re: Not installed with PHP 7.3

Post by Kovalets »

WordPress works very well. I do not use other engines.
When is PHP 7.3 support planned?
User avatar
Kovalets
Registered User
Posts: 12
Joined: Fri Jan 20, 2017 1:31 am

Re: Not installed with PHP 7.3

Post by Kovalets »

Mick wrote:
Tue Jan 01, 2019 7:20 pm
And what's the rush?
A simple desire to use the latest software ;)
User avatar
GanstaZ
Registered User
Posts: 804
Joined: Wed Oct 11, 2017 10:29 pm
Location: Zverse

Re: Not installed with PHP 7.3

Post by GanstaZ »

As mentioned above and in other topics as well, it's not supported yet. More info can be found here php 7.3 warning in installing 3.2.3 and installtion failed.
"When answer lies in the question,.. question becomes redundant!"
User avatar
warmweer
Jr. Extension Validator
Posts: 4747
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Not installed with PHP 7.3

Post by warmweer »

Kovalets wrote:
Tue Jan 01, 2019 7:09 pm
phpBB and does not support the latest version. Actually it is sad. :( Excuse me.
What's worse?
  1. The latest versions of phpBB was in RC stage when php7.3 was released and thus not downgraded to development stage in order to test all code, and adapt where necessary to account for this new version of php (since this would postpone the release for quite some time).
  2. An old-time user of phpBB did not read the version requirements and is surprised (and complains) that it doesn't work on a version it was not made to work on.
Damn it, why isn't this automatically converted to a board-wide poll?
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.
Post Reply

Return to “[3.2.x] Support Forum”