ACP not working after upgrading to 3.3.8

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
matjazv
Registered User
Posts: 21
Joined: Wed Nov 09, 2022 7:28 am

Re: ACP not working after upgrading to 3.3.8

Post by matjazv »

ssl wrote: Tue Nov 22, 2022 8:57 am Have you delete install folder after the update?
Sure did. But it's not important really. ACP should work with install folder in place...
User avatar
ssl
Registered User
Posts: 1031
Joined: Sat Feb 08, 2020 2:15 pm
Location: Pays de la Loire, France
Name: Fred Rimbert
Contact:

Re: ACP not working after upgrading to 3.3.8

Post by ssl »

matjazv wrote: Tue Nov 22, 2022 9:13 am ACP should work with install folder in place...
Only for administrators not for members. The install folder must imperatively be deleted after an update operation.
Sorry for my English ... I do my best!

phpBB: 3.3.8 | PHP: 8.1.12
[GitHub] - [Kill spam on phpBB] - [Some French translation of extensions]
User avatar
warmweer
Jr. Extension Validator
Posts: 9222
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium
Contact:

Re: ACP not working after upgrading to 3.3.8

Post by warmweer »

ssl wrote: Tue Nov 22, 2022 9:30 am
matjazv wrote: Tue Nov 22, 2022 9:13 am ACP should work with install folder in place...
Only for administrators not for members. The install folder must imperatively be deleted after an update operation.
True, but that's beside the point in this case (as the issue at hand is that the admin/founder can log in (board) but not ACP)

The problem is that the board had auth_ldap originally but the ldap server (or whatever is needed) is not available anymore and switching to db via database editing doesn't function as expected.Permissions seem to be defined (or still authorised) by ldap.

But, I've started comparing the problematic database with a clean database (using auth_db).
And the groups_table of the problematic database has an extra field (group_skip_auth, all groups set to 0).
I currently have no idea about the function of that field is but it's something I can experiment with.

Unfortunately group_Ids have been changed (to in the 30s) so visual comparison is a bit tricky but I'll link both databases in Access or LibreOffice which should make it a lot easier to identify differences in structure and values.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.


Time flies like an arrow, but fruit flies like a banana.
matjazv
Registered User
Posts: 21
Joined: Wed Nov 09, 2022 7:28 am

Re: ACP not working after upgrading to 3.3.8

Post by matjazv »

warmweer wrote: Tue Nov 22, 2022 12:55 pm The problem is that the board had auth_ldap originally but the ldap server (or whatever is needed) is not available anymore and switching to db via database editing doesn't function as expected.Permissions seem to be defined (or still authorised) by ldap.
Just to point out that switch to db authentication was made via ACP not via database, see my previous post - step 11.
User avatar
warmweer
Jr. Extension Validator
Posts: 9222
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium
Contact:

Re: ACP not working after upgrading to 3.3.8

Post by warmweer »

No positive news.
Decided to postpone database comparisons and see whether the unofficial STKs for 3.1 and 3.2 could solve this.

Started fresh with the 3.0.11 database, upgraded to 3.0.14, used the official STK, then upgraded to 3.2.11 and used Alex Sheer's STK (which allows changing auth method). NO success :(

Then tried to setup a ldap server on XAMPP, but that apparently (or better: clearly) didn't succeed (I have no experience at all with anything LAPD, erm... ldap-related at all - now I do but up to now it's not a pleasurable experience).

Next option (later today or tomorrow, depends if I can get rid of the headache I got looking at all those databases) is my previous thought:
Create a new board, copy the forums, non-default groups and users from the old (ldap-board) and recalculate permissions (luckily the Alex' STK can do part of that).

Alternatively: perhaps a phpBB developer could hop into this topic and spare me/us this misery ;)
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.


Time flies like an arrow, but fruit flies like a banana.
CPTOM
Registered User
Posts: 108
Joined: Fri Jul 02, 2021 1:05 am

Re: ACP not working after upgrading to 3.3.8

Post by CPTOM »

Did you delete everything in the cache folder other than htaccess and index.php?
Last edited by Mick on Thu Nov 24, 2022 10:00 am, edited 1 time in total.
Reason: Removed unnecessary full quotes.
User avatar
warmweer
Jr. Extension Validator
Posts: 9222
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium
Contact:

Re: ACP not working after upgrading to 3.3.8

Post by warmweer »

CPTOM wrote: Wed Nov 23, 2022 7:12 pm ...
Did you delete everything in the cache folder other than htaccess and index.php?
He probably did.
But even if he didn't -that doesn't cause any problem.
I've cleaned the original database and created an emergency founder many times already and tried trying immediate upgrades and incremental upgrades (and using all available STKs)
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.


Time flies like an arrow, but fruit flies like a banana.
matjazv
Registered User
Posts: 21
Joined: Wed Nov 09, 2022 7:28 am

Re: ACP not working after upgrading to 3.3.8

Post by matjazv »

CPTOM wrote: Wed Nov 23, 2022 7:12 pmDid you delete everything in the cache folder other than htaccess and index.php?
As you can see I deleted all folders (including cache) except... see points 14 and 15.
Last edited by Mick on Thu Nov 24, 2022 10:01 am, edited 1 time in total.
Reason: Removed unnecessary full quotes.
User avatar
warmweer
Jr. Extension Validator
Posts: 9222
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium
Contact:

Re: ACP not working after upgrading to 3.3.8

Post by warmweer »

A breakthrough. (couldn't sleep as the idea of failing isn't appealing to me) so decided to make use of that insomnia.
I made a new 3.0.11 - transferred (manually) the original founder and 1 regular member (using fakemailaddresses), their groups , 2 forums (+ set permissions) and their posts. (start small to test)
A bit of a hassle as I had to use the stk to create the emergency founder to edit everything and had to open the original board and the test copy (on different browsers) to set the permissions (and it is a pain to do that)

BUT: i upgraded that experimental board to 3.3.8 and SUCCESS (honestly I was fairly sure it would work), original founder, the 2 regular members and the emergency founder can access the 338 board with the user-, group- and group-forum permissions set as in the original board.

That took about 3 hours. So for the full board I expect it will take around 10 hours (probably more as it's not exactly fun work and I'm going to take backups after each success).

BUT: it's something I can only start on next week (but I hope a more simple solution can be found before Monday).
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.


Time flies like an arrow, but fruit flies like a banana.
Post Reply

Return to “[3.3.x] Support Forum”