3.3.7 to 3.3.8 Site No Longer Loads!

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
dagoba1
Registered User
Posts: 7
Joined: Thu Oct 28, 2021 8:31 pm

3.3.7 to 3.3.8 Site No Longer Loads!

Post by dagoba1 »

Hello.

I've done a few previous upgrades to my phpBB site without issue. Last night, I went from 3.3.7 to 3.3.8 following the steps here: https://www.phpbb.com/support/docs/en/3 ... date_full/

Once completing these steps, it was working. I was in the admin panel and looking at plugins needing updates, etc. But, this morning, the site doesn't appear to be loading at all.

Any ideas on how to troubleshoot and get the site going again? Is it possible that the admin console works. But, the main page does not (maybe due to an outdated plugin)? If so, is there a path/way to get back into the admin directly so I can fix?

Thank you for any help you can offer!
Last edited by Mick on Tue Nov 22, 2022 9:51 am, edited 1 time in total.
Reason: Solved.
User avatar
[Dimetrodon]
Registered User
Posts: 196
Joined: Tue Aug 30, 2022 3:29 am
Location: Paleozoic Era
Contact:

Re: 3.3.7 to 3.3.8 Site No Longer Loads!

Post by [Dimetrodon] »

Please fill out a support request template and include a link to the board: https://www.phpbb.com/support/srt/

There are many things that can result in a site not loading.
User avatar
warmweer
Jr. Extension Validator
Posts: 9222
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium
Contact:

Re: 3.3.7 to 3.3.8 Site No Longer Loads!

Post by warmweer »

dagoba1 wrote: Sun Nov 20, 2022 9:08 pm Once completing these steps, it was working. I was in the admin panel and looking at plugins needing updates, etc. But, this morning, the site doesn't appear to be loading at all.
That is something you should have done before updating.
dagoba1 wrote: Sun Nov 20, 2022 9:08 pmAny ideas on how to troubleshoot and get the site going again? Is it possible that the admin console works. But, the main page does not (maybe due to an outdated plugin)? If so, is there a path/way to get back into the admin directly so I can fix?
One thing you could try is to edit the phpbb_ext table to disable all extensions. (set ext_active to 0 and clear board and browser cache).

When posting the SRT, be sure to provide information as to method of updating.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.


Time flies like an arrow, but fruit flies like a banana.
dagoba1
Registered User
Posts: 7
Joined: Thu Oct 28, 2021 8:31 pm

Re: 3.3.7 to 3.3.8 Site No Longer Loads!

Post by dagoba1 »

[Dimetrodon] wrote: Sun Nov 20, 2022 9:55 pm Please fill out a support request template and include a link to the board: https://www.phpbb.com/support/srt/

There are many things that can result in a site not loading.
Thank you. Nice template builder system! Here's mine:


Support Request Template
What version of phpBB are you using? phpBB 3.3.8
What is your board's URL? www.moddingham.com
Who do you host your board with? dreamhost
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What version of phpBB3 did you update from? phpBB 3.3.7
What extensions do you have installed? I don't know all names by heart. But, I can list by their folder names as uploaded.

A few of these are installed but deactivated. I can't remember which:

alfredoramos>markdown
andreask>ium
dmzx>copyright
mailboxvalidator>emailvalidator
phpbb>boardannouncements, boardrules, googleanalytics, mediaembed, viglink
phpbbmodders>banhammer
phpbbservices>spamremover
rmcgirr83>stopforumspam
sitesplat>cloudflareip
spaceace>roundavatars
vse>abbc3, lightbox
What styles do you currently have installed? 1978, 1982, CleanSilver, proDVGFX, prosilver
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5
What is your level of experience? Experienced with PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? I followed the update steps here as I had done before: https://www.phpbb.com/support/docs/en/3 ... date_full/

The database update went well with no errors. And it appeared to be working as I went right to the admin panel. I was going to update the extensions the next day. But, when I looked again the site no longer loaded. I suspect because the admin panel works but the public facing page does not.
Please describe your problem. I believe that its a problem with the extensions being outdated. But, not 100% certain.

The trouble is that I can not update those the recommended way (disabling before updating files, etc) without having access to the admin panel.
Generated by SRT Generator
dagoba1
Registered User
Posts: 7
Joined: Thu Oct 28, 2021 8:31 pm

Re: 3.3.7 to 3.3.8 Site No Longer Loads!

Post by dagoba1 »

warmweer wrote: Sun Nov 20, 2022 10:36 pm When posting the SRT, be sure to provide information as to method of updating.
I followed the steps for the "Full Package" update: https://www.phpbb.com/support/docs/en/3 ... date_full/

I used FTP for the transferring.
User avatar
[Dimetrodon]
Registered User
Posts: 196
Joined: Tue Aug 30, 2022 3:29 am
Location: Paleozoic Era
Contact:

Re: 3.3.7 to 3.3.8 Site No Longer Loads!

Post by [Dimetrodon] »

General Error
SQL ERROR [ mysqli ]

Connection timed out [2002]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.
I coaxed the server into finally displaying the above message.

Then, trying to access viewforum.php nets me an error from cloudflare:
timeout.png
Sorry if this comes off as dismissive, but I doubt you can access your ACP even if you had a direct link, nor do I think it an issue caused by phpBB. This looks like a problem with your host and the way their servers are configured.

Your ACP would be under this link: www.moddingham.com/adm/index.php

I would get a phpBB error message saying I do not have permission to access it since I am not an Admin. Instead, I got served another server error message, this time a standard 503 Service Unavailable message. This seems to be an issue with your host.
User avatar
warmweer
Jr. Extension Validator
Posts: 9222
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium
Contact:

Re: 3.3.7 to 3.3.8 Site No Longer Loads!

Post by warmweer »

Same here (just now but also yesterday late)
General Error
SQL ERROR [ mysqli ]

Connection timed out [2002]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.
I did manage to check your styles and extension versions

1978, 1982, CleanSilver and proDVGFX are all v 334
dmzx/copyright = 1.0.2 latest = 1.0.3
phpbb/mediaembed 1.1.2 latest = 2.0.0
phpbb/boardannouncements = 1.1.0 latest = 1.1.1
vse/abbc3 = 3.3.3 latest = 3.3.5
vse/lightbox 2.0.3 latest = 2.0.4
rmcgirr83/stopforumspam = 1.4.0 latest = 1.4.3 (not validated on phpBB)
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.


Time flies like an arrow, but fruit flies like a banana.
dagoba1
Registered User
Posts: 7
Joined: Thu Oct 28, 2021 8:31 pm

Re: 3.3.7 to 3.3.8 Site No Longer Loads!

Post by dagoba1 »

[Dimetrodon] wrote: Mon Nov 21, 2022 4:20 pm I would get a phpBB error message saying I do not have permission to access it since I am not an Admin. Instead, I got served another server error message, this time a standard 503 Service Unavailable message. This seems to be an issue with your host.
Thank you for taking a look.

I think I figured out what the culprit is. I had left an old db on the server (from a different forum install) for reference. When I did the upgrade, I deleted it because I figured it had served its safety purpose. But, now, I think I deleted the wrong one!

Good thing I backed it up first!
dagoba1
Registered User
Posts: 7
Joined: Thu Oct 28, 2021 8:31 pm

Re: 3.3.7 to 3.3.8 Site No Longer Loads!

Post by dagoba1 »

warmweer wrote: Mon Nov 21, 2022 5:26 pm Same here (just now but also yesterday late)
General Error
SQL ERROR [ mysqli ]

Connection timed out [2002]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.
I did manage to check your styles and extension versions

1978, 1982, CleanSilver and proDVGFX are all v 334
dmzx/copyright = 1.0.2 latest = 1.0.3
phpbb/mediaembed 1.1.2 latest = 2.0.0
phpbb/boardannouncements = 1.1.0 latest = 1.1.1
vse/abbc3 = 3.3.3 latest = 3.3.5
vse/lightbox 2.0.3 latest = 2.0.4
rmcgirr83/stopforumspam = 1.4.0 latest = 1.4.3 (not validated on phpBB)
Thank you!

It turned out to be easier to fix than I expected. I had only deleted one of the mysql host names (the wrong one). The db was still there just fine. As soon as I recreated the host name it loaded right up!
Post Reply

Return to “[3.3.x] Support Forum”