cookies and domains

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
PorkysGaming
Registered User
Posts: 13
Joined: Thu Nov 24, 2022 10:29 am

cookies and domains

Post by PorkysGaming »

Hello everybody.

I have a domain and will simply call it gamer.com
i use a template that i purchased that isnt phpbb based.
I also have a tebex account and have a cname record that goes to vip.gaming.com
This has auto renewing SSL certificate.
This is all working as it should.

I want to add a phpbb forum as well.

I created inside the gaming.com installation directory a phpbb installation
which is now gaming.com/forum

I can access the forum without any issues BUT.....
on the ACP when trying to make certain changes i get logged out of the ACP.
( anything to do with forum banner )

I suspect this is a cookie issue?
how would i go about making it so the phpbb installation is forum.gaming.com
as opposed to gaming.com/forum which is what it currently is
as hopefully this will rectify the issue.
Currently running the latest version of phpbb ( downloaded yesterday )
cookie setting is set to .gaming.com
cookie path is set to /forum
i have tried ssl enabled and not enabled.
i have tried leaving cookie path as just / and as /forum

Any help would be very much apprieciated as im pulling my hair out lol
Last edited by Mick on Thu Nov 24, 2022 8:28 pm, edited 1 time in total.
Reason: Solved.
User avatar
Mick
Support Team Member
Support Team Member
Posts: 24789
Joined: Fri Aug 29, 2008 9:49 am
Contact:

Re: cookies and domains

Post by Mick »

Firstly see Knowledge Base - Fixing incorrect cookie settings. If that doesn't help please fill out the Support Request Template and post it back here to enable us to assist you better, don't forget to supply the PHP version your using as well.
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel
User avatar
PorkysGaming
Registered User
Posts: 13
Joined: Thu Nov 24, 2022 10:29 am

Cookies and Domains

Post by PorkysGaming »

Support Request Template
What version of phpBB are you using? phpBB 3.3.8
What is your board's URL? http://porkysgaming.com/forum
Who do you host your board with? krystal hosting uk
How did you install your board? I used a tool provided by my host
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What extensions do you have installed? ACP Add User
Advanced BBCode Box
Avatars on Memberlist
Blinking counter, for new pm and new notify
Copyright Extended
Database Optimize & Repair Tool
hCaptcha
Header Banner ( doesnt appear in Extensions )
Link bbCode Extension
PayPal Donation Extension
phpBB Media Embed PlugIn
phpBB SiteMaker
phpBB Studio - Discord Oauth2 light
Round avatars
Share On
Steam Status
Topic Preview
VigLink
Welcome back
What styles do you currently have installed? proDVGFX
What language(s) is your board currently using? English
Which database type/version are you using? MariaDB
What is your level of experience? New to PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? created a fresh board
installed some extensions
Please describe your problem. when using the ACP i am having to reauthorise as it kicks me out of the ACP

I have a domain and will simply call it gamer.com
i use a template that i purchased that isnt phpbb based.
I also have a tebex account and have a cname record that goes to vip.gaming.com
This has auto renewing SSL certificate.
This is all working as it should.

I want to add a phpbb forum as well.

I created inside the gaming.com installation directory a phpbb installation
which is now gaming.com/forum

I can access the forum without any issues BUT.....
on the ACP when trying to make certain changes i get logged out of the ACP.
( anything to do with forum banner )

I suspect this is a cookie issue?
how would i go about making it so the phpbb installation is forum.gaming.com
as opposed to gaming.com/forum which is what it currently is
as hopefully this will rectify the issue.
Currently running the latest version of phpbb ( downloaded yesterday )
cookie setting is set to .gaming.com
cookie path is set to /forum
i have tried ssl enabled and not enabled.
i have tried leaving cookie path as just / and as /forum

I have followed the fix cookie settings link advice to no avail

Any help would be very much apprieciated as im pulling my hair out lol
Generated by SRT Generator
User avatar
PorkysGaming
Registered User
Posts: 13
Joined: Thu Nov 24, 2022 10:29 am

Re: cookies and domains

Post by PorkysGaming »

Thanks for the reply mick, i have already done the fix cookie link thing,
i have filled out the request template and submitted it
( in the correct support forum 3.3.x )
cheers
User avatar
Mick
Support Team Member
Support Team Member
Posts: 24789
Joined: Fri Aug 29, 2008 9:49 am
Contact:

Re: cookies and domains

Post by Mick »

As a test try reverting to the default prosilver style and disabling (NOT DELETING) all your extensions and test.

Did you try another browser and or clearing the browser and phpBB caches?
PorkysGaming wrote: Thu Nov 24, 2022 11:17 amHow did you install your board? I used a tool provided by my host
Incidentally, using hosts 1-click installers very often causes problems like logging in and out issues. If you have a search here you'll find dozens of cases the same or similar to yours. The code hosts use for 1-clicks isn't ours so we have difficulty supporting it. It is always recommended to install properly using the files from here.
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel
User avatar
PorkysGaming
Registered User
Posts: 13
Joined: Thu Nov 24, 2022 10:29 am

Re: cookies and domains

Post by PorkysGaming »

tried removing all the plugins except for forum banner which is where i am noticing the logging out, and setting prosilver as default
and i am thinking that it may be the forum banner extension causing the issues
althought the dev states that " Does it not work with 3.3? Extensions don't need to be updated for every single phpBB release. "

so it could very well be that causing the issue.
I know the header banner extension does not show in the acp so is incompatiable.

i was thinking it was maybe a cookie issue with it being gaming.com/forum
and not forum.gaming.com?
User avatar
Mick
Support Team Member
Support Team Member
Posts: 24789
Joined: Fri Aug 29, 2008 9:49 am
Contact:

Re: cookies and domains

Post by Mick »

The url to your board is irrelevant so long as the cookie settings are correct.

Any questions about extensions needs to be asked of the author in the dedicated discussion/support forum for the extension or wherever you got it from.

if none of the above helps I suggest, as it's a brand new board, you remove what you have and reinstall using the files from here. It will save you a lot of grief in the future.
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel
User avatar
[Dimetrodon]
Registered User
Posts: 196
Joined: Tue Aug 30, 2022 3:29 am
Location: Paleozoic Era
Contact:

Re: cookies and domains

Post by [Dimetrodon] »

Hello.

This may be helpful in disabling all your extensions if you feel like they're the cause of your issue: https://www.phpbb.com/support/docs/en/3 ... s-at-once/

The script at the bottom of the page does not require ACP access.
🇺🇦 Stand with Ukraine 🇺🇦
"Life is rarely a choice between good and bad, but bad and worse." - Steve Shahbazian
When seeking support, please consider filling out the Support Request Template. It makes it easier for anyone trying to help.
My corner of the web.
User avatar
PorkysGaming
Registered User
Posts: 13
Joined: Thu Nov 24, 2022 10:29 am

Re: cookies and domains

Post by PorkysGaming »

[Dimetrodon] wrote: Thu Nov 24, 2022 12:36 pm Hello.

This may be helpful in disabling all your extensions if you feel like they're the cause of your issue: https://www.phpbb.com/support/docs/en/3 ... s-at-once/

The script at the bottom of the page does not require ACP access.
Darn it, i did them one at a time lol, bookmarked for future reference, many thanks
User avatar
PorkysGaming
Registered User
Posts: 13
Joined: Thu Nov 24, 2022 10:29 am

Re: cookies and domains

Post by PorkysGaming »

Mick wrote: Thu Nov 24, 2022 12:25 pm The url to your board is irrelevant so long as the cookie settings are correct.

Any questions about extensions needs to be asked of the author in the dedicated discussion/support forum for the extension or wherever you got it from.

if none of the above helps I suggest, as it's a brand new board, you remove what you have and reinstall using the files from here. It will save you a lot of grief in the future.
Then it is probable that it was the extension causing the issues, still awaiting a reply on the extension authers support page.
I shall see how things go and if it isnt resolved with the removal of the extension then a new board will be the only way forward.
I shall manually add a banner in the overal header ( ive done that in the past successfully on previous boards ive had ).

Many thanks for the help my friend
User avatar
[Dimetrodon]
Registered User
Posts: 196
Joined: Tue Aug 30, 2022 3:29 am
Location: Paleozoic Era
Contact:

Re: cookies and domains

Post by [Dimetrodon] »

I don't know why, but when I browse your site, I am asked by my browser if I want to save my password even though I don't have a username and have never logged in.

I have no idea if that's a bug with a plugin you're using, but if it isn't, it may be related to the one click install. If so, it's certainly a bad install.

Either way, it may be related to you getting kicked out of the ACP.
Strange password prompt.png
🇺🇦 Stand with Ukraine 🇺🇦
"Life is rarely a choice between good and bad, but bad and worse." - Steve Shahbazian
When seeking support, please consider filling out the Support Request Template. It makes it easier for anyone trying to help.
My corner of the web.
User avatar
PorkysGaming
Registered User
Posts: 13
Joined: Thu Nov 24, 2022 10:29 am

Re: cookies and domains

Post by PorkysGaming »

no idea what is causing that, ive removed a few plugins and think it seems to working as it should now
( it shouldnt be open to registrations at the moment )
Post Reply

Return to “[3.3.x] Support Forum”