Startup page remains in english

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
bcw
Registered User
Posts: 4
Joined: Mon Jan 23, 2023 4:05 pm

Startup page remains in english

Post by bcw »

Hello,
I am trying to customise a newly instance of phpBB for a French community.
I searched this forum, noticed there were more issues around this topic but could not get a solution.

I would like the opening page (when users have not yet logged in) to be in French.
The page for a particular user, after they have logged in, should be by default French, but modifiable via the UCP to another language.
The latter works, the first one does not.
I was hoping the first requirement could be met by setting the board default language to French in the ACPl. I have done that, but no success.
What am I doing wrong?

By the way - I am running phpBB 3.3.9 on an Ubuntu 22.04.1 LTS host
Thanks!
Last edited by HiFiKabin on Tue Jan 24, 2023 12:59 pm, edited 1 time in total.
Reason: Solved
User avatar
warmweer
Jr. Extension Validator
Posts: 9496
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium
Contact:

Re: Startup page remains in english

Post by warmweer »

I suspect you installed the board with British English as only language pack (and thus default language).
The user anonymous has English as Language as it's the only one installed.

When you then install a new language and set it as default, users' language isn't changed, basically a new language has become available but anonymous continues having English as language.
Change anonymous' language to French, log out and then see which language is used. (tested on my side ;-) )
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.


Time flies like an arrow, but fruit flies like a banana.
bcw
Registered User
Posts: 4
Joined: Mon Jan 23, 2023 4:05 pm

Re: Startup page remains in english

Post by bcw »

Thank you.
Indeed - I first installed the forum with only UK English, later added the French package.
I've been trying to change the Anonymous user's language. I would expect that to be in the ACP area, under users and groups. If I click Manage Users,
and select "Anonymous" I can see and change some elements, but the preferred language is not amongst them.
And, I suppose by definition, I cannot login as Ananymous, Correct?
User avatar
warmweer
Jr. Extension Validator
Posts: 9496
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium
Contact:

Re: Startup page remains in english

Post by warmweer »

ACP > tab USERS AND GROUPS > USERS > Manage users > select anonymous user > click on Submit > Select form Preferences from the dropdown
>>> Edit global settings > My language:
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.


Time flies like an arrow, but fruit flies like a banana.
User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 6105
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: Startup page remains in english

Post by HiFiKabin »

bcw wrote: Tue Jan 24, 2023 10:36 am And, I suppose by definition, I cannot login as Anonymous , Correct?
Correct, but if you are not logged in you will see the features that the Anonymous user has.

Set the default language as described above and that is what will be seen to anyone not logged in


language.png
bcw
Registered User
Posts: 4
Joined: Mon Jan 23, 2023 4:05 pm

Re: Startup page remains in english

Post by bcw »

Just to make sure I understand you correctly:
Following your screenshot, I need to login as administrator, go to the Board Settings in ACP, and set the language to French, correct?
I did this as a first attempt, but that does not work for me.
User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 6105
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: Startup page remains in english

Post by HiFiKabin »

Correct.

... but as that seems not to have worked, try this:-

ACP> Users And Groups> Manage Users > Select anonymous user > Submit > Preferences

Select French and submit
User avatar
Mannix_
Registered User
Posts: 1555
Joined: Sun Oct 25, 2015 2:56 pm
Name: Matt
Contact:

Re: Startup page remains in english

Post by Mannix_ »

bcw wrote: Tue Jan 24, 2023 11:05 am I did this as a first attempt, but that does not work for me.
That settings should work for all non logged in users. This won't affect users that already registered and logged in.
Did I helped You? Consider a donation.
New version of phpBB has been released? My styles aren't validated for it yet? Check my page for the latest downloads!
User avatar
warmweer
Jr. Extension Validator
Posts: 9496
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium
Contact:

Re: Startup page remains in english

Post by warmweer »

bcw wrote: Tue Jan 24, 2023 11:05 am Just to make sure I understand you correctly:
Following your screenshot, I need to login as administrator, go to the Board Settings in ACP, and set the language to French, correct?
I did this as a first attempt, but that does not work for me.
Setting the default language to French will make that the default language for anyone registering from that moment on. But it doesn't change the language of the current members (anonymous is also a member).
As I mentioned, and as HiFiKabin confirmed, you need to change the language of the user anonymous.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.


Time flies like an arrow, but fruit flies like a banana.
bcw
Registered User
Posts: 4
Joined: Mon Jan 23, 2023 4:05 pm

Re: Startup page remains in english

Post by bcw »

HiFiKabin wrote: Tue Jan 24, 2023 11:15 am Correct.

... but as that seems not to have worked, try this:-

ACP> Users And Groups> Manage Users > Select anonymous user > Submit > Preferences

Select French and submit
That seems to work! At actually looked at that place, but did not spot the form options.
Thanks everyone for thinking along. I am new to this software, but quite impressed so far!
User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 6105
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: Startup page remains in english

Post by HiFiKabin »

Glad its solved the problem.
Post Reply

Return to “[3.3.x] Support Forum”