Snitz mdb to MySql PhPBB

Converting from other board software? Good decision! Need help? Have a question about a convertor? Wish to offer a convertor package? Post here.
pyxone
Registered User
Posts: 2
Joined: Fri Sep 29, 2023 6:32 am

Snitz mdb to MySql PhPBB

Post by pyxone »

Hello all. I have a .mdb from Snitzforums which I would like to convert to mysql PhPBb33. Now you have a converter1.7 that should work with PhPBb2.
The challenge I encounter is starting the phpbb2 software installation. Locally on my PC I use wampserver on which I can install 3.3 without any problems. I think only phpbb2 needs a slightly "older version" of php because of the following magic_quotes error. (no longer available in current PHP versions)

Code: Select all

Fatal error: Uncaught Error: Call to undefined function set_magic_quotes_runtime()
Can someone convert an MDB to MySQL or can someone tell me how I can get an older PHP installed locally?
User avatar
warmweer
Jr. Extension Validator
Posts: 11467
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Snitz mdb to MySql PhPBB

Post by warmweer »

pyxone wrote: Fri Sep 29, 2023 6:42 am ...
Can someone convert an MDB to MySQL or can someone tell me how I can get an older PHP installed locally?
old versions of easyphp

old versions of xampp

old versions of wamp
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.


Time flies like an arrow, but fruit flies like a banana.
User avatar
Toxyy
Registered User
Posts: 960
Joined: Mon Oct 24, 2016 3:22 pm
Location: Namek

Re: Snitz mdb to MySql PhPBB

Post by Toxyy »

I forget what MySQL phpbb2 needs, but I've done conversions from other forums from phpbb2 to phpbb3 in the past a doof ew times. phpBB came out ~Oct 2014, which is around php 5.5, so I would install something like php 5.3 or even earlier to be able to install a phpbb 2 board, it mentions php v4 but I've installed phpbb 2 successfully using some early version of php 5 before.

Once that's installed you can follow the instructions as you've already found here. It states that the converter is for snitz -> phpbb2, but requires a Snitz 3.4.03 MySQL database. If you know the version, the best download links I can find are on their sourceforge: https://sourceforge.net/projects/sf2k/f ... ms%202000/

I'd try to install the version just above or matching your databse version, if they don't include install instructions I did find this website here, then I'd try to continue with the converter here (possibly check out the link a couple posts above for more info). From what I can tell the converter might actually support up to version 3.4.

Unsure how the converter works or if it even needs an actual db install; perhaps the .mdb file is actually a mysql dump with a weird file extension that could be imported into phpmyadmin, possibly with some tweaking. Unsure. I'd try my instructions above, then running the converter.

Good luck!
I am a web developer/administrator, specializing in forums. If you have work you need done or are too lazy to do, pm me!

Some of my extensions:
[3.3][BETA] Post Form Templates || [3.3][BETA] Anonymous Posts || [3.2][3.3][BETA] ACP Merge Child Forums || [3.2][BETA] Sticky Ad || [3.2][DEV] User Delete Topics || [3.3][DEV] Moderate While Searching || [3.3][RC] Short Number Twig Extension
User avatar
Mick
Support Team Member
Support Team Member
Posts: 26703
Joined: Fri Aug 29, 2008 9:49 am

Re: Snitz mdb to MySql PhPBB

Post by Mick »

  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel©
🇬🇧
pyxone
Registered User
Posts: 2
Joined: Fri Sep 29, 2023 6:32 am

Re: Snitz mdb to MySql PhPBB

Post by pyxone »

Toxxy en warmweer, thanks for all your input. It's still fun to tinker with this. With wampserver links you can go back to 2013 with a 64bit version and php 5.5. I managed to install phpBB2 without any problems. I'm going to sit down in the coming days and start the plugin for a conversion. ;)

Return to “[3.3.x] Convertors”