[solved] Nothing happens when uploading attachment

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
redsquirrel
Registered User
Posts: 40
Joined: Wed Aug 20, 2014 3:54 am

[solved] Nothing happens when uploading attachment

Post by redsquirrel »

I'm testing attachments and in dev on my local server, if I upload an attachment, it works, but in prod, nothing happens. No error or anything, it just never ends up showing up in the post, even though it showed that it uploaded correctly. What should I be checking? I tried to chmod 777 the download folder, which is where it appears attachments are going, and that did nothing. Obviously that's not a proper fix but just wanted to rule out permission issue but it's not that. Anything else I could check?

EDIT: I figured it out, it's actually the files folder. It was not actually created on live since my rsync script skips it on purpose so I'm not messing with live attachment data. Created it with chmod 775 and added blank index.htm file in it and it seems to work now. Be nice if it gave an error or something though...
Last edited by Mick on Tue Dec 12, 2023 11:40 am, edited 1 time in total.
Reason: Solved.

Return to “[3.3.x] Support Forum”