[3.3] maybe a bug in registration a user ?

Do not post support requests, bug reports or feature requests. Discuss phpBB here. Non-phpBB related discussion goes in General Discussion!
Get Involved
effixx
Registered User
Posts: 7
Joined: Sat Feb 10, 2024 5:02 pm

[3.3] maybe a bug in registration a user ?

Post by effixx »

I have just noticed a strange phenomenon when registering users.
Step 1
A user who has already been registered by the system is supposed to log in for the first time.

USER : "PETER"
MAIL: "[email protected]"

Step 2
The user fills out the registration form again instead of logging in. In doing so, he makes a mistake on typing.

USER : "PETET"
MAIL: "[email protected]"

Step 3
The system informs him that this e-mail address is already taken. Which is fine. But in the database there is now a BUG !
I could see that name of the correponding user_id in phpbb_users was overwriten with "PETET" !



Support Request Template
What version of phpBB are you using? phpBB 3.3.9
What is your board's URL?
Who do you host your board with? VPS Linux VC8-32
How did you install your board? I used the download package from strato
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? yes
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What extensions do you have installed? gtranslate / board announcement /
What styles do you currently have installed? prosilver/ Multi-design
What language(s) is your board currently using? de
Which database type/version are you using? MariaDB 10
What is your level of experience? New to PHP and phpBB
What actions did you take
Please describe your problem. ovewrite the username in phpbb_users
Last edited by thecoalman on Tue Feb 27, 2024 3:39 pm, edited 1 time in total.
Reason: Moved to phpBB discusssion
User avatar
thecoalman
Community Team Member
Community Team Member
Posts: 6002
Joined: Wed Dec 22, 2004 3:52 am
Location: Pennsylvania, U.S.A.

Re: [3.3] maybe a bug in registration a user ?

Post by thecoalman »

Bugs can be reported to the bug tracker. Link to it can be found under the development links in the header.

https://tracker.phpbb.com/secure/Dashboard.jspa
“Results! Why, man, I have gotten a lot of results! I have found several thousand things that won’t work.”

Attributed - Thomas Edison

Return to “phpBB Discussion”