ACP: The requested page could not be found.

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
madscook
Registered User
Posts: 5
Joined: Thu Feb 29, 2024 10:13 pm

ACP: The requested page could not be found.

Post by madscook »

Support Request Template
What version of phpBB are you using? phpBB 3.3.11
What is your board's URL? https://staff.angerpool.com/
Who do you host your board with? self hosted
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? Yes
What extensions do you have installed? I have installed a style called "Prosilver Dark Edition"
What styles do you currently have installed? Prosilver Dark Edition
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5
What is your level of experience? New to phpBB but not PHP
What username can be used to view this issue? No answer given
What password can be used to view this issue? No answer given
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Nothing i was using the ACP yesterday, i was creating a new sub forum.
Please describe your problem. I am able to log in , post and everything in the user interface.

The problem happens when i click on "Administration Control Panel" then i am asked to log in and after that is done I get the following message:
"Information
The requested page could not be found."
Generated by SRT Generator
Last edited by Mick on Sat Mar 02, 2024 4:00 pm, edited 2 times in total.
Reason: Solved.
User avatar
Mick
Support Team Member
Support Team Member
Posts: 26702
Joined: Fri Aug 29, 2008 9:49 am

Re: ACP: The requested page could not be found.

Post by Mick »

From what I can see the board is using 3.3.11 but your dark style is for 3.3.8, board and style versions must match. You can revert to prosilver to test.
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel©
🇬🇧
madscook
Registered User
Posts: 5
Joined: Thu Feb 29, 2024 10:13 pm

Re: ACP: The requested page could not be found.

Post by madscook »

Hello

How do i do that when i dont have access to the ASC?

And why did this stop working after over 2 months use?
User avatar
Mick
Support Team Member
Support Team Member
Posts: 26702
Joined: Fri Aug 29, 2008 9:49 am

Re: ACP: The requested page could not be found.

Post by Mick »

In answer to your second question, I don’t know, did your host change anything like the PHP version which is 8.0.30 at the moment? You could ask them. I’m not saying that is definitely the issue but until you try it with the stock prosilver we’ll never know. Also did you try a different browser and or purge the browser cache (CTRL + F5) and purge the board cache (using FTP to delete everything in the /cache folder except index.htm and .htaccess) or try incognito mode to log in?

As per your first question, try this:

In phpMyAdmin, run the following, which will create an admin user named Admin1 with a password of admin. From that point you should be able to get into the ACP.

Code: Select all

INSERT INTO phpbb_users (user_type, group_id, username, username_clean, user_regdate, user_password, user_email, user_lang, user_style, user_rank, user_colour, user_posts, user_permissions, user_ip, user_birthday, user_lastpage, user_last_confirm_key, user_post_sortby_type, user_post_sortby_dir, user_topic_sortby_type, user_topic_sortby_dir, user_avatar, user_sig, user_sig_bbcode_uid, user_jabber, user_actkey, user_newpasswd) VALUES (3, 5, 'Admin1', 'admin1', 0, '21232f297a57a5a743894a0e4a801fc3', '[email protected]', 'en', 1, 1, 'AA0000', 1, '', '', '', '', '', 't', 'a', 't', 'd', '', '', '', '', '', '');
Change your table prefix if it is not phpbb_

See Executing SQL Queries in phpMyAdmin if you are unfamiliar with running database queries.

As soon as you have done this, use the temporary admin account and revert to prosilver and test then delete the temporary account.

This is because:
  1. anyone could use that account to log in to your board if you didn't change the password.
  2. this temporary user has not been fully set up (e.g. it is not a member of the "Registered users" group, so it won't have normal access to your forums).
To remove the account you will first need to remove founder status from it:

ACP> USERS AND GROUPS tab> Manage Users> Admin1> Overview> Founder = No
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel©
🇬🇧
madscook
Registered User
Posts: 5
Joined: Thu Feb 29, 2024 10:13 pm

Re: ACP: The requested page could not be found.

Post by madscook »

Hello

Thanks for your reply.

I have tried the following of the thing you suggesting in the following order:
- PHP version is 8.0.33 = Correct version is set
- purge the board cache (using FTP to delete everything in the /cache folder except index.htm and .htaccess) = Tested, issue is still there.
- Browser cache (CTRL + F5) = Tested, issue is still there. Even tried 3-4 other devices with the same result
- incognito mode = Tested, issue is still there.

To explain the issue it a little more clearly:
- I am able to login to the forum and the user interface
- While i am logged in i am clicking on the "Administration Control Panel". I get prompted to log in again. The login is accepted but instead of being redirected to ACP I get a page saying: (see ACP issue.png)

With other words its not a login issue, but some kind of redirect issue.

This bring me to my next question
- Creating a new account would not solve this problem will it? regarding your suggestion creating admin1 account.
- Is there a way of changing the style by changing parameters in the configuration files?
You do not have the required permissions to view the files attached to this post.
User avatar
warmweer
Jr. Extension Validator
Posts: 11462
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

ACP, only the UCP

Post by warmweer »

Can't you change you (user) default style back to prosilver ? That doesn't require the ACP .
Or even set default style to prosilver in the config_table and override user_style.
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.


Time flies like an arrow, but fruit flies like a banana.
madscook
Registered User
Posts: 5
Joined: Thu Feb 29, 2024 10:13 pm

Re: ACP: The requested page could not be found.

Post by madscook »

I am not sure i follow what i should do, could you please show me step by step? please
User avatar
Mick
Support Team Member
Support Team Member
Posts: 26702
Joined: Fri Aug 29, 2008 9:49 am

Re: ACP: The requested page could not be found.

Post by Mick »

I merely suggested creating the emergency admin1 account so you could get back in to the ACP and change the style back to prosilver as explained in the instructions as a test as your existing style is out of date/doesn’t match your phpBB version.
As soon as you have done this, use the temporary admin account and revert to prosilver and test then delete the temporary account.
In my opinion it’s safer doing it this way but if you want to change it in the database that’s up to you.
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel©
🇬🇧
5hocK
Registered User
Posts: 3139
Joined: Wed Nov 23, 2011 7:00 pm
Location: UK

Re: ACP: The requested page could not be found.

Post by 5hocK »

Turning off mod security in your cpanel should allow you to get back into the acp. It's a short term solution, for me atleast.
I'm having the exact same problem as the OP screenshot. Mod security was always on my hosts side of things until I noticed it in cpanel today.
User avatar
Talk19Zehn
Registered User
Posts: 876
Joined: Tue Aug 09, 2011 1:10 pm

Re: ACP: The requested page could not be found.

Post by Talk19Zehn »

Hello madscook, here you´ll find another examples ....
You have received good informations and tips and here you will find examples of further explanations ISP / cPanel / ModSecurity, if applicable and not yet known:
viewtopic.php?t=2651503
and / or
viewtopic.php?t=2651509

The update for Prosilver Dark Edition (phpBB version 3.3.11) can be found in the database:
https://www.phpbb.com/customise/db/styl ... lver_dark/

Your fresh installation shows phpbb_version = 3.3.11 and for prosilver ...
# General Information about this style
name = prosilver
copyright = © phpBB Limited, 2007
style_version = 3.3.11
phpbb_version = 3.3.11
madscook wrote: Thu Feb 29, 2024 10:24 pm Support Request Template
What version of phpBB are you using? phpBB 3.3.9
...(...)...
So phpBB 3.3.9 is not or no more relevant, I think. :)

Best wishes and success

Edit: 02 Mar 2024, 15:20
ModSecurity: Please ask your host if required (?).
Best regards
phpBB3 Designs - My own works: Stylearea Ongray-Designs, Adventinducement-Calendar for phpBB
madscook
Registered User
Posts: 5
Joined: Thu Feb 29, 2024 10:13 pm

Re: ACP: The requested page could not be found.

Post by madscook »

Thank you very much Talk19Zehn and warmweer this solved my problem! I can now access ACP again
- I have also updated the style to version 3.3.11.
- I have also changed the version number in my first post so it reflect the correct version number.

I will talk with my ISP about the mod security issue and what can be done to work around it. Maybe PhpBB must do a upgrade on their end?

Thanks again, Mads
User avatar
Mick
Support Team Member
Support Team Member
Posts: 26702
Joined: Fri Aug 29, 2008 9:49 am

Re: ACP: The requested page could not be found.

Post by Mick »

It’s not a phpBB issue it’s a server setup problem. They need to find what is triggering mod_security and adjust it accordingly.
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel©
🇬🇧
User avatar
timelessbeing
Registered User
Posts: 171
Joined: Fri Jul 02, 2010 9:27 pm

Re: ACP: The requested page could not be found.

Post by timelessbeing »

Same problem here. Suddenly unable to access ACP.
I've tried purging site data, and even using a different browser, with no change.
Server error log contains loads of gibberish (see below), but it's all old. Nothing from today.
(it's probably because for the last month or so my server is being pummelled by Russian bot registrations, but StopForumSpam extension is doing a good job of rejecting them.)
I am on a shared server. I don't see any options to disable mod_security or PHP Immunity.
What do I do?
I've sent a ticket to my host. Waiting to hear back what they'll say ...

Code: Select all

[Wed Feb 28 17:50:34.918834 2024] [security2:error] [pid 363138] [client 37.19.195.77:48828] [client 37.19.195.77] ModSecurity: Warning. Pattern match "(\\\\/(images|img(s)?|pictures|upload(s)?)\\\\/[^\\\\.]{0,108}\\\\.(pht|phtml|php\\\\d?$))" at REQUEST_URI. [file "/etc/apache2/conf.d/modsec_vendor_configs/imunify360-full-apache/012_i360_1_infectors.conf"] [line "74"] [id "77140878"] [msg "IM360 WAF: Infectors: Suspicious access attempt (webshell)!||MVN:REQUEST_URI||WPU:||T:APACHE||MV:/wp-admin/images/atomlib.php||SC:/home/exekfd/public_html/wp-admin"] [severity "DEBUG"] [tag "service_i360custom"] [hostname "astrosafarivans.org"] [uri "/wp-admin/images/atomlib.php"] [unique_id "Zd-4uvycLe5JfbfzBVigRAAAAFE"]
[Wed Feb 28 10:23:47.224408 2024] [security2:error] [pid 3785614] [client 64.252.195.7:64518] [client 64.252.195.7] ModSecurity: Warning. Match of "rx ^$" against "FILES_TMPNAMES:fileupload" required. [file "/etc/apache2/conf.d/modsec_vendor_configs/imunify360-full-apache/013_i360_filescan.conf"] [line "43"] [id "77317957"] [msg "IM360 WAF: Track file upload||MV:/tmp//20240228-102343-Zd9P_wLq-V-1jb27A8-gWQAAAAs-file-AshiFn||Size:1496484||User:exekfd||SC:/home/exekfd/public_html/chevygmcvans/posting.php||WPU:||T:APACHE||"] [severity "NOTICE"] [tag "service_im360"] [tag "noshow"] [hostname "www.chevygmcvans.com"] [uri "/posting.php"] [unique_id "Zd9P_wLq-V-1jb27A8-gWQAAAAs"], referer: http://www.chevygmcvans.com/posting.php?f=20&mode=post&sid=f7ab64734c8bdcbcdff0ea952f519f55
[Wed Feb 28 10:23:47.224319 2024] [security2:error] [pid 3785614] [client 64.252.195.7:64518] [client 64.252.195.7] ModSecurity: Warning. Match of "rx ^$" against "FILES:fileupload" required. [file "/etc/apache2/conf.d/modsec_vendor_configs/imunify360-full-apache/013_i360_filescan.conf"] [line "43"] [id "77317957"] [msg "IM360 WAF: Track file upload||MV:image0.jpeg||Size:1496484||User:exekfd||SC:/home/exekfd/public_html/chevygmcvans/posting.php||WPU:||T:APACHE||"] [severity "NOTICE"] [tag "service_im360"] [tag "noshow"] [hostname "www.chevygmcvans.com"] [uri "/posting.php"] [unique_id "Zd9P_wLq-V-1jb27A8-gWQAAAAs"], referer: http://www.chevygmcvans.com/posting.php?f=20&mode=post&sid=f7ab64734c8bdcbcdff0ea952f519f55
You do not have the required permissions to view the files attached to this post.
Last edited by timelessbeing on Mon Mar 04, 2024 6:26 am, edited 1 time in total.
User avatar
timelessbeing
Registered User
Posts: 171
Joined: Fri Jul 02, 2010 9:27 pm

Re: ACP: The requested page could not be found.

Post by timelessbeing »

hosting tech support fixed the issue by disabling some rule.
The mod_sec user ID is 77350314. The WAF ruleset is "IM360 WAF: Path traversal attack". I have disabled the mod_sec check for your account.

Return to “[3.3.x] Support Forum”