After upgrade from 3.0.11 to 3.3.11, no default phpbb avatar

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
Brf
Support Team Member
Support Team Member
Posts: 53447
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}

Re: After upgrade from 3.0.11 to 3.3.11, no default phpbb avatar

Post by Brf »

Mick wrote: Fri Mar 22, 2024 9:27 am
wonder_wonder wrote: Fri Mar 22, 2024 8:36 amIt hasn't worked
You have to upload a ‘no avatar’ image for the group first.
There is already a no_avatar.gif as part of prosilver and a no-avatar class in the viewtopic template. I wonder why that image was not wired into the class in the CSS.
User avatar
cabot
Registered User
Posts: 721
Joined: Sat Jan 07, 2012 4:16 pm

Re: After upgrade from 3.0.11 to 3.3.11, no default phpbb avatar

Post by cabot »

Hello,
wonder_wonder wrote: Fri Mar 22, 2024 8:36 am but I don't like touching the code in the phpbb files
If you're interested, I've just created a simple little extension that displays the no_avatar.gif image in topics and pm's if the user hasn't selected an avatar.
https://github.com/cabot/defaultavatar
wonder_wonder
Registered User
Posts: 100
Joined: Thu Feb 16, 2017 2:52 pm

Re: After upgrade from 3.0.11 to 3.3.11, no default phpbb avatar

Post by wonder_wonder »

Brf wrote: Fri Mar 22, 2024 12:43 pm
Mick wrote: Fri Mar 22, 2024 9:27 am
You have to upload a ‘no avatar’ image for the group first.
There is already a no_avatar.gif as part of prosilver and a no-avatar class in the viewtopic template. I wonder why that image was not wired into the class in the CSS.
If I understood correctly (my English is not very good) I think the same as you, there is already a no_avatar.gif as part of prosilver and a no-avatar class in the viewtopic template, then, why was that image not connected to the class in CSS? I think it should appear...
cabot wrote: Sat Mar 23, 2024 12:38 pm Hello,
wonder_wonder wrote: Fri Mar 22, 2024 8:36 am but I don't like touching the code in the phpbb files
If you're interested, I've just created a simple little extension that displays the no_avatar.gif image in topics and pm's if the user hasn't selected an avatar.
https://github.com/cabot/defaultavatar
Thanks for the link, I'm going to try it.

Anyway, doing what they mentioned above works, I delete the current "no_avatar.gif", select the image "no_avatar.gif" and set it to the group, then it is shown everywhere.

I make a comparison with the fresh install from 3.3.11 and the one upgraded from 3.0.11 and everything is exactly the same. In one it shows (the fresh install) the other does not
User avatar
Mick
Support Team Member
Support Team Member
Posts: 26639
Joined: Fri Aug 29, 2008 9:49 am

Re: After upgrade from 3.0.11 to 3.3.11, no default phpbb avatar

Post by Mick »

Brf wrote: Fri Mar 22, 2024 12:43 pmI wonder why that image was not wired into the class in the CSS
For some reason or other I only just noticed that the default user avatar is used in the notifications drop down so maybe that image was only added with the introduction of 3.1 and notifications and not considered to be added generally?
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel
wonder_wonder
Registered User
Posts: 100
Joined: Thu Feb 16, 2017 2:52 pm

Re: After upgrade from 3.0.11 to 3.3.11, no default phpbb avatar

Post by wonder_wonder »

Mick wrote: Sat Apr 20, 2024 7:39 am
Brf wrote: Fri Mar 22, 2024 12:43 pmI wonder why that image was not wired into the class in the CSS
For some reason or other I only just noticed that the default user avatar is used in the notifications drop down so maybe that image was only added with the introduction of 3.1 and notification and not considered to be added generally?
I did the test, before this conversion, I had phpbb installed since 2018, so I think it was version 3.2 that I was upgrading to the latest one we are on.
Now I don't have that forum, because with the conversion, the previous one was deleted (its database of course) and after conversion, I left the converted one (which was my initial idea) that first one that I installed in 2018 was for testing.

In that forum, the avatar in general terms was by default, now you are making me doubt whether or not I added it to the groups, I cannot confirm that 100%, but I would swear not...

I have solved it, I have added the "no_avatar" image to the groups, so the user who does not have an avatar will appear that one by default.
If I enter the group and delete it, although it appears in the group (in ACP), the user stops showing said avatar.

Without going any further, if you indicate this, it will be like that, you are the ones who know this best, I would swear that in the one I installed in 2018 the avatar already came by default in general terms (I am referring to the "no_avatar") but... .there is the possibility that I added them as I have done in the converted, I would swear not but...my memory does not extend to that...

PS: Sorry for my bad english
User avatar
Mick
Support Team Member
Support Team Member
Posts: 26639
Joined: Fri Aug 29, 2008 9:49 am

Re: After upgrade from 3.0.11 to 3.3.11, no default phpbb avatar

Post by Mick »

wonder_wonder wrote: Sat Apr 20, 2024 1:08 pm...my memory does not extend to that…
Neither does mine, it usually fits in the ‘shot to bits’ category. Please don’t apologise for your English it’s most certainly better than me trying to speak your home language ;)

Anyway, maybe a dev will pass by who knows the answer.
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel
wonder_wonder
Registered User
Posts: 100
Joined: Thu Feb 16, 2017 2:52 pm

Re: After upgrade from 3.0.11 to 3.3.11, no default phpbb avatar

Post by wonder_wonder »

Mick wrote: Sat Apr 20, 2024 1:29 pm
wonder_wonder wrote: Sat Apr 20, 2024 1:08 pm...my memory does not extend to that…
Neither does mine, it usually fits in the ‘shot to bits’ category. Please don’t apologise for your English it’s most certainly better than me trying to speak your home language ;)

Anyway, maybe a dev will pass by who knows the answer.
Hehehe, yes, it fits perfectly in the 'shot to bits' category :)
If you know what my native language is, confirm that my English is horrible... your words are appreciated.

Although maybe a dev will pass by who knows the answer, it hasn't been a major problem, I have proceeded as advised in this topic, I have gone to each group, I have added the image manually and it works, the "no_avatar" appears users who do not have an avatar (in general mode, not just in notifications).

But yes, if they solve this doubt for us... already from the memory part, you made me doubt, I would swear not but... now I doubt if I did it in the clean installation or not...

Grateful :)

Return to “[3.3.x] Support Forum”