Upgrading from 3.2.9 to 3.3.x when board is not working

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
DominusExult
Registered User
Posts: 8
Joined: Tue May 19, 2020 9:16 am

Upgrading from 3.2.9 to 3.3.x when board is not working

Post by DominusExult »

So we retired our old board but left it running to conserve the old messages. Now the host updated to php to 8.2 and the board is no longer working.

Following https://www.phpbb.com/support/docs/en/3 ... upgrade32/ should give me a working forum back I guess :)

Problem is that I can't do anything that requires a working board
Deactivate all styles except for prosilver

Deactivate any extensions which are not compatible with phpBB 3.3. Check with the extension author to find out if an extension is compatible or not.

Set British English as the only language pack
What's the advice there? Just wing it (of course backing up the database and forum as it is) and hope it works?
User avatar
Mick
Support Team Member
Support Team Member
Posts: 26712
Joined: Fri Aug 29, 2008 9:49 am

Re: Upgrading from 3.2.9 to 3.3.x when board is not working

Post by Mick »

Please fill out the Support Request Template and post it back here to enable us to assist you better.
DominusExult wrote: Thu Apr 04, 2024 10:18 pmFollowing upgrade32/ should give me a working forum back I guess
Yes.

Knowledge Base - Disabling all extensions at once will get you over the extension part. What style and language packs are you using?

The easiest would be if your host is willing to drop the PHP version back to your original version or similar temporarily while you tidy things up? In some (most these days) hosting packages you can do that yourself. If they can’t/won’t you could always follow Installing and Setting Up Your Own Web Server and import your backup in to that, carry out the upgrade then transfer it back to your domain. Knowledge Base - Transferring Your Board to a New Host or Domain should help with that.

It would be helpful in future if your host didn’t just upgrade PHP versions without first giving you a couple of weeks to sort your end out.
  • "The more connected we get the more alone we become" - Kyle Broflovski©
  • "The good news is hell is just the product of a morbid human imagination.
    The bad news is, whatever humans can imagine, they can usually create.
    " - Harmony Cobel©
🇬🇧
DominusExult
Registered User
Posts: 8
Joined: Tue May 19, 2020 9:16 am

Re: Upgrading from 3.2.9 to 3.3.x when board is not working

Post by DominusExult »

Thank you!

This whole situation is mostly my own fault. The host is SourceForge and we have a project there and we were able to get a secured Vhost which required us switching to their more secure infrastructure which uses PHP 8.x.
As our forum is in observatory mode only I kind of forgot about it (and in the back of my mind, I thought it was compatible with PHP8).


I'll take the advice of transferring it to my own server, upgrade and then retransfer it. Though we were not using any plugins except the STK one and no extra styles but ours was a bit adapted.

Return to “[3.2.x] Support Forum”