Error on Line 1617

Get help with installation and running phpBB 3.3.x here. Please do not post bug reports, feature requests, or extension related questions here.
abrogard
Registered User
Posts: 342
Joined: Tue May 24, 2005 8:32 am
Location: australia
Name: arthur brogard

Error on Line 1617

Post by abrogard »

I get this when trying to create a new user after inputting username, password:

------------------------------------------------------------------
phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_messenger.php on line 1617: stream_socket_enable_crypto(): Peer certificate CN=`mboxhosting.com' did not match expected CN=`mail.mblforum.com'

Warning: Cannot modify header information - headers already sent by (output started at /srv/disk6/1393753/www/mblforum.com/forum/includes/functions.php:3035) in /srv/disk6/1393753/www/mblforum.com/forum/includes/functions.php on line 4150

Warning: Cannot modify header information - headers already sent by (output started at /srv/disk6/1393753/www/mblforum.com/forum/includes/functions.php:3035) in /srv/disk6/1393753/www/mblforum.com/forum/includes/functions.php on line 4150

Warning: Cannot modify header information - headers already sent by (output started at /srv/disk6/1393753/www/mblforum.com/forum/includes/functions.php:3035) in /srv/disk6/1393753/www/mblforum.com/forum/includes/functions.php on line 4150

Warning: Cannot modify header information - headers already sent by (output started at /srv/disk6/1393753/www/mblforum.com/forum/includes/functions.php:3035) in /srv/disk6/1393753/www/mblforum.com/forum/includes/functions.php on line 4150
MBLForum

For Library/Book/Literature/Literacy Lovers Everywhere/Anywhere

Skip to content
------------------------------------------------------------------------
and the message to the new user never arrives.

Anyone know how I can fix it?

p.s. I think we can rule out problems with the host because I just started a new board on the same host and registered a new user on it with no problems.


:)
User avatar
Mike-on-Tour
Registered User
Posts: 482
Joined: Wed Jan 15, 2020 3:51 pm
Location: Germany
Name: Michael

Re: Error on Line 1617

Post by Mike-on-Tour »

Would be nice to know what versions of phpBB you are refering to and what PHP version it is your board is running on. As a first guess I would say that your e-mail functionality isn't set up properly.
Watz fo lunch?
If you like my extensions or my support please consider a donation: Image
abrogard
Registered User
Posts: 342
Joined: Tue May 24, 2005 8:32 am
Location: australia
Name: arthur brogard

Re: Error on Line 1617

Post by abrogard »

the board is 3.3.11
and php is 7.4.33
if it is any help at all I can tell you the board, of course: mblforum.com

:)
User avatar
Mike-on-Tour
Registered User
Posts: 482
Joined: Wed Jan 15, 2020 3:51 pm
Location: Germany
Name: Michael

Re: Error on Line 1617

Post by Mike-on-Tour »

Thanks, just tried it. It gives me the PHP warning but no e-mail. My best guess (I am no server expert) still is a mis-configuration of your (safe) e-mail account.
Watz fo lunch?
If you like my extensions or my support please consider a donation: Image
User avatar
ssl
Registered User
Posts: 1725
Joined: Sat Feb 08, 2020 2:15 pm
Location: Le Lude, Pays de la Loire - France
Name: Fred Rimbert

Re: Error on Line 1617

Post by ssl »

Would you please read this topic: viewtopic.php?t=2652586
Sorry for my English ... I do my best!

phpBB: 3.3.11 | PHP: 8.2.16
[Kill spam on phpBB] - [Some French translation of extensions]
"Mistress, Mistress someone is bothering me in pm"
abrogard
Registered User
Posts: 342
Joined: Tue May 24, 2005 8:32 am
Location: australia
Name: arthur brogard

Re: Error on Line 1617

Post by abrogard »

Could you please read this topic: viewtopic.php?t=2652586
Sorry for my English ... I do my best!

Yep. Read it. Has different line numbers but could well be the answer I guess.

I'll have to look at it tomorrow when I'm fresh and see if I can figure something out. Thanks for that. :)
User avatar
Brf
Support Team Member
Support Team Member
Posts: 53446
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}

Re: Error on Line 1617

Post by Brf »

ssl wrote: Tue Apr 16, 2024 9:53 am Would you please read this topic: viewtopic.php?t=2652586
I am not sure why you would point to that topic. The OP for this topic is already pointing to the first error line, which is
abrogard wrote: Tue Apr 16, 2024 8:37 am /includes/functions_messenger.php on line 1617:
The error says the certificate for the server (mboxhosting.com) does not match the URL being used (mail.mblforum.com)
User avatar
ssl
Registered User
Posts: 1725
Joined: Sat Feb 08, 2020 2:15 pm
Location: Le Lude, Pays de la Loire - France
Name: Fred Rimbert

Re: Error on Line 1617

Post by ssl »

Brf wrote: Tue Apr 16, 2024 1:47 pm I am not sure why you would point to that topic.
Because I completely forgot the first error line.
Sorry for my English ... I do my best!

phpBB: 3.3.11 | PHP: 8.2.16
[Kill spam on phpBB] - [Some French translation of extensions]
"Mistress, Mistress someone is bothering me in pm"
User avatar
warmweer
Jr. Extension Validator
Posts: 11366
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Bel ... gium

Re: Error on Line 1617

Post by warmweer »

You still need to set cookie_secure to true, and redirect to https in .htaccess.
+ clean up the board and delete the agrorussian user and his posts (and probably also other spam accounts)
Spelling is freeware, which means you can use it for free.
On the other hand, it is not open source, which means you cannot change it or publish it in a modified form.


Time flies like an arrow, but fruit flies like a banana.
User avatar
EA117
Registered User
Posts: 2162
Joined: Wed Aug 15, 2018 3:23 am

Re: Error on Line 1617

Post by EA117 »

abrogard wrote: Tue Apr 16, 2024 8:37 am phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_messenger.php on line 1617: stream_socket_enable_crypto(): Peer certificate CN=`mboxhosting.com' did not match expected CN=`mail.mblforum.com'
It appears you have SMTP setup to use TLS/SSL with "Verify SMTP peer name" enabled in the phpBB SMTP settings, but the host mail.mblforum.com resolves to is setup with a certificate issued to mboxhosting.com and not mail.mblforum.com.

The quick workaround would be to simply turn off "Verify SMTP peer name", and live with the slightly weakened security posture of not being able to verify the host is whom you expected. And maybe that's the long term solution too, if you find you don't have control over how that certificate is provisioned.

If your host provides PHP "mail()" function support, another workaround or long term solution could be to just turn off SMTP use by phpBB, and instead rely on using the PHP mail() function support provided by your host.

Only your hosting provider could tell you for sure whether you (or they) are able to change the certificate to match the DNS name of the server. Or whether there is a different DNS name provided by your host you could use for SMTP, which would match the configured certificate.

If you installed a different phpBB instance on this same server and it doesn't demonstrate the same behavior, then I would have to guess this second instance is not configured to use SMTP, or is using a different SMTP server, or isn't configured to use SSL/TLS for SMTP, or doesn't have "Verify SMTP peer name" enabled.
abrogard
Registered User
Posts: 342
Joined: Tue May 24, 2005 8:32 am
Location: australia
Name: arthur brogard

Re: Error on Line 1617

Post by abrogard »

EA117 wrote: Tue Apr 16, 2024 8:41 pm
I checked with the new board and saw it does not use SMTP so I turned it off on mblforum too.
And then it sent the 'welcome' verification message without error.
But it never arrived.
I created another new user to make sure and the same: all apparently okay but never arrived.
My new user email addresses all go via a filter to I created yet another that did not go via a filter but came straight to me.
It didn't arrive either.

I sent 'test email' from both boards.
Nothing arrived from either.

I created another new user on the 'good' board just to make sure it is okay, wholly and sure enough, it worked.
I tested that new user by logging him in. No problems.

So: Test messages do not arrive from either board.
Verify emails from mblforum do not arrive. So cannot complete the new registration process.

Gets tedious and challenging thinking up new users and emails. Is there an easier way?
abrogard
Registered User
Posts: 342
Joined: Tue May 24, 2005 8:32 am
Location: australia
Name: arthur brogard

Re: Error on Line 1617

Post by abrogard »

warmweer wrote: Tue Apr 16, 2024 4:23 pm You still need to set cookie_secure to true, and redirect to https in .htaccess.
+ clean up the board and delete the agrorussian user and his posts (and probably also other spam accounts)
Yep. I know. It is still a big mess isn't it? I cleaned up the root dir though, did that much. :)

Got to get these basics organised first: will it take new users, will it accept posts...
abrogard
Registered User
Posts: 342
Joined: Tue May 24, 2005 8:32 am
Location: australia
Name: arthur brogard

Re: Error on Line 1617

Post by abrogard »

An email just arrived from saconveyancer congratulating me on the board being correctly set up. That's not the 'test email' is it? we write the contents of that ourselves don't we? so where's it from, what caused it?
User avatar
EA117
Registered User
Posts: 2162
Joined: Wed Aug 15, 2018 3:23 am

Re: Error on Line 1617

Post by EA117 »

abrogard wrote: Tue Apr 16, 2024 11:20 pm An email just arrived from saconveyancer congratulating me on the board being correctly set up. That's not the 'test email' is it?
Yes, the "Send a test email" button in ACP sends a message containing at minimum "Congratulations. If you received this email, phpBB is correctly configured to send emails." Whatever you put into the additional "Message" box under the "Send a test email" button, if anything, will appear as an additional paragraph in the test email. This free-form additional "Message" content allows you to keep track of which test you actually successfully received, by allowing you to put information such as "Test at 13:30" or "Test after turning off Verify SMTP peer name" into the actual test email.

Agreed that "the other phpBB board instance was not attempting to use SMTP" is only the answer to "why I wasn't getting the same PHP Warning", and is not an indication of what SMTP or PHP mail() configuration will be required in order to successfully send email from the server where your phpBB instances are being hosted.

Consulting with your host or at least their documentation may be necessary to determine what exactly they expect or require for PHP applications running on their servers to send email, whether by SMTP or using the PHP mail() function. e.g. Your host might require that you're using a particular "From:" address in order to allow the mail through on PHP mail(); or maybe they do require or specifically do not support TLS/SSL for the internal SMTP server; maybe they expect you to use "localhost" as the DNS name instead of their "external" SMTP server, etc.

No one answer is correct for everyone, and you have to determine what your host provides or requires. Sometimes they can be pretty picky or non-obvious, because your host is trying to prevent their servers from being used to generate spam email. You can of course just keep randomly testing until you find something that works, if the host or their documentation is not particularly helpful. Don't share any passwords, but if you share what your host's documentation declares regarding the configuration needed for a PHP-based application to send email from their servers, we may be able to help with additional more specific suggestions.

Using the "Send a test email" is sufficient for testing whether or not the emails "are going through at all" based on the current phpBB email settings. Once you determine the SMTP or PHP mail() settings that allow the test mail to arrive consistently, then you can move on to testing actual user creation and the notification email expected in that situation. I've normally just deleted the test user and then tr-registered exactly the same username and email again, as opposed to accumulating multiple unique test user accounts.
abrogard
Registered User
Posts: 342
Joined: Tue May 24, 2005 8:32 am
Location: australia
Name: arthur brogard

Re: Error on Line 1617

Post by abrogard »

Excellent. Thank you for all that. I'll peruse and learn at leisure.
But it seems saconveyancer is totally set up fine.
It is only about a week old and should be the same version as mblforum
saconveyancer was installed with an absolute minimum of configuring. it just about as it comes, right out of the box.
with that version then could I perhaps get it to do an automatic reinstall and see what that does? such a think possible?
I think the later versions do auto updates don't they? so will they do auto reinstall?

Return to “[3.3.x] Support Forum”