Up to php 4.1.0 now allowed for MODs in the database

This forum is now closed as part of retiring phpBB2.
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

This forum is now closed due to phpBB2.0 being retired.
Post Reply
wGEric
Former Team Member
Posts: 8805
Joined: Sun Oct 13, 2002 3:01 am
Location: Friday
Name: Eric Faerber
Contact:

Up to php 4.1.0 now allowed for MODs in the database

Post by wGEric » Sun Mar 13, 2005 11:31 pm

We, the MOD Team, have decided to allow php4 functionality, up to and including 4.1.0, but nothing later for MODs submitted to the MOD Database. This is because phpBB 2.0.13 uses some php 4 only code and we want MODs to be written for the same version of php that phpBB requires.

This means you can use any functions or other things in php that are included in php 4.1.0. If you require anything higher or anything that isn't part of the default php installation (GD Libraries, Imagemagick, etc) you need to say so in the author notes.

We will not be allowing the short version of variables ($_POST, $_GET, etc). This is so that MODs stay consistent with the way phpBB is coded.
Eric

Post Reply

Return to “[2.0.x] MOD Writers Discussion”