Domain name forwarding to PHPBB question

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
Y2kGoofball
Registered User
Posts: 64
Joined: Wed Jul 23, 2003 10:03 pm

Domain name forwarding to PHPBB question

Post by Y2kGoofball » Fri Mar 18, 2005 5:21 am

ok this is kind of a carry on from a previous question

My PHPBB is hosted by a free host, and is http:xxxxxxxxxxxxxx

Ive brought a domain name and forwarding package, xxxxxxxxxxxxxx

When my members use xxxxxxxxxxxxxx to access the forum they are logged out. Naturally they log in and away they go. BUT when they leave the forum and come back later via xxxxxxxxxxx, their logged out??

If they go in via the direct link (exoboards.com) and chose to stay logged in, it keeps them logged in.

Ive been told
Posted: Tue Mar 15, 2005 12:41 am Post subject:

--------------------------------------------------------------------------------

No problem--don't we all have those days!

Open your admin panel->General Admin->Configuration
Use:
Cookie domain: .v8superforum.exoboards.com (notice the dot in front)
Cookie name: v8superforum
Cookie path: /
Cookie secure: disabled
Session length: 3600
Log out, clear your browser's cookies, and try again.
Also make sure your domain name is v8superforum.exoboards.com and your script path is /


This works, if I go to xxxxxxxxxxxxand log in, then go to another website like www.phpbb.com and then go to xxxxxxxxxx I'm logged in (before doing that it would log me out) however, if I close the internet explorer browser and come back it logs me out

I'm assuming theres something with the domain name.

Is there anything I need to do if I am using a domain name to forward to my boards?

I'm really stuck and its started to annoy some members who have went walking never to come back, which no forum needs or wants to see!

Cheers

Matt

flogger12
Registered User
Posts: 14936
Joined: Tue Nov 25, 2003 2:13 am

Post by flogger12 » Fri Mar 18, 2005 5:54 am

the problem is that the board has to know where it really is, it doesn't like the redirects , you have to either use the actual url to the board and go there using that url or you have to be able to have the domain name resolve to where the board is. not redirect but resolve. and that means host the board somewhere that lets you use your domain name. and that usually means paying for it.

sorry,
robert

Y2kGoofball
Registered User
Posts: 64
Joined: Wed Jul 23, 2003 10:03 pm

Post by Y2kGoofball » Fri Mar 18, 2005 6:00 am

thanks dude, that answers my question!

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom » Fri Mar 18, 2005 6:23 am

You can force the redirect... Add this to the begining of your index.php file (right after the version comments), and it will direct them straight to the URL the server wants to use. If you've configured that to be the new domain, well then that's just right! :)

Code: Select all

if ($_SERVER["HTTP_HOST"] != $_SERVER["SERVER_NAME"])
{
   header("Location: http://". $_SERVER["SERVER_NAME"] . $_SERVER["REQUEST_URI"]);
   die();
}
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

juiced
Registered User
Posts: 204
Joined: Sat Nov 27, 2004 9:23 am
Contact:

Post by juiced » Tue Apr 26, 2005 11:45 pm

dumb question, but can you define the variables for me to change?
Image
Do your part in the environment! The best investment for your kids & future.

dwntwn87
Registered User
Posts: 27
Joined: Fri May 20, 2005 8:08 pm

Re: Domain name forwarding to PHPBB question

Post by dwntwn87 » Fri May 27, 2005 2:34 am

Posted: Tue Mar 15, 2005 12:41 am Post subject:

--------------------------------------------------------------------------------

No problem--don't we all have those days!

Open your admin panel->General Admin->Configuration
Use:
Cookie domain: .v8superforum.exoboards.com (notice the dot in front)
Cookie name: v8superforum
Cookie path: /
Cookie secure: disabled
Session length: 3600
Log out, clear your browser's cookies, and try again.
Also make sure your domain name is v8superforum.exoboards.com and your script path is /



This works, if I go to www.v8superforum.com and log in, then go to another website like www.phpbb.com and then go to www.v8superforum.com I'm logged in (before doing that it would log me out) however, if I close the internet explorer browser and come back it logs me out


I am having the same problem as described here and I have a domain name that redirects to another however, I can't get mine fixed.

The domain for people to type in is http://www.matureadultgamers.com which gets redirected to http://www.linkdesignz.com/mag but maintains http://www.matureadultgamers.com in the browser.

My current settings are below.
Domain name: www.linkdesignz.com
Script path: /mag/
Cookie domain: [empty]
Cookie name: phpbbmysql
Cookie path: /
Cookie secure: disabled
Session length: 3600

I have tried chaning my cookie domain and path to a few different scenarios but I don't think I'm picking the right configuration. Can someone help?

dwntwn87
Registered User
Posts: 27
Joined: Fri May 20, 2005 8:08 pm

Post by dwntwn87 » Fri May 27, 2005 3:07 am

Anyone got an idea?

Andromeda16
Registered User
Posts: 87
Joined: Fri Jun 10, 2005 2:02 am
Contact:

Post by Andromeda16 » Sun Jun 12, 2005 7:11 am

espicom wrote: You can force the redirect... Add this to the begining of your index.php file (right after the version comments), and it will direct them straight to the URL the server wants to use. If you've configured that to be the new domain, well then that's just right! :)

Code: Select all

if ($_SERVER["HTTP_HOST"] != $_SERVER["SERVER_NAME"])
{
   header("Location: http://". $_SERVER["SERVER_NAME"] . $_SERVER["REQUEST_URI"]);
   die();
}


Is there anything you need to enter into that code that is specific to your forums?

Andromeda16
Registered User
Posts: 87
Joined: Fri Jun 10, 2005 2:02 am
Contact:

Post by Andromeda16 » Mon Jun 13, 2005 6:27 am

Anyone?

Demian
Registered User
Posts: 1
Joined: Tue Nov 27, 2007 12:48 am

Re: Domain name forwarding to PHPBB question

Post by Demian » Wed Nov 28, 2007 9:53 am

Hi,

It worked for me too!

Thanks a lot!!

:)

Y2kGoofball wrote:ok this is kind of a carry on from a previous question

My PHPBB is hosted by a free host, and is http:xxxxxxxxxxxxxx

Ive brought a domain name and forwarding package, xxxxxxxxxxxxxx

When my members use xxxxxxxxxxxxxx to access the forum they are logged out. Naturally they log in and away they go. BUT when they leave the forum and come back later via xxxxxxxxxxx, their logged out??

If they go in via the direct link (exoboards.com) and chose to stay logged in, it keeps them logged in.

Ive been told
Posted: Tue Mar 15, 2005 12:41 am Post subject:

--------------------------------------------------------------------------------

No problem--don't we all have those days!

Open your admin panel->General Admin->Configuration
Use:
Cookie domain: .v8superforum.exoboards.com (notice the dot in front)
Cookie name: v8superforum
Cookie path: /
Cookie secure: disabled
Session length: 3600
Log out, clear your browser's cookies, and try again.
Also make sure your domain name is v8superforum.exoboards.com and your script path is /


This works, if I go to xxxxxxxxxxxxand log in, then go to another website like http://www.phpbb.com and then go to xxxxxxxxxx I'm logged in (before doing that it would log me out) however, if I close the internet explorer browser and come back it logs me out

I'm assuming theres something with the domain name.

Is there anything I need to do if I am using a domain name to forward to my boards?

I'm really stuck and its started to annoy some members who have went walking never to come back, which no forum needs or wants to see!

Cheers

Matt

Locked

Return to “2.0.x Support Forum”