[2.0.19] Inline Spoiler Tag

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
3
75%
Very Good
1
25%
Good
0
No votes
Fair
0
No votes
Poor
0
No votes
 
Total votes: 4

Extensions Robot
Extensions Robot
Extensions Robot
Posts: 25307
Joined: Sat Aug 16, 2003 7:36 am

[2.0.19] Inline Spoiler Tag

Postby Extensions Robot » Sun Feb 12, 2006 8:38 pm

MOD Name: Inline Spoiler Tag
Author: ahwm
MOD Description: Adds a unique spoiler tag that is black text inline with the original message posted by the user. Optional "mouseover to view" version included as well. [spoiler] Spoiler Text [/spoiler]


MOD Version: 1.0.1

Download File: inline spoiler 1.0.1.zip
mods overview page: View
File Size: 4391 Bytes

Security Score: 0

Support for this MOD needs to be asked within this topic. The phpBB Teams are not responsible or required to give anyone support for this MOD. By installing this MOD, the phpBB Support Team or phpBB MODifications Team may not be able to provide support.

This MOD has only been tested by the phpBB MOD Team with the phpBB version in the topic title. It may not work in any other versions of phpBB.
Last edited by Extensions Robot on Mon Apr 30, 2007 12:30 am, edited 1 time in total.
(this is a non-active account manager for the phpBB Extensions Team)

User avatar
webmacster87
Former Team Member
Posts: 3758
Joined: Fri Jun 11, 2004 2:30 am
Location: San Mateo, CA
Name: Douglas Bell
Contact:

Postby webmacster87 » Mon Feb 13, 2006 2:54 am

MOD Validated/Released

Notes:
Adds a [spoiler][/spoiler] BBCode to your board which uses a black background to hide the contained text in-line with the rest of the post text.

ahwm
Registered User
Posts: 60
Joined: Thu Jan 19, 2006 5:17 am
Location: Idaho
Contact:

Postby ahwm » Mon Feb 13, 2006 3:06 am

Excellent...

Demo board: http://www.thescripters.com/forum/viewtopic.php?t=18

Guest availability. If you want to post. If not, that works too :P

It works on 2.0.16 and 2.0.19, so it should work everywhere else right? :P

Hasn't been tested on anything earlier than 2.0.16.

It does require some minor javascript, but any new browser that allows javascript should be able to use it. If you run into problems with that, try the non-mouseover version instead.

EDIT: Tested compatible with 2.0.20 as well.
Last edited by ahwm on Wed May 31, 2006 6:12 am, edited 2 times in total.
"I'm not lazy, I'm motivationally challenged"

tehbmwman
Registered User
Posts: 46
Joined: Sun Nov 20, 2005 12:12 am

Postby tehbmwman » Mon Feb 13, 2006 3:10 am

Thats pretty neat.

User avatar
niksa
Registered User
Posts: 612
Joined: Mon Sep 08, 2003 7:20 pm
Location: Future birthplace of James T. Kirk
Contact:

Postby niksa » Mon Feb 13, 2006 5:14 am

Ooo... I like it. :)
Does it work on all browswers?

ahwm
Registered User
Posts: 60
Joined: Thu Jan 19, 2006 5:17 am
Location: Idaho
Contact:

Postby ahwm » Mon Feb 13, 2006 5:21 am

niksa wrote:Ooo... I like it. :)
Does it work on all browswers?


So far it seems to....

I personally have tested it on IE 6, Firefox 1.5, Maxthon 1.5.2 Build 21.. Opera won't run on my computer... Neither will Netscape...

But it should work on all browsers...
"I'm not lazy, I'm motivationally challenged"

User avatar
DennyCrane
Registered User
Posts: 86
Joined: Mon Oct 17, 2005 3:47 am

Postby DennyCrane » Mon Feb 13, 2006 7:18 pm

can't find

$EMBB_widths = array(''
$EMBB_values = array(''


in includes/bbcode.php

:?:

ahwm
Registered User
Posts: 60
Joined: Thu Jan 19, 2006 5:17 am
Location: Idaho
Contact:

Postby ahwm » Tue Feb 14, 2006 6:45 am

dirTdogE wrote:can't find

$EMBB_widths = array(''
$EMBB_values = array(''


in includes/bbcode.php

:?:


Sorry for not getting back to you sooner.. phpBB didn't tell me someone had posted a reply here...

Anway... Do you have Multi BBCode installed? that is first required...

If you do, then open includes/bbcode.php and look for...

Code: Select all

// MULTI BBCODE-begin
function Multi_BBCode()
{
   global $template, $lang;

   // DO NOT CHANGE THIS ARRAY
   $hotkeys = array('', 'd', 'e', 'g', 'h', 'j', 'k', 'm', 'n', 'r', 't', 'v', 'x', 'y', 'z', '1', '2', '3', '4', '5', '6', '7', '8', '9', '0');

   //NOTE: the first element of each array must be ''   Add new elements AFTER the ''
   $EMBB_widths = array('','40','50','60') ;
   $EMBB_values = array('','Hide','Spoiler','XSpoiler') ;
   for ($i=1; $i<count($EMBB_values); $i++)
   {
      // load BBcode MODs info
      $val = ($i*2)+16 ;
      $help_lang = ( !empty($lang['bbcode_help'][(strtolower($EMBB_values[$i]))]) ) ? $lang['bbcode_help'][(strtolower($EMBB_values[$i]))] : $lang['bbcode_help'][$EMBB_values[$i]];
      $template->assign_block_vars('MultiBB', array(
         'KEY' => $hotkeys[$i],
         'NAME' => "addbbcode$val",
         'HELP' => sprintf($help_lang, $hotkeys[$i]),
         'WIDTH' => $EMBB_widths[$i],
         'VALUE' => $EMBB_values[$i],
         'STYLE' => "bbstyle($val)")
      );
   }
}
// MULTI BBCODE-end


if that's not there, you need to install it...

http://www.phpbb.com/phpBB/viewtopic.php?t=145513
"I'm not lazy, I'm motivationally challenged"

User avatar
Wizard_SEMFE
Registered User
Posts: 10
Joined: Tue Jun 29, 2004 11:15 pm

Postby Wizard_SEMFE » Thu Feb 16, 2006 3:57 am

ahwm wrote:
niksa wrote:Ooo... I like it. :)
Does it work on all browswers?


So far it seems to....

I personally have tested it on IE 6, Firefox 1.5, Maxthon 1.5.2 Build 21.. Opera won't run on my computer... Neither will Netscape...

But it should work on all browsers...


It works on Opera too ;)
Good Job :D
Oh my god they killed Kenny!!! You bastards!!!

Ρε θα γίνει η μάχη των μαύρων μέσα σε τούνελ!!!

ahwm
Registered User
Posts: 60
Joined: Thu Jan 19, 2006 5:17 am
Location: Idaho
Contact:

Postby ahwm » Fri Feb 24, 2006 9:02 pm

Minor update to demo board information.

We were having issues with spam so it requires logging in now.
"I'm not lazy, I'm motivationally challenged"

octoberthehottie
Registered User
Posts: 35
Joined: Fri Sep 19, 2003 7:25 pm
Contact:

Postby octoberthehottie » Tue Mar 28, 2006 7:10 am

Good job, works well, I had no compatiblitity problems as I did with another I tried, so very pleased. The only issue I had a question on was I have installed the Mod Super Quick Reply, sqr-1.3.2.mod and I was trying to no avail to add the spoiler button to the quick reply form as well, I figured out how to add the tag after the URL button, but it didn't help it display, so I am guessing I am missing something. If you have the time to figure out the modifications to add it to that as well I would be very grateful as my quick reply isn't so quick anymore.
OctoberTheHottie
www.aimxpress.net/

helluvaguy
Registered User
Posts: 155
Joined: Fri Sep 07, 2001 12:06 pm

Postby helluvaguy » Tue Mar 28, 2006 9:47 am

Is there a way to put the .spoiler statement into the .css file instead of the overal_header.tpl file?

I tried to simply put

Code: Select all

.spoiler {background: #000000; color: #000000}
into .css, but it didn't work.

Any ideas?

ahwm
Registered User
Posts: 60
Joined: Thu Jan 19, 2006 5:17 am
Location: Idaho
Contact:

Postby ahwm » Tue Mar 28, 2006 3:26 pm

I'll have to take a look this afternoon for both of you. I don't have time right this moment... But I'll see what I can do... and I guess it should go into css with no problem.. but I'm not sure why it won't...
"I'm not lazy, I'm motivationally challenged"

Archer UE
Registered User
Posts: 3
Joined: Sun Apr 30, 2006 3:23 am

Postby Archer UE » Sun Apr 30, 2006 5:35 pm

helluvaguy wrote:Is there a way to put the .spoiler statement into the .css file instead of the overal_header.tpl file?

I tried to simply put

Code: Select all

.spoiler {background: #000000; color: #000000}
into .css, but it didn't work.

Any ideas?


That's odd, I did exactly the same thing and it worked perfectly fine for me.

helluvaguy
Registered User
Posts: 155
Joined: Fri Sep 07, 2001 12:06 pm

Postby helluvaguy » Sun Apr 30, 2006 5:40 pm

What template are you useing? Where exactly did you put it? Could you post the surrounding code area?


Return to “[2.0.x] MOD Database Releases”

Who is online

Users browsing this forum: No registered users and 8 guests