What could cause Question marks on templates (?'s)?

This forum is now closed. Please ask all styles-related questions in the phpBB 3.0 Styles Support & Discussion Forum.
Locked
JuanJohnSilver
Registered User
Posts: 10
Joined: Tue Mar 20, 2007 9:06 pm

What could cause Question marks on templates (?'s)?

Post by JuanJohnSilver »

I installed DAJ Glass, and around some of the item on the index there are ?'s, when I remove <span.... that are around the Text it doesn't show the marks anymore, but the font changes since the it was <span class:...

Is there anyway around this to fix it? Doesn't happen on other templates (maybe very few of them have question marks, but the majority do not).
Thatbitextra
Former Team Member
Posts: 7604
Joined: Mon Mar 21, 2005 5:04 am
Location: A place where something is or could be located; a site.
Contact:

Re: What could cause Question marks on templates (?'s)?

Post by Thatbitextra »

What are you using to edit it?
Styles KB
My MODs: Choose Who to Accept PMs From (Prevents unwanted PMs!) | Warn of Old Topic Before Posting Reply
Style: subBlack (Now updated to phpBB 2.0.22 and 5 new color schemes!)
JuanJohnSilver
Registered User
Posts: 10
Joined: Tue Mar 20, 2007 9:06 pm

Re: What could cause Question marks on templates (?'s)?

Post by JuanJohnSilver »

Dreamweaver 8, they dont show in dreamweaver but show in both IE and firefox
User avatar
Arty
Former Team Member
Posts: 16654
Joined: Wed Mar 06, 2002 2:36 pm
Name: Vjacheslav Trushkin
Contact:

Re: What could cause Question marks on templates (?'s)?

Post by Arty »

Don't use dreamweaver, frontpage, or any other WYSIWYG editor. They mess up code. Get EditPlus or TextPad instead.
Vjacheslav Trushkin / Arty.
Free phpBB 3.1 styles | New project: Iconify - modern SVG framework
smitjel
Registered User
Posts: 461
Joined: Sat Jun 11, 2005 11:40 pm
Location: Birmingham, AL

Re: What could cause Question marks on templates (?'s)?

Post by smitjel »

I can confirm this behavior from DAJ Glass. It's not your editor. The author put non-standard symbols in his template files. You'd have to go through each template file and delete those characters one by one to resolve the issue. I went through and corrected overall_header and overall_footer to prove it...kinda not worth it though, however good it looks.

This is what it looks like for me (running Firefox on Fedora linux):
Image
My Quick Reply MOD for phpBB2
Pada
Registered User
Posts: 2
Joined: Thu Mar 16, 2006 2:29 pm

Re: What could cause Question marks on templates (?'s)?

Post by Pada »

I've used Crimson Editor to replace the following characters in all the .tpl files with their associated HTML Entity codes:
  • ALT+0160 ( ) with &nbsp;
    ALT+0171 («) with &laquo;
    ALT+0187 (») with &raquo;
    ALT+0169 (©) with &copy;
It is possible that more of these characters exist.
See http://www.w3schools.com/tags/ref_entities.asp for the HTML entities...
Locked

Return to “[2.0.x] Styles Development & Discussion”