[Fixed] CGI Timeout

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
coldnet
Registered User
Posts: 16
Joined: Tue Mar 18, 2003 8:21 am

[Fixed] CGI Timeout

Post by coldnet »

I have successfully installed the phpBB in IIS 5.0 with MySQL as the database.

Everything is working fine except when I want to register a new member or send private message to other member, the page will poll there for a while and then display 'CGI Timeout' error. Even though the private message will still be sent and new member still be registered.

Is there any solutions? Thanks.
Oliver
Registered User
Posts: 93
Joined: Wed Jun 12, 2002 3:49 pm
Contact:

Post by Oliver »

have you put phpbb in the cgi-bin ?
coldnet
Registered User
Posts: 16
Joined: Tue Mar 18, 2003 8:21 am

Post by coldnet »

No, because I'm using IIS 5.0, I just create a directory for the phpBB2 and installed there, I have no problem for new post except those problem mentioned above.
coldnet
Registered User
Posts: 16
Joined: Tue Mar 18, 2003 8:21 am

Post by coldnet »

Nobody has the answer?
coldnet
Registered User
Posts: 16
Joined: Tue Mar 18, 2003 8:21 am

Post by coldnet »

I really need help!
coldnet
Registered User
Posts: 16
Joined: Tue Mar 18, 2003 8:21 am

Post by coldnet »

Bump.
coldnet
Registered User
Posts: 16
Joined: Tue Mar 18, 2003 8:21 am

Post by coldnet »

6 hours already, sorry but bump again.
coldnet
Registered User
Posts: 16
Joined: Tue Mar 18, 2003 8:21 am

Post by coldnet »

Bump again.
coldnet
Registered User
Posts: 16
Joined: Tue Mar 18, 2003 8:21 am

Post by coldnet »

Kindly help. Thanks.
User avatar
Techie-Micheal
Security Consultant
Posts: 19511
Joined: Sun Oct 14, 2001 12:11 am
Location: In your servers

Post by Techie-Micheal »

Thank you for waiting. :) What version of phpBB? Any MODs installed? What version of PHP?
Proven Offensive Security Expertise. OSCP - GXPN
coldnet
Registered User
Posts: 16
Joined: Tue Mar 18, 2003 8:21 am

Post by coldnet »

Oh, thank GOD.


PHP 4.3.1
MySQL 3.23.53
phpBB2 2.0.4
coldnet
Registered User
Posts: 16
Joined: Tue Mar 18, 2003 8:21 am

Post by coldnet »

No MOD installed.

Running on Windows 2000 Server edition (IIS5.0).

The error (CGI Timeout) occur when:

1. Register a new member
2. Send PM
3. Add group member

Thanks for the concern.
User avatar
Techie-Micheal
Security Consultant
Posts: 19511
Joined: Sun Oct 14, 2001 12:11 am
Location: In your servers

Post by Techie-Micheal »

In IIS, are you using PHP as a cgi executable or as an ISAPI module? CGI Timeout, IIRC, is similar to the "Time limit of 30 seconds exceeded" which if you are getting that error, something is seriously wrong.
Proven Offensive Security Expertise. OSCP - GXPN
coldnet
Registered User
Posts: 16
Joined: Tue Mar 18, 2003 8:21 am

Post by coldnet »

I'm using PHP as a CGI executable.

What I have done is:

1. Extract all the PHP distribution files to a directory C:\PHP.
2. Copy the php.ini to C:\WINNT.
3. Edit the php.ini.
- cgi.force_redirect = 0
4. In Internet Services Manager, add in the application mappings for the PHP extension '.php' under web server's application configurations property.
5. Restart IIS.
6. Install phpBB2 - working so far.
7. Register new member - CGI Timeout.

That's all what I have done.
User avatar
Techie-Micheal
Security Consultant
Posts: 19511
Joined: Sun Oct 14, 2001 12:11 am
Location: In your servers

Post by Techie-Micheal »

Try the ISAPI module.
Proven Offensive Security Expertise. OSCP - GXPN
Locked

Return to “2.0.x Support Forum”