Advertisement Management

Version 2.0.2: a couple of questions - Advertisement Management

Version 2.0.2: a couple of questions

by jmputz » Tue Jul 16, 2019 3:39 pm

I installed Advertisement Management (for the first time) on my forum (3.2.7) because I received policy violation warnings from Google.

This is a clean installation and I keep getting ads on pages like login or new message.
The option "Display on content pages only" is enabled (I ticked "yes"), and i emptied the cache to be sure and... ads are still showing on those pages. Mr Google will not like me :lol:

Further I was triying to find how to display the statistics, but I cannot find anything in this area. My forum does not display this information (only name, priority, start date, end date and status). Did I miss something during installation?
jmputz
Registered User
Posts: 26
Joined: Sun Aug 26, 2007 9:58 am
Contact:

Re: Version 2.0.2: a couple of questions

by DavidIQ » Thu Jul 18, 2019 7:06 pm

Example links please?
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17179
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Version 2.0.2: a couple of questions

by jmputz » Fri Jul 19, 2019 9:58 am

jmputz
Registered User
Posts: 26
Joined: Sun Aug 26, 2007 9:58 am
Contact:

Re: Version 2.0.2: a couple of questions

by jmputz » Sun Jul 21, 2019 9:23 am

It seems that the page I mentioned above is OK now.. (good thing). Although I found ads on this page last week (and Google noticed me again after submitting the change) I cannot find it in the list of impacted pages in my adsense profile.
There is another page which seems to give problems, the posting page.
https://www.whisky-distilleries.info/Fo ... f=7&t=3782
Screenshot 2019-07-21 at 11.21.02.png
jmputz
Registered User
Posts: 26
Joined: Sun Aug 26, 2007 9:58 am
Contact:

Re: Version 2.0.2: a couple of questions

by DavidIQ » Sun Jul 21, 2019 9:10 pm

Posting page is not viewable by bots. If it is then you have some problems with permissions.
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17179
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact:

Re: Version 2.0.2: a couple of questions

by jmputz » Tue Jul 23, 2019 7:31 am

Both problems appear again in the report.
What kind of permission problems are you referring to?
I reinstalled the most recent version from scratch a couple of month ago and did not change anything to the permissions. And yet Googles points out this 2 pages: login and post....
Screenshot 2019-07-23 at 09.25.20.png
Any suggestion would be appreciated.
jmputz
Registered User
Posts: 26
Joined: Sun Aug 26, 2007 9:58 am
Contact:

Re: Version 2.0.2: a couple of questions

by VSE » Tue Jul 23, 2019 3:59 pm

With Display on content pages only enabled, ads will not show on any MCP or UCP page. Enable that. Then you must resolve the issue with Google in your Adsense panel. I don't know what but probably something like marking the issue they flagged as resolved.

As for the posting page, that should also be resolved with Google since, in your example you are Replying. There is content in the reply (the Topic Review below the message field shows the posts in that topic). Although it may be worth treating posting just like the UCP and MCP as far as the Content Only setting goes in a future version.
🧩 My Extensions 🧩 ✨ YES...they ALL work with phpBB 3.3!! ✨
Please do not PM me for support.
User avatar
VSE
Extensions Development Coordinator
Extensions Development Coordinator
Posts: 5095
Joined: Sat Jan 17, 2009 9:37 am
Location: Los Angeles, CA
Name: Matt Friedman
Contact:

Re: Version 2.0.2: a couple of questions

by jmputz » Fri Jul 26, 2019 7:59 am

VSE wrote:With Display on content pages only enabled, ads will not show on any MCP or UCP page. Enable that. Then you must resolve the issue with Google in your Adsense panel. I don't know what but probably something like marking the issue they flagged as resolved.

As for the posting page, that should also be resolved with Google since, in your example you are Replying. There is content in the reply (the Topic Review below the message field shows the posts in that topic). Although it may be worth treating posting just like the UCP and MCP as far as the Content Only setting goes in a future version.
I guess I have understood this and of course this option is enabled. And yet Google keeps telling me I'm violating their rules. And indeed, I keep seeing ads on login pages.
I have no doubt about the quality of the extension... but reality is sometimes harder than therory.
Can I suggest some possible issues I think could explain this...?
I run the French version of PHPbb 3.2.7 ( i imagine the extension is compatible with this latest version of PHPbb).
I use 3 different styles based on Prosilver : Prosilver, Latte and Creamy. Could it be possible that one or more of this styles cause the problem? In this case is there a modification I can make in order to avoid ads on the forbidden pages?

Further, possibly this can be much ado about nothing. I don't care if Google does not show ads on these pages if this does not mean global penalty for me as a publisher. On the other hand, they simply could stop showing them on those pages... One thing does puzzlem me a bit. My revenues from Adsense have never been so low (and I use it since about 15 years now) and my site and forum has never been so "up to date"...
Attachments
Screenshot 2019-07-26 at 09.47.45.png
Screenshot 2019-07-26 at 09.50.04.png
jmputz
Registered User
Posts: 26
Joined: Sun Aug 26, 2007 9:58 am
Contact:

Re: Version 2.0.2: a couple of questions

by jmputz » Fri Aug 09, 2019 6:15 am

I’m a bit surprised to get no reaction anymore.
Do my suggestions make sense?
jmputz
Registered User
Posts: 26
Joined: Sun Aug 26, 2007 9:58 am
Contact:

Re: Version 2.0.2: a couple of questions

by odf » Tue Oct 22, 2019 9:07 pm

Sorry for interference, just to report that the extension does not work with Elegance style in phpBB 3.2.7, it only shows a blank space where the advert is supposed to appear.
odf
Registered User
Posts: 130
Joined: Sun Jan 22, 2017 8:55 pm
Contact:

Re: Version 2.0.2: a couple of questions

by gokmenecer » Sun Dec 01, 2019 8:15 am

How can you solve this problem? I have same problem and cant fix :( still showing ads on login page
gokmenecer
Registered User
Posts: 1
Joined: Sun Dec 01, 2019 8:13 am
Contact:

Re: Version 2.0.2: a couple of questions

by DavidIQ » Sun Dec 01, 2019 1:35 pm

The actual login page that you get to by clicking the login link on your site or is this the login page you get when you click on a link about a post reply?
Apply to become a Jr. Extension Validator
My extensions | In need of phpBB services? | Was I helpful today?
No unsolicited PMs unless you're planning on asking for paid help.
User avatar
DavidIQ
Customisations Team Leader
Customisations Team Leader
Posts: 17179
Joined: Thu Jan 06, 2005 1:30 pm
Location: Fishkill, NY
Name: David Colón
Contact: