Ajax Chat

Problem in phpBB 3.2.2, any sugestions? - Ajax Chat

Problem in phpBB 3.2.2, any sugestions?

by artiko17 » Sun Feb 18, 2018 9:34 pm

Hi... Firstyly, my language is not good, sorry. I have a little - i hope - problem with this chat i 3.2.2 version.

"Fatal error: Can't use method return value in write context in /home/sparqkle/public_html/ext/spaceace/ajaxchat/controller/chat.php on line 399"

I am not a php programmer, saddly :(

I am not moddified this file in any way. Any sugestions how i can make it to run correctly in 3.2.2 version?
artiko17
Registered User
Posts: 2
Joined: Sun Feb 18, 2018 9:29 pm
Contact:

Re: Problem in phpBB 3.2.2, any sugestions?

by spaceace » Mon Feb 19, 2018 5:18 pm

this is something i'm unable to reproduce as all my testing on a 3.2.2 board produce no error and is working as it should
User avatar
spaceace
Registered User
Posts: 1795
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: Problem in phpBB 3.2.2, any sugestions?

by artiko17 » Mon Feb 19, 2018 6:31 pm

Eles theme in 1.61 can cause that problem? Or any of this extensions?
http://puu.sh/zrfnN.png
artiko17
Registered User
Posts: 2
Joined: Sun Feb 18, 2018 9:29 pm
Contact:

Re: Problem in phpBB 3.2.2, any sugestions?

by raptor666 » Mon May 28, 2018 5:00 pm

I had an old chat version above the old phpbb version. Since then, it's not good since I tried to add a new one to the new phpbb version. Since then he has written this bug to the old chat version and the latest one.
raptor666
Registered User
Posts: 11
Joined: Fri May 18, 2018 9:06 pm
Contact:

Re: Problem in phpBB 3.2.2, any sugestions?

by spaceace » Tue May 29, 2018 7:02 am

what PHP version do you have?
User avatar
spaceace
Registered User
Posts: 1795
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: Problem in phpBB 3.2.2, any sugestions?

by raptor666 » Wed May 30, 2018 9:52 am

database server: MySQL(i) 5.6.39-log
PHP version: 5.4.45
forum version: 3.2.2
raptor666
Registered User
Posts: 11
Joined: Fri May 18, 2018 9:06 pm
Contact:

Re: Problem in phpBB 3.2.2, any sugestions?

by spaceace » Wed May 30, 2018 10:29 am

that is why i can't reproduce the error :lol:

PHP 5.4 as well as 5.5 are EOL and i no longer work with them.

you really should get it updated to at least 5.6 but even that will be EOL in January 2019
User avatar
spaceace
Registered User
Posts: 1795
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: Problem in phpBB 3.2.2, any sugestions?

by raptor666 » Sun Jun 03, 2018 7:23 pm

Ohh, okay, I wrote to web hosting to switch to php 7.

Thx.
raptor666
Registered User
Posts: 11
Joined: Fri May 18, 2018 9:06 pm
Contact: