Contact Admin

Enabling prevents emails but I get confirmation msg - Contact Admin

Enabling prevents emails but I get confirmation msg

by topshot » Sat May 12, 2018 2:33 am

Just trying out your ext with 3.2.2. However, whenever I enable it, the UI seems to work as one would expect but I don't get the emails even though I get the message it was sent. It doesn't matter whether logged in or as guest. Disabling will allow the emails through.

This is on a shared server, which claims in cPanel to be PHP 5.4.45 but within phpBB says it's 5.5.37. Also of note is that I had to disable SSL verification for SMTP to work since it's a shared system I have no control over.

What do I need to check or change in the code?
topshot
Registered User
Posts: 30
Joined: Fri Sep 15, 2006 8:17 pm

Re: Enabling prevents emails but I get confirmation msg

by topshot » Sun May 13, 2018 2:02 am

It turns out they are coming through eventually but those using the CA extension are delayed quite a bit (at least an hour). This morning I saw at least most of my test emails from last night.

I did another test and without the extension it shows up immediately. With the extension, it took 77 minutes. Why is the extension delaying delivery?
topshot
Registered User
Posts: 30
Joined: Fri Sep 15, 2006 8:17 pm

Re: Enabling prevents emails but I get confirmation msg

by RMcGirr83 » Sun May 13, 2018 10:26 am

The emails are saved in the queue

https://github.com/rmcgirr83/contactadm ... r.php#L500

If you want them immediately then you need to change the code in the controller per

https://wiki.phpbb.com/Sending_e-mails# ... Enqueueing
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored
User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Enabling prevents emails but I get confirmation msg

by topshot » Sun May 13, 2018 12:21 pm

OK. I was wondering if you were using the cron job for some reason. Since our site is low volume I'll just leave it as is. Thank you.
topshot
Registered User
Posts: 30
Joined: Fri Sep 15, 2006 8:17 pm