Contact Admin

Fatal error: Cannot redeclare generate_smilies() - Contact Admin

Fatal error: Cannot redeclare generate_smilies()

by wads24 » Tue Oct 30, 2018 1:33 am

I upgraded to latest version of contact admin 1.1.7 just the other day.
Released:Tue Oct 16, 2018 10:07 am
File size:33.77 KiB
Validated for:phpBB 3.2.3
Now, when trying to send a PM to a user I get the below error:
Fatal error: Cannot redeclare generate_smilies() (previously declared in /includes/functions_posting.php:25) in /includes/functions_posting.php on line 167

I searched the forum and found this link: https://www.phpbb.com/customise/db/exte ... 31#p567531
wads24 wrote:
RMcGirr83 wrote:This is now in the latest version of the Contact Admin Extension.
I have just updated to most recent version of contact admin.

Fatal error: Cannot redeclare generate_smilies() (previously declared in /includes/functions_posting.php:25) in /includes/functions_posting.php on line 167
RMcGirr83 wrote:Right and that has zero to do with contact admin so post in the other extension or do a search in the other extension.
wads24 wrote:I just disabled the contact admin extension, cleared cache.... The error went away... Then I re-enabled contact admin and cleared cache and got the error again.
Anyone else having this issue?
Thanks in advance for a reply.
User avatar
wads24
Registered User
Posts: 520
Joined: Fri Jun 10, 2005 4:44 am
Name: James

Re: Fatal error: Cannot redeclare generate_smilies()

by RMcGirr83 » Tue Oct 30, 2018 10:16 am

In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored
User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Fatal error: Cannot redeclare generate_smilies()

by Hippie459MN » Thu Jan 10, 2019 12:58 am

RMcGirr83 wrote:New version has been submitted, in the mean time you can apply these edits.

https://github.com/rmcgirr83/contactadm ... 6737136f9c
I quoted your post from another topic. I am also getting this error below whenever I try to do a "search users posts" after I updated to v1.1.7 but your github link gives me a 404 page not found. If I disable the ext then everything works just fine.

Code: Select all

 Fatal error: Cannot redeclare generate_smilies() (previously declared in /home2/hippie74/public_html/hydrostreamforums/includes/functions_posting.php:25) in /home2/hippie74/public_html/hydrostreamforums/includes/functions_posting.php on line 167
Like I said, I disable the Contact Admin EXT and the problem goes away.

Any help would be great. Thanks.
User avatar
Hippie459MN
Registered User
Posts: 918
Joined: Mon Oct 15, 2007 10:13 pm
Location: Minnesota, USA
Contact: