Group Subscription (PayPal)

No transactions or subscriptions showing in ACP module... - Group Subscription (PayPal)

Re: No transactions or subscriptions showing in ACP module..

by Thunderer » Sun Oct 20, 2019 9:17 pm

Thunderer
Registered User
Posts: 132
Joined: Mon Apr 20, 2009 1:49 am
Contact:

Re: No transactions or subscriptions showing in ACP module..

by Thunderer » Sun Oct 20, 2019 9:22 pm

Not showing any errors in the log on my CPanel.

Also, no transactions showing in the Database either, which, perhaps, is the key to the issue?

I am at a loss as to what to do or as to what the issue could be. I was wondering if it was P/Pal related, but then, that is just me grasping at straws for an explanation.
Thunderer
Registered User
Posts: 132
Joined: Mon Apr 20, 2009 1:49 am
Contact:

Re: No transactions or subscriptions showing in ACP module..

by Thunderer » Sun Oct 20, 2019 9:47 pm

Account activated on BRCAMS for you.
Thunderer
Registered User
Posts: 132
Joined: Mon Apr 20, 2009 1:49 am
Contact:

Re: No transactions or subscriptions showing in ACP module..

by StevoTVR » Sun Oct 20, 2019 10:19 pm

You don't seem to have any active subscription packages.
User avatar
StevoTVR
Registered User
Posts: 254
Joined: Thu Jul 13, 2006 6:23 pm
Name: Steve Guidetti
Contact:

Re: No transactions or subscriptions showing in ACP module..

by Thunderer » Sun Oct 20, 2019 10:26 pm

Actually, I do. User "Grifterguru" has an active subscription. (I had to set it manually!

Also, there is a 1 year £16 option and the 4 week £2 option.
Thunderer
Registered User
Posts: 132
Joined: Mon Apr 20, 2009 1:49 am
Contact:

Re: No transactions or subscriptions showing in ACP module..

by StevoTVR » Sun Oct 20, 2019 10:31 pm

Make sure the packages are actually enabled. I don't see any listed.
User avatar
StevoTVR
Registered User
Posts: 254
Joined: Thu Jul 13, 2006 6:23 pm
Name: Steve Guidetti
Contact:

Re: No transactions or subscriptions showing in ACP module..

by Thunderer » Sun Oct 20, 2019 10:43 pm

Packages ARE enabled.

Also testing out your user permissions, I can actually see the subscriptions page and the packages
Thunderer
Registered User
Posts: 132
Joined: Mon Apr 20, 2009 1:49 am
Contact:

Re: No transactions or subscriptions showing in ACP module..

by StevoTVR » Sun Oct 20, 2019 10:59 pm

I am seeing one package now and everything seems normal. Without any errors it's hard to tell what's going on.
User avatar
StevoTVR
Registered User
Posts: 254
Joined: Thu Jul 13, 2006 6:23 pm
Name: Steve Guidetti
Contact:

Re: No transactions or subscriptions showing in ACP module..

by Thunderer » Sun Oct 20, 2019 11:40 pm

The problem is the connection between the transaction and the database. The database is not showing any paypal transactions despite at least two transactions being made.

I am also wondering if it is to do with the TLS 1.2 and HTTP/1.1 compliance requirements of paypal. (Paypal TLS 1.2 and HTTP/1.1 compliance requirements
Thunderer
Registered User
Posts: 132
Joined: Mon Apr 20, 2009 1:49 am
Contact:

Re: No transactions or subscriptions showing in ACP module..

by StevoTVR » Mon Oct 21, 2019 12:01 am

Yeah that's possible. When I have some time I'll test it and see if that is a requirement for IPN. You should probably enable HTTPS on your site anyway.
User avatar
StevoTVR
Registered User
Posts: 254
Joined: Thu Jul 13, 2006 6:23 pm
Name: Steve Guidetti
Contact:

Re: No transactions or subscriptions showing in ACP module..

by Thunderer » Mon Oct 21, 2019 1:00 am

I just tried using IPN on the "Paypal donation" extension running on the forum and it appears to points towards TLS 1.2 and HTTP/1.1 compliance being a necessary factor for IPN to work.

Much as I state that, my knowledge is limited on that front.
Thunderer
Registered User
Posts: 132
Joined: Mon Apr 20, 2009 1:49 am
Contact:

Re: No transactions or subscriptions showing in ACP module..

by Thunderer » Mon Oct 21, 2019 3:47 pm

Ok, a little update. I have checked and treble checked with my server provider and have even run an SSL Labs test and yes, TLS1.2 and HTTP/1.1 are indeed active on my server.

I have also just taken time to look at the paypal donation extension and that, too is displaying a "not detected" notification for TLS1.2 and HTTP/1.1

I am actually wondering now, if this is something with my server provider, though to be honest I am scratching my head a lot here given I know that TLS1.2 and HTTP/1.1 are active on my server!

*** QUICK EDIT ***

Just had a read over on the "paypal donation extension" and it appears that there was a problem with paypal (which I am unsure whether it was ever resolved), that required a single word change in the controller file to return a "false positive" on the detction for "TLS1.2 HTTP/1.1" which resolved the problem.

Here is the post: (Read the 4th reply, by Skouat)

https://www.phpbb.com/customise/db/exte ... 81#p701681

*** QUICK EDIT ***
Last edited by Thunderer on Mon Oct 21, 2019 5:02 pm
Thunderer
Registered User
Posts: 132
Joined: Mon Apr 20, 2009 1:49 am
Contact:

Re: No transactions or subscriptions showing in ACP module..

by ZlaYa07 » Mon Oct 21, 2019 4:27 pm

I've tested it with the paypal donation extension too, ~10 days ago -> displaying not detected etc, I've troubleshooted etc, many people state that Paypal's ipn service is down, counting months, so don't know what's the problem on their side, I've seen much topics and people talking about it being down, even on paypal support forums and no eta on when they will fix it.
I contacted my hosting provider, they said that they support TLS 1.2 / HTTP 1.1 and I even tested their claim on this site: http://ssl-checker.online-domain-tools.com -> where I confirmed that TLS 1.2 / HTTP 1.1 is indeed supported
You have varoious websites for site downtime like this one below, I've tested few, all of them reported the paypal service being down.
https://downforeveryoneorjustme.com/tlstest.paypal.com
https://www.isitdownrightnow.com/tlstes ... l.com.html
https://down.com
Etc...
Last edited by ZlaYa07 on Fri Oct 25, 2019 5:59 am
ZlaYa07
Registered User
Posts: 10
Joined: Tue Oct 15, 2019 2:18 pm
Contact:

Re: No transactions or subscriptions showing in ACP module..

by StevoTVR » Mon Oct 21, 2019 4:43 pm

It may be available on your server but you aren't using it. You should change your phpBB server settings to use https and port 443.
User avatar
StevoTVR
Registered User
Posts: 254
Joined: Thu Jul 13, 2006 6:23 pm
Name: Steve Guidetti
Contact:

Re: No transactions or subscriptions showing in ACP module..

by Thunderer » Tue Oct 22, 2019 10:02 pm

Given the fact that it trips a 404 on the subscription and donation pages, moving to https and port 443 is a small problem at the moment.

moving to a new, dedicated server for the website should hopefully solve that problem I hope, as currently it is on a "Shared" server with my other websites which, up until now, has never been a problem.
Thunderer
Registered User
Posts: 132
Joined: Mon Apr 20, 2009 1:49 am
Contact: