Linked Accounts

Wrong links (missing .php) - Linked Accounts

Wrong links (missing .php)

by </Solidjeuh> » Tue Jan 15, 2019 8:25 pm

There are a few links that are not correct in version 1.1.3

Link account button:
/ucp.?i=-flerex-linkedaccounts-ucp-main_module&mode=link
After account is linked:
/ucp.?i=-flerex-linkedaccounts-ucp-main_module&mode=management
Search account:
/memberlist.?mode=searchuser&form=ucp&field=username&select_single=1

/ucp.?i= is missing php. should be /ucp.php?i=

/memberlist.? is also missing php. Should be /memberlist.php?

main_module.php:

This:

Code: Select all

'U_LINK_ACCOUNT' => append_sid($this->phpbb_root_path . 'ucp.' . $this->phpEx, 'i=' . $this->module_basename . '&amp;mode=link'),
Should be:

Code: Select all

'U_LINK_ACCOUNT' => append_sid($this->phpbb_root_path . 'ucp.php' . $this->phpEx, 'i=' . $this->module_basename . '&amp;mode=link'),
===================

This:

Code: Select all

'U_FIND_USERNAME' => append_sid("{$this->phpbb_root_path}memberlist.$this->phpEx", "mode=searchuser&amp;form=ucp&amp;field=username&amp;select_single=1"),
Should be:

Code: Select all

'U_FIND_USERNAME' => append_sid("{$this->phpbb_root_path}memberlist.php$this->phpEx", "mode=searchuser&amp;form=ucp&amp;field=username&amp;select_single=1"),
===================

This:

Code: Select all

redirect(append_sid($this->phpbb_root_path . 'ucp.' . $this->phpEx, 'i=' . $this->module_basename . '&amp;mode=management'));
Should be:

Code: Select all

redirect(append_sid($this->phpbb_root_path . 'ucp.php' . $this->phpEx, 'i=' . $this->module_basename . '&amp;mode=management'));
User avatar
</Solidjeuh>
Registered User
Posts: 1732
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: Wrong links (missing .php)

by Flerex » Wed Jan 16, 2019 12:15 pm

Version 1.1.4 is already in queue for approval and fixes this specific problem. If you don't want for it to be approved you can use this release from the repository that I just made available.
User avatar
Flerex
Registered User
Posts: 99
Joined: Sun Oct 14, 2012 8:35 pm
Location: Galicia, Spain
Name: Flerex
Contact:

Re: Wrong links (missing .php)

by </Solidjeuh> » Wed Jan 16, 2019 2:09 pm

Oooh ok thank you :D
User avatar
</Solidjeuh>
Registered User
Posts: 1732
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact: