mChat

Database problem - mChat

Database problem

by Renzotom » Tue Jan 09, 2018 7:44 pm

Hello, I updated on new verison 3.2.2 and I have following error, can you fix it please?

Code: Select all

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 565
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()
Last edited by Renzotom on Thu Jan 11, 2018 10:21 pm
Renzotom
Registered User
Posts: 55
Joined: Mon Dec 25, 2017 1:47 pm
Contact:

Re: Support for 3.2.2

by kasimi » Wed Jan 10, 2018 9:34 am

What makes you think it's an mChat issue? There is no mention of mChat in what you posted, which seems to be missing the actual error message too.
User avatar
kasimi
Extension Customisations
Extension Customisations
Posts: 3294
Joined: Sat Sep 10, 2011 7:12 pm
Location: Germany
Contact:

Re: Support for 3.2.2

by Renzotom » Wed Jan 10, 2018 1:09 pm

kasimi wrote:What makes you think it's an mChat issue? There is no mention of mChat in what you posted, which seems to be missing the actual error message too.
It happens, when I enable mChat and wanna set it in extensions. PS: I also moved database, maybe this issue is with that?

PS: There is also message, modul isn't available, I deleted moduls about mChat from database, beacuse it said me to delete 3 rows (without deleting it wouldn't enable, I have to delete it).
Renzotom
Registered User
Posts: 55
Joined: Mon Dec 25, 2017 1:47 pm
Contact:

Re: Support for 3.2.2

by kasimi » Wed Jan 10, 2018 1:47 pm

Post the complete error message, not just the backtrace.
User avatar
kasimi
Extension Customisations
Extension Customisations
Posts: 3294
Joined: Sat Sep 10, 2011 7:12 pm
Location: Germany
Contact:

Re: Support for 3.2.2

by Renzotom » Wed Jan 10, 2018 3:27 pm

It is almost complete error, I didn't posted prev part, beacuse it wasn't translate, so translate to English is by me:

Code: Select all

General error // Translated by me
The module is not accessible // Translated by me

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 565
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()
Renzotom
Registered User
Posts: 55
Joined: Mon Dec 25, 2017 1:47 pm
Contact:

Re: Support for 3.2.2

by kasimi » Wed Jan 10, 2018 4:05 pm

Go to ACP, System, Module management. Delete all modules related to mChat and then add them back.
User avatar
kasimi
Extension Customisations
Extension Customisations
Posts: 3294
Joined: Sat Sep 10, 2011 7:12 pm
Location: Germany
Contact:

Re: Support for 3.2.2

by Renzotom » Wed Jan 10, 2018 4:13 pm

Tried and still nothing? Or how to you mean it? I deleted mChat category in Modules, create new one, add there modules again.

PS: I am also tried remove mChat folder and install it again.
Last edited by Renzotom on Wed Jan 10, 2018 4:21 pm
Renzotom
Registered User
Posts: 55
Joined: Mon Dec 25, 2017 1:47 pm
Contact:

Re: Support for 3.2.2

by kasimi » Wed Jan 10, 2018 4:19 pm

Yes, that's what I meant. I'm out of ideas, sorry. Try the 3.2 support forum.
User avatar
kasimi
Extension Customisations
Extension Customisations
Posts: 3294
Joined: Sat Sep 10, 2011 7:12 pm
Location: Germany
Contact:

Re: Support for 3.2.2

by Renzotom » Wed Jan 10, 2018 4:23 pm

And isn't problem beacuse I imported old database somehow? But some files didn't worked so I must used new.
Renzotom
Registered User
Posts: 55
Joined: Mon Dec 25, 2017 1:47 pm
Contact:

Re: Support for 3.2.2

by kasimi » Wed Jan 10, 2018 4:32 pm

If it worked fine before importing the old database then that must be what caused your problem. I don't know how to fix it though.
User avatar
kasimi
Extension Customisations
Extension Customisations
Posts: 3294
Joined: Sat Sep 10, 2011 7:12 pm
Location: Germany
Contact:

Re: Support for 3.2.2

by Renzotom » Wed Jan 10, 2018 6:07 pm

There must be some files in database or in new version 3.2.2, which making that error.
Renzotom
Registered User
Posts: 55
Joined: Mon Dec 25, 2017 1:47 pm
Contact:

Re: Support for 3.2.2

by RMcGirr83 » Wed Jan 10, 2018 9:08 pm

FWIW, I just updated my test forum with this extension installed and didn't have any issues.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored
User avatar
RMcGirr83
Recognised Extension Developer
Posts: 20955
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Support for 3.2.2

by kasimi » Thu Jan 11, 2018 9:21 pm

Make a backup of your database, disable mChat and delete data. Download a fresh copy of the extension files here from the CDB, upload them to the server and enable mChat.
User avatar
kasimi
Extension Customisations
Extension Customisations
Posts: 3294
Joined: Sat Sep 10, 2011 7:12 pm
Location: Germany
Contact:

Re: Support for 3.2.2

by Renzotom » Thu Jan 11, 2018 9:33 pm

And delete database? Beacuse I tried disable mChat, delete data, fresh copy.

I now can only try backup database, delete database and see, if it will work on fresh database. If yes, mistake will be somewhere in database.
Renzotom
Registered User
Posts: 55
Joined: Mon Dec 25, 2017 1:47 pm
Contact:

Re: Support for 3.2.2

by kasimi » Thu Jan 11, 2018 9:41 pm

Delete mChat data and run this query:

Code: Select all

SELECT *
FROM phpbb_modules
WHERE module_basename LIKE '%mchat%'
Any rows in the result?
User avatar
kasimi
Extension Customisations
Extension Customisations
Posts: 3294
Joined: Sat Sep 10, 2011 7:12 pm
Location: Germany
Contact: