PayPal Donation Extension

Extension Wrongly Setup or Malfunctioning - PayPal Donation Extension

Extension Wrongly Setup or Malfunctioning

by spyderwycksson » Sun Mar 03, 2019 8:26 pm

Hi,

I use the latest WAMP Web Server x64 on a Windows machine and i try to use this extension on my forum from phpbb, i already setup the cfg's with new settings to can use this extension but when i push Overwiev in this extension menu i get this:

cURL version: 7.61.1 SSL version: OpenSSL/1.1.1a
TLS 1.2 and HTTP/1.1: Not detected

Why i get the message TLS 1.2 and HTTP/1.1: Not detected because i already enabled this settings in my cfg's on server and what i need to do to fix this joke, because i already search the internet about the ssl certificates and other dumy settings to can enable this to connect to paypal website but i can't solve it.

Thanks for your time. :?: :?: :ugeek: :evil: :evil:
spyderwycksson
Registered User
Posts: 5
Joined: Thu Jan 24, 2019 1:37 am
Contact:

Re: Extension Wrongly Setup or Malfunctioning

by spyderwycksson » Sun Mar 03, 2019 9:18 pm

Note: I successfuly conected to paypal but i can use the sandbox system for tests and other things.
spyderwycksson
Registered User
Posts: 5
Joined: Thu Jan 24, 2019 1:37 am
Contact:

Re: Extension Wrongly Setup or Malfunctioning

by Skouat » Mon Mar 04, 2019 8:17 pm

Hi,

Please take a look on https://www.paypal.com/en/webapps/mpp/tls-http-upgrade
Especially the chapter "Verify your systems at https://tlstest.paypal.com!"

Regards.
Skouat
Code Contributor
Posts: 709
Joined: Mon Mar 10, 2008 5:30 pm
Location: France
Contact:

Re: Extension Wrongly Setup or Malfunctioning

by spyderwycksson » Tue Mar 05, 2019 2:30 am

Thanks for your response but i already checked all of that and my browsers support the connection to Paypal, i already write in this topic that i can connect to paypal but i can't use the sandbox sistem...is there a file where i need to put the link to test the connection to paypal in your extension ? Ok, now i get the point, i will change the link that connect the extension to the paypal systems with that provided for tests and see what is the error that don't let me to use the extension.
PS: Purhaps, next time, when someone asks for help, you can explain like this, for dumies, to can be easily undestanded by everyone.
spyderwycksson
Registered User
Posts: 5
Joined: Thu Jan 24, 2019 1:37 am
Contact:

Re: Extension Wrongly Setup or Malfunctioning

by Skouat » Tue Mar 05, 2019 6:45 pm

Hi,
spyderwycksson wrote: i already checked all of that and my browsers support the connection to Paypal, i already write in this topic that i can connect to paypal but i can't use the sandbox sistem
This is your web server that requires to support TLS 1.2 and HTTP/1.1 not your browser.
From your webserver, in command line, use command such as curl https://tlstest.paypal.com. Or, as indicated on the PayPal link provide in my previous message, use a PHP script to ensure that your server meets the requirements.
spyderwycksson wrote: is there a file where i need to put the link to test the connection to paypal in your extension ?
This is already checked by the extension, that's why in the Overview module you have TLS 1.2 and HTTP/1.1: Not detected
spyderwycksson wrote: Purhaps, next time, when someone asks for help, you can explain like this, for dumies, to can be easily undestanded by everyone.
Perhaps you can read the FAQ, especially the item PayPal security guidelines
All those points are checked by the extension, so if it fails, it's up to you to comply with these requirements, not me.
Skouat
Code Contributor
Posts: 709
Joined: Mon Mar 10, 2008 5:30 pm
Location: France
Contact: