PayPal Donation Extension

Current stable(ish) version? - PayPal Donation Extension

Current stable(ish) version?

by v12mike » Wed May 15, 2019 3:34 pm

I am confused about which version is safe to run.

I was running a version identified as 2.0.0-dev and after updating my board to phpBB v3.2.7 decided to update various extensions.
On the customisation/extensions page, ppde was indicated as needing an update, and the details page took me to https://github.com/Skouat/ext_paypal_do ... -3.3.x.zip, but this version does not allow the acp pages to be opened.

Code: Select all

[Wed May 15 15:08:49.934650 2019] [php7:notice] [pid 20930] [client 82.242.120.202:60096] PHP Fatal error:  Uncaught TypeError: Argument 4 passed to phpbb\\extension\\manager::__construct() must implement interface phpbb\\filesystem\\filesystem_interface, string given, called in /var/webs/forums/fcf/forum/cache/production/container_dbdbe80dc7030ae9bd39ee30cca82130.php on line 3510 and defined in /var/webs/forums/fcf/forum/phpbb/extension/manager.php:50\nStack trace:\n#0 /var/webs/forums/fcf/forum/cache/production/container_dbdbe80dc7030ae9bd39ee30cca82130.php(3510): phpbb\\extension\\manager->__construct(Object(phpbb_cache_container), Object(phpbb\\db\\driver\\factory), Object(phpbb\\config\\db), 'phpbb_ext', './../', 'php', Object(phpbb\\cache\\service))\n#1 /var/webs/forums/fcf/forum/vendor/symfony/dependency-injection/Container.php(295): phpbb_cache_container->getSkouat_Ppde_ExtensionManagerService()\n#2 /var/webs/forums/fcf/forum/vendor/symfony/dependency-injection/ContainerBuilder.php(446): Symfony\\Component\\DependencyInjection\\Container->get('skouat.ppde.ext...', 2)\n#3 /var/webs/forums/fcf/forum/cache/production/container_dbd in /var/webs/forums/fcf/forum/phpbb/extension/manager.php on line 50, referer: https://frenchcarforum.co.uk/forum/adm/index.php?sid=35155c4119c55a4081da330aefbabda9&i=31
May 
Can you please clarify which version is recommended for phpBB v3.2.7?
v12mike
Registered User
Posts: 328
Joined: Thu Jul 09, 2015 5:03 pm
Contact:

Re: Current stable(ish) version?

by Skouat » Wed May 15, 2019 5:41 pm

Hi

You are notified for new version because you use a develop version of PPDE. So, none of them are stable.

On Github the branch that contains:
- 3.3.x is for phpBB 3.3.x
- 3.2.x is for phpBB 3.2.x

As you use the version 2.0.0-dev you can update to the stable version 2.0.1, available here on the tabs Contribution

If you want to continue using a develop version, I’ll let you find how to do it by yourself. I’ll not provide any information about how to use an unstable version.
Skouat
Code Contributor
Posts: 708
Joined: Mon Mar 10, 2008 5:30 pm
Location: France
Contact:

Re: Current stable(ish) version?

by v12mike » Wed May 15, 2019 6:07 pm

Thank you for your reply.
You might want to update your 3.0.0-dev composer.json to prevent installation on 3.2.x boards.
v12mike
Registered User
Posts: 328
Joined: Thu Jul 09, 2015 5:03 pm
Contact:

Re: Current stable(ish) version?

by Skouat » Wed May 15, 2019 10:47 pm

This is already the case : https://github.com/Skouat/ext_paypal_do ... r.json#L47 ;)
But phpBB doesn't support this information.
Skouat
Code Contributor
Posts: 708
Joined: Mon Mar 10, 2008 5:30 pm
Location: France
Contact: