Stop Forum Spam

Forum becomes excessively slow/unresponsive - Stop Forum Spam

Forum becomes excessively slow/unresponsive

by zip88 » Mon Oct 30, 2017 10:14 pm

Upon enabling Stop Forum Spam with default settings (or any variation of SFS settings), my forum becomes unresponsive after a few minutes. Certain pages will still continue to load while other similar pages won't, e.g. topic A will load when topic B won't, profile C will load when profile D won't, private message E will load when private message F won't, etc. The common denominator of pages that will load seems to be that they were all previously cached.

If I don't disable SFS quickly enough, the admin panel for SFS settings will become unresponsive as well.

I'm using nginx and Cloudflare DNS/HTTP proxy.

Any ideas?
zip88
Registered User
Posts: 1
Joined: Mon Oct 30, 2017 9:58 pm

Re: Forum becomes excessively slow/unresponsive

by RMcGirr83 » Sat Nov 04, 2017 10:41 am

Cloudflare is known to cause issues on forums if not setup correctly.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored
User avatar
RMcGirr83
Recognised Extension Developer
Posts: 20931
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Forum becomes excessively slow/unresponsive

by AoSiX » Wed Apr 18, 2018 10:11 pm

zip88 wrote: Upon enabling Stop Forum Spam with default settings (or any variation of SFS settings), my forum becomes unresponsive after a few minutes. Certain pages will still continue to load while other similar pages won't, e.g. topic A will load when topic B won't, profile C will load when profile D won't, private message E will load when private message F won't, etc. The common denominator of pages that will load seems to be that they were all previously cached.

If I don't disable SFS quickly enough, the admin panel for SFS settings will become unresponsive as well.

I'm using nginx and Cloudflare DNS/HTTP proxy.

Any ideas?
Well I know for sure this is the case when your forum have a lot of users. See https://github.com/rmcgirr83/stopforumspam/issues/19. The issue has been closed, but the issue still exists.
AoSiX
Registered User
Posts: 2
Joined: Thu Aug 24, 2017 3:40 pm
Contact:

Re: Forum becomes excessively slow/unresponsive

by RMcGirr83 » Thu Apr 19, 2018 11:06 am

Then use the previous version linked to in that ticket which doesn't have the ability to report users within a topic.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored
User avatar
RMcGirr83
Recognised Extension Developer
Posts: 20931
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact: