Stop Forum Spam

Cannot install with phpBB 3.2.2 - spambots are killing me - Stop Forum Spam

Cannot install with phpBB 3.2.2 - spambots are killing me

by 5chn3ll » Mon Mar 19, 2018 1:31 am

My site (996outpost.com) is getting crushed by payday loan and bitcoin spambots.

I desperately want to use this extension, but my install is 3.2.2, which appears to be > the version supported by Stop Forum Spam.

Is there any way to override this? Is it pointless to even try (i.e. will the plugin function with 3.2.2)?

Thanks in advance! My mods are going to mutiny if I can't get a handle on the bogus account registrations.
5chn3ll
Registered User
Posts: 6
Joined: Mon Mar 19, 2018 1:27 am
Contact:

Re: Cannot install with phpBB 3.2.2 - spambots are killing m

by RMcGirr83 » Mon Mar 19, 2018 10:39 am

Should work and install fine in 3.2.2
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored
User avatar
RMcGirr83
Recognised Extension Developer
Posts: 20811
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Cannot install with phpBB 3.2.2 - spambots are killing m

by 5chn3ll » Mon Mar 19, 2018 4:03 pm

Interesting - the extension does not appear in the disabled extensions list. I installed another extension last night to make sure I'm not doing it incorrectly; the other extension loaded as expected. For reasons I don't understand, Stop Forum Spam does not appear on the 'Customise' tab.

I'm using phpBB on a GoDaddy-hosted Linux install. phpBB version displayed is "3.2.2."

Are there any prerequisites or PHP options that need to be set? Does phpBB generate any debug output I can check for any clues as to why the extension isn't being detected/loaded?
5chn3ll
Registered User
Posts: 6
Joined: Mon Mar 19, 2018 1:27 am
Contact:

Re: Cannot install with phpBB 3.2.2 - spambots are killing m

by 5chn3ll » Mon Mar 19, 2018 4:24 pm

Issue resolved - I was being an a$$hat.

I had (erroneously) assumed that /ext/ was not phpBB-specific, and that all extensions should go into /etc/phpbb/[publisher]/[extension] instead of /etc/[publisher]/[extension].

https://www.phpbb.com/extensions/installing/ made me realize that I had made a wrong assumption about the phpBB extension folder hierarchy.
5chn3ll
Registered User
Posts: 6
Joined: Mon Mar 19, 2018 1:27 am
Contact: