phpBB SiteMaker

Forum now unavailable - 'White Screen' - phpBB SiteMaker

Forum now unavailable - 'White Screen'

by pathfinderenterprises » Mon Sep 11, 2017 11:05 am

I had decided to try 'SiteMaker' and after installing and activating it on my 3.2.1 board I began to try and add blocks to the sidebar. it appeared to work, no content was being displayed in a custom block.

I decided to continue with other work and come back to SiteMaker at a later time. I clicked to leave the editor and I got a blank white screen. Now I can't access my forum at all; when I try and reload my forum I get a white screen and I get the same if I try to go to the adm index.

The only access I have to my forum is by ftp; I have tried removing the SiteMaker files AND disabling the extension using phpMyAdmin but that has made no difference.

What else can I do to get my forum back?
Keith


If everything seems to be going well, you have obviously overlooked something.
pathfinderenterprises
Registered User
Posts: 142
Joined: Fri Aug 04, 2006 5:14 pm
Location: Bolton
Contact:

Re: Forum now unavailable - 'White Screen'

by pathfinderenterprises » Mon Sep 11, 2017 11:10 am

Got it :D

I used ftp to clear the cache and all is well.
Keith


If everything seems to be going well, you have obviously overlooked something.
pathfinderenterprises
Registered User
Posts: 142
Joined: Fri Aug 04, 2006 5:14 pm
Location: Bolton
Contact:

Re: Forum now unavailable - 'White Screen'

by pathfinderenterprises » Mon Sep 11, 2017 11:43 am

I have just tried to reinstall SiteMaker and when I try and activate it I now get an error:
SQL ERROR [ mysqli ]

Table 'havenown_hof.phpbb_sm_blocks' doesn't exist [1146]
I have deleted and replaced the ext files and tried to 'delete data' which gave the same error.
I have cleared the cache again, but still can't get the ext to enable.
Keith


If everything seems to be going well, you have obviously overlooked something.
pathfinderenterprises
Registered User
Posts: 142
Joined: Fri Aug 04, 2006 5:14 pm
Location: Bolton
Contact:

Re: Forum now unavailable - 'White Screen'

by pathfinderenterprises » Wed Sep 27, 2017 6:00 pm

I would really appreciate some advice about this.
Keith


If everything seems to be going well, you have obviously overlooked something.
pathfinderenterprises
Registered User
Posts: 142
Joined: Fri Aug 04, 2006 5:14 pm
Location: Bolton
Contact:

Re: Forum now unavailable - 'White Screen'

by Blitze » Mon Oct 02, 2017 4:06 am

Sorry for the late response. I have fixed this issue and submitted a new version for approval. Because this might take a while, backup your database, and execute this query:

Code: Select all

UPDATE phpbb_migrations SET migration_depends_on = 'a:2:{i:0;s:51:\"\\blitze\\sitemaker\\migrations\\v20x\\m1_initial_schema\";i:1;s:64:\"\\blitze\\sitemaker\\migrations\\converter\\c4_convert_primetime_data\";}' WHERE migration_name = '\\blitze\\sitemaker\\migrations\\v30x\\m16_add_block_view_field'
My Extensions: phpBB SiteMaker
Blitze
Registered User
Posts: 366
Joined: Tue Nov 29, 2005 5:06 pm

Re: Forum now unavailable - 'White Screen'

by pathfinderenterprises » Mon Oct 02, 2017 7:56 am

I am not comfortable with MYSQL and avoid doing anything to my databases if at all possible.

Are these the correct steps for running your query?

1. Back Up my DBase (within my forum)
2. Login to my cPanel
3. phpMyAdmin
4. Select my DBase
5. Select SQL Tab
6. Paste your query into window
7. Select GO
8. Cross my fingers and hope I've not screwed anything up
Keith


If everything seems to be going well, you have obviously overlooked something.
pathfinderenterprises
Registered User
Posts: 142
Joined: Fri Aug 04, 2006 5:14 pm
Location: Bolton
Contact:

Re: Forum now unavailable - 'White Screen'

by Blitze » Mon Oct 02, 2017 1:44 pm

Yep, that's it :)
My Extensions: phpBB SiteMaker
Blitze
Registered User
Posts: 366
Joined: Tue Nov 29, 2005 5:06 pm

Re: Forum now unavailable - 'White Screen'

by pathfinderenterprises » Mon Oct 02, 2017 3:54 pm

Thanks.

So, when I've done that what should I do?
1. Delete the ext Data or
2. Enable the ext or
3. Re-install the ext
Keith


If everything seems to be going well, you have obviously overlooked something.
pathfinderenterprises
Registered User
Posts: 142
Joined: Fri Aug 04, 2006 5:14 pm
Location: Bolton
Contact:

Re: Forum now unavailable - 'White Screen'

by Blitze » Mon Oct 02, 2017 4:04 pm

That's up to you at that point. The bug prevented you from deleting the data or enabling the extension of you had disabled it. After taking the above steps you should be able to delete data or enable the extension again.
My Extensions: phpBB SiteMaker
Blitze
Registered User
Posts: 366
Joined: Tue Nov 29, 2005 5:06 pm

Re: Forum now unavailable - 'White Screen'

by pathfinderenterprises » Tue Oct 03, 2017 8:29 am

O.k.
1. I ran your query and all seemed to be ok (I got a green message)
2. I tried to delete the data and my original error message
3. I deleted the old files and uploaded a new set and then tried to enable the ext and again I got the error.

This is the full error:
General Error
SQL ERROR [ mysqli ]

Table 'havenown_hof.phpbb_sm_blocks' doesn't exist [1146]

SQL

SHOW COLUMNS FROM phpbb_sm_blocks

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 999
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/tools/tools.php
LINE: 885
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/phpbb/db/tools/tools.php
LINE: 902
CALL: phpbb\db\tools\tools->sql_list_columns()

FILE: [ROOT]/phpbb/db/tools/tools.php
LINE: 541
CALL: phpbb\db\tools\tools->sql_column_exists()

FILE: (not given by php)
LINE: (not given by php)
CALL: phpbb\db\tools\tools->perform_schema_changes()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 711
CALL: call_user_func_array()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 658
CALL: phpbb\db\migrator->run_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 400
CALL: phpbb\db\migrator->process_data_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 351
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 351
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 288
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 241
CALL: phpbb\db\migrator->update_do()

FILE: [ROOT]/phpbb/extension/base.php
LINE: 78
CALL: phpbb\db\migrator->update()

FILE: [ROOT]/phpbb/extension/manager.php
LINE: 190
CALL: phpbb\extension\base->enable_step()

FILE: [ROOT]/includes/acp/acp_extensions.php
LINE: 209
CALL: phpbb\extension\manager->enable_step()

FILE: [ROOT]/includes/functions_module.php
LINE: 676
CALL: acp_extensions->main()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()
Keith


If everything seems to be going well, you have obviously overlooked something.
pathfinderenterprises
Registered User
Posts: 142
Joined: Fri Aug 04, 2006 5:14 pm
Location: Bolton
Contact:

Re: Forum now unavailable - 'White Screen'

by RMcGirr83 » Tue Oct 03, 2017 9:36 am

Where did you get the "new set" of files from?
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored
User avatar
RMcGirr83
Recognised Extension Developer
Posts: 20925
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: Forum now unavailable - 'White Screen'

by pathfinderenterprises » Tue Oct 03, 2017 10:31 am

https://www.phpbb.com/customise/db/download/146251

I just did what I do with any other ext update - disable (your ext was already disabled) - delete existing files - upload new files - enable ext.
Keith


If everything seems to be going well, you have obviously overlooked something.
pathfinderenterprises
Registered User
Posts: 142
Joined: Fri Aug 04, 2006 5:14 pm
Location: Bolton
Contact:

Re: Forum now unavailable - 'White Screen'

by Blitze » Tue Oct 03, 2017 2:31 pm

No, I have not released any new versions. You fixed the problem, then you downloaded an old version and reintroduced the problem. I have removed that block on my site so people don't download an older version. The upcoming version is 3.1.0 and it has been submitted for validation.
My Extensions: phpBB SiteMaker
Blitze
Registered User
Posts: 366
Joined: Tue Nov 29, 2005 5:06 pm

Re: Forum now unavailable - 'White Screen'

by pathfinderenterprises » Tue Oct 03, 2017 5:01 pm

After running your query the first thing I tried to do was delete the existing data and I got the error. It was only after trying that I uploaded the files. So, it seems that running the query didn't solve the problem.

Just to be sure, I have run your query again and still can't delete data. I have also tried enabling the ext but again I get the same error.

Will installing your new version, when it is available, rectify the error?
Keith


If everything seems to be going well, you have obviously overlooked something.
pathfinderenterprises
Registered User
Posts: 142
Joined: Fri Aug 04, 2006 5:14 pm
Location: Bolton
Contact:

Re: Forum now unavailable - 'White Screen'

by Blitze » Sun Oct 08, 2017 4:44 am

Ok, I have learned more about this bug. The bug is real, but you only experienced it because you tried to purge this extension. I don't know if this is a phpBB bug or a bug introduced by my extension but here's what's going on.

With version 3.0.1, I made a change (migration) that added a table column and dropped another in the sm_blocks table. I also added instructions to revert the changes when the extension is purged. This change has a dependency on the initial migration that created the sm_blocks table. When you purge the extension, it deletes the sm_blocks table before reverting the aforementioned migration, thereby causing the error message you see.

I have addressed this issue going forward but here's the problem: If you had purged this extension and ran into this bug, you lost the sm_blocks table but the extension was not purged. So you can't purge it because of the database error message, but you also cannot enable it because the sm_blocks table is missing. So what to do? I am weighing options. I have reached out to the devs for advice. Waiting for response... Stay tuned...
My Extensions: phpBB SiteMaker
Blitze
Registered User
Posts: 366
Joined: Tue Nov 29, 2005 5:06 pm