Scroll Page

Missing arrow images - Scroll Page

Missing arrow images

by Electrix » Tue Feb 02, 2016 2:05 pm

Hello, I was using your extension "Scroll to top" on my board without any problems. Today I tried to switch to you new extension "Scroll page".

The problem is, that the floating black rectangle appears, but there are no arrows inside.
arrows.png
arrows.png (1.36 KiB) Viewed 142 times
I did a little research and found out, that the cause was this CSS rule:

Code: Select all

background-image: url('./images/sprite.svg'); /* SVG image */
When I switched this rule off (or commented out), the arrows appeared. The strange part is the arrows originally (without modifications) did not appear only on production board, but they did appear on localhost (Win32 XAMPP).

So I'm assuming, there is something different about CSS rules, or SVG handling on "non-localhost" pages. I have reproduced the exactly same results with Chrome (48.0), Firefox (44.0) and MS Edge (25.0).

Is there any other way to fix this part from deleting SVG background from CSS rules? Thank you.
„Only a life lived for others is a life worthwhile.“[A. Einstein]
User avatar
Electrix
Registered User
Posts: 41
Joined: Mon Apr 13, 2015 10:21 am
Location: Czech Republic
Contact:

Re: Missing arrow images

by VSE » Tue Feb 02, 2016 3:13 pm

Sounds more like a problem with where your production board is hosted? Maybe they have a problem with SVG files?

Read: https://css-tricks.com/snippets/htacces ... tent-type/

For phpBB 3.2 this will probably switch to icon fonts, so it won't be image based anymore.
🧩 My Extensions 🧩 ✨ YES...they ALL work with phpBB 3.3!! ✨
Please do not PM me for support.
User avatar
VSE
Extensions Development Coordinator
Extensions Development Coordinator
Posts: 5065
Joined: Sat Jan 17, 2009 9:37 am
Location: Los Angeles, CA
Name: Matt Friedman
Contact: