Simple mentions

Not working on my board with phpBB3.2.1 - Resolved :) - Simple mentions

Not working on my board with phpBB3.2.1 - Resolved :)

by neeraj.sinha » Thu Oct 05, 2017 7:44 am

I installed this extension and it is enabled, however, nothing happens when I type "@" in a post. The user doesn't gets tagged even if I manually complete his username. What have I done wrong?

Pls check the attached screen-grabs.
phpBB Version.png
Installed Extensions.png
extension details.png
Not Working.png
Last edited by neeraj.sinha on Fri Oct 06, 2017 5:14 am
neeraj.sinha
Registered User
Posts: 16
Joined: Wed Oct 04, 2017 3:53 pm
Contact:

Re: Not working on my board with phpBB3.2.1

by Paul » Thu Oct 05, 2017 7:57 am

Did you set the permissions correctly?
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development
Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 25229
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: Not working on my board with phpBB3.2.1

by neeraj.sinha » Thu Oct 05, 2017 8:39 am

What permissions need to be set and where?
neeraj.sinha
Registered User
Posts: 16
Joined: Wed Oct 04, 2017 3:53 pm
Contact:

Re: Not working on my board with phpBB3.2.1

by Paul » Thu Oct 05, 2017 8:51 am

The mention permission in forums permission
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development
Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 25229
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: Not working on my board with phpBB3.2.1

by neeraj.sinha » Thu Oct 05, 2017 9:01 am

Can't see any "mention" permission to enable
Content permissions.png
Post Permissions.png
Is there any configuration guide available?
neeraj.sinha
Registered User
Posts: 16
Joined: Wed Oct 04, 2017 3:53 pm
Contact:

Re: Not working on my board with phpBB3.2.1

by neeraj.sinha » Thu Oct 05, 2017 9:42 am

Going through other support threads, I even checked Roles > Forum Permissions for Standard Access (given to Registered Users), still can't see the mention setting there.
Roles-Forum Permissions.png
neeraj.sinha
Registered User
Posts: 16
Joined: Wed Oct 04, 2017 3:53 pm
Contact:

Re: Not working on my board with phpBB3.2.1

by neeraj.sinha » Thu Oct 05, 2017 10:00 am

Ok, so the Mention button is visible while posting, but an error message appears stating "You cannot use certain BBCodes: [mention]."
permission issue.png
Must have something to do with the permissions, but I've tried to find it out everywhere without any luck. Any help will be appreciated please.
neeraj.sinha
Registered User
Posts: 16
Joined: Wed Oct 04, 2017 3:53 pm
Contact:

Re: Not working on my board with phpBB3.2.1

by neeraj.sinha » Fri Oct 06, 2017 5:14 am

Finally, I managed to resolve it. For benefit of others. Here's what you need to do:

1. Upload the extentions to relevant directory (/ext)
2. ACP >> Customize >> Simple Mentions >> Enable
3. ACP >> Permissions >> Global Permissions >> Group Permissions >> Registered Users >> User Permissions >> Roles >> Mics >> Can use the mention System = Yes
OR
3. ACP >> Permissions >> Permission Roles >> User Roles >> Standard Features >> Edit >> User permissions >> Mics >> Can use the mention System = Yes

@Paul: It would be great if you can add the above instructions on the mod installation instructions so that no one has to scourge through various threads here and there to find it out. With various mention of roles, I was confused and thought it to be ACP >> Permissions >> Permission Roles >> Forum Roles

Nice extension Paul! :)
neeraj.sinha
Registered User
Posts: 16
Joined: Wed Oct 04, 2017 3:53 pm
Contact:

Re: Not working on my board with phpBB3.2.1 - Resolved :)

by eunaumtenhoid » Fri Oct 27, 2017 9:58 pm

dont work for me:

sometimes it works, sometimes it does not work
My translations of the extensions for Brazilian Portuguese
https://github.com/phpBBTraducoes
User avatar
eunaumtenhoid
Registered User
Posts: 850
Joined: Wed Jun 03, 2009 12:46 am
Location: ????

Re: Not working on my board with phpBB3.2.1 - Resolved :)

by Bermudez » Fri Nov 17, 2017 4:39 pm

eunaumtenhoid wrote:dont work for me:

sometimes it works, sometimes it does not work
That happens to me too.
Bermudez
Registered User
Posts: 142
Joined: Mon Aug 15, 2011 11:56 pm
Location: Spain
Name: Juan Antonio
Contact:

Re: Not working on my board with phpBB3.2.1 - Resolved :)

by neeraj.sinha » Sat Nov 18, 2017 4:24 am

Please ensure you follow the exact steps given by me at https://www.phpbb.com/customise/db/exte ... f9#p592026

It's working perfectly for me at https://scoutmytrip.com/community/
neeraj.sinha
Registered User
Posts: 16
Joined: Wed Oct 04, 2017 3:53 pm
Contact:

Re: Not working on my board with phpBB3.2.1 - Resolved :)

by odf » Tue Nov 21, 2017 10:33 am

neeraj.sinha wrote:Finally, I managed to resolve it. For benefit of others. Here's what you need to do:

1. Upload the extentions to relevant directory (/ext)
2. ACP >> Customize >> Simple Mentions >> Enable
3. ACP >> Permissions >> Global Permissions >> Group Permissions >> Registered Users >> User Permissions >> Roles >> Mics >> Can use the mention System = Yes
OR
3. ACP >> Permissions >> Permission Roles >> User Roles >> Standard Features >> Edit >> User permissions >> Mics >> Can use the mention System = Yes

@Paul: It would be great if you can add the above instructions on the mod installation instructions so that no one has to scourge through various threads here and there to find it out. With various mention of roles, I was confused and thought it to be ACP >> Permissions >> Permission Roles >> Forum Roles

Nice extension Paul! :)
I followed exactly what you wrote but extension still doesn't work. I can @person but they will not get notification that they are mentioned. @Paul, can you help on this?
odf
Registered User
Posts: 95
Joined: Sun Jan 22, 2017 8:55 pm
Contact:

Re: Not working on my board with phpBB3.2.1 - Resolved :)

by neeraj.sinha » Tue Nov 21, 2017 11:19 am

The mentioned person doesn't even gets a notification in the notification panel? That's strange!

Of course the email notification is something that the user has to set under UCP > Board Preferences > Edit Notification options > Someone mentioned me > mail has to be ticked.
neeraj.sinha
Registered User
Posts: 16
Joined: Wed Oct 04, 2017 3:53 pm
Contact:

Re: Not working on my board with phpBB3.2.1 - Resolved :)

by eunaumtenhoid » Tue Nov 21, 2017 11:42 am

odf wrote:
neeraj.sinha wrote:Finally, I managed to resolve it. For benefit of others. Here's what you need to do:

1. Upload the extentions to relevant directory (/ext)
2. ACP >> Customize >> Simple Mentions >> Enable
3. ACP >> Permissions >> Global Permissions >> Group Permissions >> Registered Users >> User Permissions >> Roles >> Mics >> Can use the mention System = Yes
OR
3. ACP >> Permissions >> Permission Roles >> User Roles >> Standard Features >> Edit >> User permissions >> Mics >> Can use the mention System = Yes

@Paul: It would be great if you can add the above instructions on the mod installation instructions so that no one has to scourge through various threads here and there to find it out. With various mention of roles, I was confused and thought it to be ACP >> Permissions >> Permission Roles >> Forum Roles

Nice extension Paul! :)
I followed exactly what you wrote but extension still doesn't work. I can @person but they will not get notification that they are mentioned. @Paul, can you help on this?
I TOO
My translations of the extensions for Brazilian Portuguese
https://github.com/phpBBTraducoes
User avatar
eunaumtenhoid
Registered User
Posts: 850
Joined: Wed Jun 03, 2009 12:46 am
Location: ????

Re: Not working on my board with phpBB3.2.1 - Resolved :)

by odf » Sun Dec 31, 2017 1:48 pm

This is what I discovered regarding the simple mentions ext:

If by the time you're creating a post/topic and mention some user(s), they will get notification that they have been mentioned in some topic/post. But, if you create a topic/post, submit it and then go back, edit it, mention some users and re-submit it, the users you mentioned after editing post/topic won't be notified!

What could be the solution to the problem?
odf
Registered User
Posts: 95
Joined: Sun Jan 22, 2017 8:55 pm
Contact: