Simple mentions

[3.3] @ does not work - [mention]username[/mention] works - Simple mentions

[3.3] @ does not work - [mention]username[/mention] works

by Kaffe » Fri Jan 10, 2020 8:51 pm

As described in the subject, @ does not trigger a dropdown list of usernames. However, the [mention]username[/mention] BBCode works.

In addtion, checking my browser debugger gives me this:
[Error] Failed to load resource: the server responded with a status of 500 (Internal Server Error) (mentionloc, line 0) https://MYURL.TLD/mentionloc?q=Kaf
Kaffe
Registered User
Posts: 72
Joined: Tue Nov 01, 2016 6:18 pm

Re: [3.3] @ does not work - [mention]username[/mention] work

by cprgolds » Fri Jan 10, 2020 10:53 pm

It is working fine for me. Did it work for you previously?
User avatar
cprgolds
Registered User
Posts: 458
Joined: Thu Oct 11, 2007 5:49 am
Location: Portland, Oregon
Contact:

Re: [3.3] @ does not work - [mention]username[/mention] work

by Kaffe » Fri Jan 10, 2020 11:22 pm

I installed the extension on a clean install of 3.3
Kaffe
Registered User
Posts: 72
Joined: Tue Nov 01, 2016 6:18 pm

Re: [3.3] @ does not work - [mention]username[/mention] work

by cprgolds » Fri Jan 10, 2020 11:53 pm

Did you start typing a name, or just wait for the dropdown? You need to start typing the name.
User avatar
cprgolds
Registered User
Posts: 458
Joined: Thu Oct 11, 2007 5:49 am
Location: Portland, Oregon
Contact:

Re: [3.3] @ does not work - [mention]username[/mention] work

by Kaffe » Sat Jan 11, 2020 9:33 am

I am starting to type the name, but nothing.
I am running php version 7.2, can that be the problem?
Kaffe
Registered User
Posts: 72
Joined: Tue Nov 01, 2016 6:18 pm

Re: [3.3] @ does not work - [mention]username[/mention] work

by Paul » Sat Jan 11, 2020 4:23 pm

Please provide your board URL + a test account.
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development
Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 26259
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: [3.3] @ does not work - [mention]username[/mention] work

by SimInnovations » Tue Feb 04, 2020 9:47 am

We have the same problem, the mention plugin prevents our phpBB system from working (running PHP 7.1.14). It's a stock 3.3.0 phpBB installation.
If you want then I can set up an example installation. Or do you have an idea already of what it can be?
SimInnovations
Registered User
Posts: 1
Joined: Tue Feb 04, 2020 9:41 am
Location: The Netherlands
Contact:

Re: [3.3] @ does not work - [mention]username[/mention] work

by ZeldaClassic » Thu Feb 20, 2020 11:04 am

I can confirm that this fails to work:

PHPBB 3.3.0, clean install;
DB: MySQL(i) 5.7.29-0ubuntu0.18.04.1
PHP: 7.2.24-0ubuntu0.18.04.3

Forum URL: https:/openzc.org/forum

I disabled all of the WYSIWYG extensions to see if the conflict was with them, but with the base editor, the @mention ext outright fails to create dropdown listers or insert mention tags around the username.
ZeldaClassic
Registered User
Posts: 11
Joined: Thu Feb 20, 2020 11:00 am
Contact:

Re: [3.3] @ does not work - [mention]username[/mention] work

by Paul » Sat Feb 22, 2020 10:48 am

I just tried it on a clean 3.3 install with a clean download from the extension, and it works as expected. If it doesn't work, please provide a board URL + test account otherwise I am not able to help.
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development
Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 26259
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: [3.3] @ does not work - [mention]username[/mention] work

by ZeldaClassic » Sun Feb 23, 2020 12:45 am

Paul wrote:I just tried it on a clean 3.3 install with a clean download from the extension, and it works as expected. If it doesn't work, please provide a board URL + test account otherwise I am not able to help.
I added you as user Paul, with a loopback email. I'll sent a PM to you, with your password. Please inform me of what access level you require, and if you need ssh.

https://openzc.org/forum/viewforum.php?f=7

You can make test topics on that board.
ZeldaClassic
Registered User
Posts: 11
Joined: Thu Feb 20, 2020 11:00 am
Contact:

Re: [3.3] @ does not work - [mention]username[/mention] work

by ZeldaClassic » Sun Feb 23, 2020 1:03 am

Here, also, is the Chrome console output:

Code: Select all

GET https://openzc.org/forum/app.php/cron/cron.task.core.tidy_warnings 404 (Not Found)
jquery-3.4.1.min.js?assets_version=16:2 GET https://openzc.org/forum/app.php/mentionloc?q= 404 (Not Found)
send @ jquery-3.4.1.min.js?assets_version=16:2
ajax @ jquery-3.4.1.min.js?assets_version=16:2
k.<computed> @ jquery-3.4.1.min.js?assets_version=16:2
getJSON @ jquery-3.4.1.min.js?assets_version=16:2
remoteSearch @ mention.js?assets_version=16:5
values @ mention.js?assets_version=16:22
value @ tribute.js:330
value @ tribute.js:654
value @ tribute.js:591
jquery-3.4.1.min.js?assets_version=16:2 GET https://openzc.org/forum/app.php/mentionloc?q=Z 404 (Not Found)
send @ jquery-3.4.1.min.js?assets_version=16:2
ajax @ jquery-3.4.1.min.js?assets_version=16:2
k.<computed> @ jquery-3.4.1.min.js?assets_version=16:2
getJSON @ jquery-3.4.1.min.js?assets_version=16:2
remoteSearch @ mention.js?assets_version=16:5
values @ mention.js?assets_version=16:22
value @ tribute.js:330
value @ tribute.js:654
value @ tribute.js:591
jquery-3.4.1.min.js?assets_version=16:2 GET https://openzc.org/forum/app.php/mentionloc?q=Zo 404 (Not Found)
send @ jquery-3.4.1.min.js?assets_version=16:2
ajax @ jquery-3.4.1.min.js?assets_version=16:2
k.<computed> @ jquery-3.4.1.min.js?assets_version=16:2
getJSON @ jquery-3.4.1.min.js?assets_version=16:2
remoteSearch @ mention.js?assets_version=16:5
values @ mention.js?assets_version=16:22
value @ tribute.js:330
value @ tribute.js:654
value @ tribute.js:591
jquery-3.4.1.min.js?assets_version=16:2 GET https://openzc.org/forum/app.php/mentionloc?q=Zor 404 (Not Found)
send @ jquery-3.4.1.min.js?assets_version=16:2
ajax @ jquery-3.4.1.min.js?assets_version=16:2
k.<computed> @ jquery-3.4.1.min.js?assets_version=16:2
getJSON @ jquery-3.4.1.min.js?assets_version=16:2
remoteSearch @ mention.js?assets_version=16:5
values @ mention.js?assets_version=16:22
value @ tribute.js:330
value @ tribute.js:654
value @ tribute.js:591
jquery-3.4.1.min.js?assets_version=16:2 GET https://openzc.org/forum/app.php/mentionloc?q=Zori 404 (Not Found)
send @ jquery-3.4.1.min.js?assets_version=16:2
ajax @ jquery-3.4.1.min.js?assets_version=16:2
k.<computed> @ jquery-3.4.1.min.js?assets_version=16:2
getJSON @ jquery-3.4.1.min.js?assets_version=16:2
remoteSearch @ mention.js?assets_version=16:5
values @ mention.js?assets_version=16:22
value @ tribute.js:330
value @ tribute.js:654
value @ tribute.js:591
jquery-3.4.1.min.js?assets_version=16:2 GET https://openzc.org/forum/app.php/mentionloc?q=Zoria 404 (Not Found)
send @ jquery-3.4.1.min.js?assets_version=16:2
ajax @ jquery-3.4.1.min.js?assets_version=16:2
k.<computed> @ jquery-3.4.1.min.js?assets_version=16:2
getJSON @ jquery-3.4.1.min.js?assets_version=16:2
remoteSearch @ mention.js?assets_version=16:5
values @ mention.js?assets_version=16:22
value @ tribute.js:330
value @ tribute.js:654
value @ tribute.js:591
jquery-3.4.1.min.js?assets_version=16:2 GET https://openzc.org/forum/app.php/mentionloc?q=ZoriaR 404 (Not Found)
send @ jquery-3.4.1.min.js?assets_version=16:2
ajax @ jquery-3.4.1.min.js?assets_version=16:2
k.<computed> @ jquery-3.4.1.min.js?assets_version=16:2
getJSON @ jquery-3.4.1.min.js?assets_version=16:2
remoteSearch @ mention.js?assets_version=16:5
values @ mention.js?assets_version=16:22
value @ tribute.js:330
value @ tribute.js:654
value @ tribute.js:591
jquery-3.4.1.min.js?assets_version=16:2 GET https://openzc.org/forum/app.php/mentionloc?q=ZoriaRP 404 (Not Found)
send @ jquery-3.4.1.min.js?assets_version=16:2
ajax @ jquery-3.4.1.min.js?assets_version=16:2
k.<computed> @ jquery-3.4.1.min.js?assets_version=16:2
getJSON @ jquery-3.4.1.min.js?assets_version=16:2
remoteSearch @ mention.js?assets_version=16:5
values @ mention.js?assets_version=16:22
value @ tribute.js:330
value @ tribute.js:654
value @ tribute.js:591
jquery-3.4.1.min.js?assets_version=16:2 GET https://openzc.org/forum/app.php/mentionloc?q=ZoriaRPG 404 (Not Found)
This seems to be an nginx config issue. I'm looking into it and I'll report back if I find a solution.
ZeldaClassic
Registered User
Posts: 11
Joined: Thu Feb 20, 2020 11:00 am
Contact:

Re: [3.3] @ does not work - [mention]username[/mention] work

by ZeldaClassic » Sun Feb 23, 2020 11:24 am

I solved this. The issue was with the local site config.

In the local site config (for NGINX):

Code: Select all

/etc/nginx/sites-available/openzc.org
under

Code: Select all

server {
, I had this:

Code: Select all

location /app.php 
{ 
    try_files $uri $uri/ /forum/app.php?$query_st$
}
I had missed the absolute path to app.php in the above.

Changing it as follows was what I needed to do

Code: Select all

location /forum/app.php 
{ 
    try_files $uri $uri/ /forum/app.php?$query_st$
}
ZeldaClassic
Registered User
Posts: 11
Joined: Thu Feb 20, 2020 11:00 am
Contact:

Re: [3.3] @ does not work - [mention]username[/mention] work

by saltymichael » Thu Apr 09, 2020 9:27 pm

I can get it to work with dropdown, my problem is it isn't notifying anyone I mention? how to fix?
saltymichael
Registered User
Posts: 27
Joined: Fri Apr 03, 2020 5:06 pm
Contact:

Re: [3.3] @ does not work - [mention]username[/mention] work

by Cubguy501 » Tue Apr 21, 2020 1:20 pm

I also have the drop down working fine... but no notifications. Any help?
i can get u an account on my test board if need be

running 3.3, and php 7.3.16

EDIT::: never mind.... it works. i was tagging a test user that didn't have access to the forum i was tagging him in. therefore he doesn't get the notification im guessing.
Cubguy501
Registered User
Posts: 136
Joined: Mon Feb 07, 2011 8:39 pm
Contact:

Re: [3.3] @ does not work - [mention]username[/mention] work

by kobasamsu » Wed Jun 10, 2020 11:42 am

working... but not working safari
kobasamsu
Registered User
Posts: 4
Joined: Sat May 09, 2020 9:08 am
Contact: