Simple Spoiler BBCode

Show button doesn't work - Simple Spoiler BBCode

Show button doesn't work

by elbeborandy » Sun Jun 25, 2017 6:47 am

Hi! I already tested with another previous version (and it was working with my mobile version responsive but now with the last version is not working).

Doesn't matter the browser, ready tested on Mozilla, Safari, Chrome and Opera.

Details:

1) I'm using Flatboots style.

Image

2) My extensions right now:

Image

3) Button of show/mostrar doesn't work neither on preview or posted.

Waiting for a help :) Those extension aren't free :$ So I would like to stay with them ;$


--- Update: Works on Chrome, IE and Edge. Not Mozilla, Opera or Safari.
elbeborandy
Registered User
Posts: 20
Joined: Wed Jun 21, 2017 2:45 pm
Contact:

Re: Show button doesn't work

by elbeborandy » Sun Jun 25, 2017 6:57 am

Update.... Works on Chrome, IE and Edge. Not Mozilla, Opera or Safari.
elbeborandy
Registered User
Posts: 20
Joined: Wed Jun 21, 2017 2:45 pm
Contact:

Re: Show button doesn't work

by elbeborandy » Sun Jun 25, 2017 7:04 am

Well another update... thing is not working always on those browser I already said it was... :$ just some times... (preview and posted spoiler)
elbeborandy
Registered User
Posts: 20
Joined: Wed Jun 21, 2017 2:45 pm
Contact:

Re: Show button doesn't work

by AbaddonOrmuz » Mon Jun 26, 2017 3:23 am

Looking at your website I see the spoiler script is loaded before jQuery, so that's why it does not work.

Image

You, an extension, or the style you're using have done modifications in the way jQuery is loaded whitin the template, so I would suggest to revert back these changes as it will create conflict with other extensions that need this library.

I don't think that you really need to load that library in particular asyncronically.
Some of my phpBB extensions:
Image Imgur | :chart_with_upwards_trend: SEO Metadata | Image Markdown | :lock: Auto-lock Topics
:trophy: Check out all my validated extensions :trophy:

:penguin: Arch Linux user :penguin:
User avatar
AbaddonOrmuz
Recognised Extension Developer
Posts: 978
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo
Contact:

Re: Show button doesn't work

by elbeborandy » Mon Jun 26, 2017 8:28 am

AbaddonOrmuz wrote:Looking at your website I see the spoiler script is loaded before jQuery, so that's why it does not work.

Image

You, an extension, or the style you're using have done modifications in the way jQuery is loaded whitin the template, so I would suggest to revert back these changes as it will create conflict with other extensions that need this library.

I don't think that you really need to load that library in particular asyncronically.
Ehm, other solution? Because, again, like I told you, I paid for style and apps. So I cant revert anything or disable.
elbeborandy
Registered User
Posts: 20
Joined: Wed Jun 21, 2017 2:45 pm
Contact:

Re: Show button doesn't work

by AbaddonOrmuz » Tue Jun 27, 2017 12:20 am

elbeborandy wrote:Ehm, other solution? Because, again, like I told you, I paid for style and apps. So I cant revert anything or disable.
Looking at the source code, you could try wrapping the JavaScript code inside the head.ready() function, and there's another solution: ask for support to the style author.

It's not a problem of my extension, so there's nothing to fix ;)
Some of my phpBB extensions:
Image Imgur | :chart_with_upwards_trend: SEO Metadata | Image Markdown | :lock: Auto-lock Topics
:trophy: Check out all my validated extensions :trophy:

:penguin: Arch Linux user :penguin:
User avatar
AbaddonOrmuz
Recognised Extension Developer
Posts: 978
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo
Contact:

Re: Show button doesn't work

by elbeborandy » Tue Jun 27, 2017 4:59 am

It's not a problem for your extension but you can create support for that theme.

What an answer from you. Very sad.
elbeborandy
Registered User
Posts: 20
Joined: Wed Jun 21, 2017 2:45 pm
Contact:

Re: Show button doesn't work

by AbaddonOrmuz » Tue Jun 27, 2017 4:52 pm

As I said, that's not a problem of my extension and if I make changes, I won't be able to test as It's not a free style and I won't buy it just to test; paid styles have their own support system.

I'm giving you support for the extension, I even gave you the solution, I don't know what else you expect from me.
Some of my phpBB extensions:
Image Imgur | :chart_with_upwards_trend: SEO Metadata | Image Markdown | :lock: Auto-lock Topics
:trophy: Check out all my validated extensions :trophy:

:penguin: Arch Linux user :penguin:
User avatar
AbaddonOrmuz
Recognised Extension Developer
Posts: 978
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo
Contact:

Re: Show button doesn't work

by onlyproevo » Thu Jun 29, 2017 2:46 pm

AbaddonOrmuz wrote:As I said, that's not a problem of my extension and if I make changes, I won't be able to test as It's not a free style and I won't buy it just to test; paid styles have their own support system.

I'm giving you support for the extension, I even gave you the solution, I don't know what else you expect from me.
Hi friend.

It seems your Simple Spoiler isn't compatible with QuickReply Reloaded. It works OK once a post has been published, however, the Show button does not work in post preview.

Can you confirm this? And, assuming this is the case, is it possible to provide a fix?

Thanks! :)
onlyproevo
Registered User
Posts: 110
Joined: Tue Jun 21, 2011 8:13 pm
Contact:

Re: Show button doesn't work

by AbaddonOrmuz » Thu Jun 29, 2017 7:28 pm

onlyproevo wrote:Hi friend.

It seems your Simple Spoiler isn't compatible with QuickReply Reloaded. It works OK once a post has been published, however, the Show button does not work in post preview.

Can you confirm this? And, assuming this is the case, is it possible to provide a fix?

Thanks! :)
Hi 8-)

Open the following file and change its content:

File name:

Code: Select all

ext/alfredoramos/simplespoiler/styles/all/template/event/overall_footer_body_after.html
File content:

Code: Select all

<!-- IF not $INCLUDED_SPOILER_JS -->
<!-- INCLUDEJS @alfredoramos_simplespoiler/js/spoiler.js -->
<script type="text/javascript">
$(function() {
	'use strict';
	var $spoilers = function(elements) {
		elements.find('.spoiler').initSpoilers({
			showText: '{LA_SPOILER_SHOW}',
			hideText: '{LA_SPOILER_HIDE}'
		});
	};
	$spoilers($(document));
	$('#qr_posts').on('qr_completed', $spoilers);
	$('#qr_postform').on('ajax_submit_preview', function() {
		$spoilers($('#preview'));
	});
});
</script>
<!-- DEFINE $INCLUDED_SPOILER_JS = true -->
<!-- ENDIF -->
Please test and if you have issues open a new support topic ;)
Some of my phpBB extensions:
Image Imgur | :chart_with_upwards_trend: SEO Metadata | Image Markdown | :lock: Auto-lock Topics
:trophy: Check out all my validated extensions :trophy:

:penguin: Arch Linux user :penguin:
User avatar
AbaddonOrmuz
Recognised Extension Developer
Posts: 978
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo
Contact:

Re: Show button doesn't work

by onlyproevo » Thu Jun 29, 2017 10:23 pm

AbaddonOrmuz wrote: Please test and if you have issues open a new support topic
Quote onlyproevo
That fixed it! Thanks! :D
onlyproevo
Registered User
Posts: 110
Joined: Tue Jun 21, 2011 8:13 pm
Contact:

Re: Show button doesn't work

by onlyproevo » Fri Jun 30, 2017 10:09 am

onlyproevo wrote:
AbaddonOrmuz wrote: Please test and if you have issues open a new support topic
Quote onlyproevo
That fixed it! Thanks! :D
OK, so I've noticed a new issue.

When I submit a new post, the post preview does not disappear.

Any chance you could look into this for me?
onlyproevo
Registered User
Posts: 110
Joined: Tue Jun 21, 2011 8:13 pm
Contact:

Re: Show button doesn't work

by AbaddonOrmuz » Fri Jun 30, 2017 3:15 pm

onlyproevo wrote:OK, so I've noticed a new issue.

When I submit a new post, the post preview does not disappear.

Any chance you could look into this for me?
Are you sure it's not a problem of that extension? I mean, It's a beta version, you might want to wait until they release a stable one.

I don't see how calling a function using other events would do that, I'll look into it.
Some of my phpBB extensions:
Image Imgur | :chart_with_upwards_trend: SEO Metadata | Image Markdown | :lock: Auto-lock Topics
:trophy: Check out all my validated extensions :trophy:

:penguin: Arch Linux user :penguin:
User avatar
AbaddonOrmuz
Recognised Extension Developer
Posts: 978
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo
Contact:

Re: Show button doesn't work

by onlyproevo » Fri Jun 30, 2017 3:43 pm

AbaddonOrmuz wrote: I mean, It's a beta version, you might want to wait until they release a stable one.

I don't see how calling a function using other events would do that, I'll look into it.
Will do.

And thanks. :mrgreen:
onlyproevo
Registered User
Posts: 110
Joined: Tue Jun 21, 2011 8:13 pm
Contact:

Re: Show button doesn't work

by elbeborandy » Sat Jul 01, 2017 4:58 pm

And about my style (FLATBOOTS), the author made a fix of my problem :)
elbeborandy
Registered User
Posts: 20
Joined: Wed Jun 21, 2017 2:45 pm
Contact: