Simple Spoiler BBCode

Spoiler button not working - Simple Spoiler BBCode

Spoiler button not working

by tstarnes » Wed Oct 31, 2018 1:50 pm

Using PHPBB 3.2.3 and Simple Spoiler 1.3.0

When I put in the spoiler code, I see the text is hidden and the red button, but when you click on it, nothing happens. Checked it in chrome and firefox, and it doesn't work in either.
tstarnes
Registered User
Posts: 3
Joined: Wed Oct 31, 2018 1:48 pm
Contact:

Re: Spoiler button not working

by AbaddonOrmuz » Wed Oct 31, 2018 7:10 pm

Do you have a link? I can't fix a problem which I can't see.
Some of my phpBB extensions:
Image Imgur | :chart_with_upwards_trend: SEO Metadata | Image Markdown | :lock: Auto-lock Topics
:trophy: Check out all my validated extensions :trophy:

:penguin: Arch Linux user :penguin:
User avatar
AbaddonOrmuz
Recognised Extension Developer
Posts: 984
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo
Contact:

Re: Spoiler button not working

by Affin » Wed Nov 14, 2018 9:28 pm

Same thing for me nothing happens
Affin
I've Been Banned!
Posts: 256
Joined: Fri May 25, 2018 9:52 pm
Contact:

Re: Spoiler button not working

by AbaddonOrmuz » Wed Nov 14, 2018 9:45 pm

Affin wrote:Same thing for me nothing happens
The you get the same response:
AbaddonOrmuz wrote: Do you have a link? I can't fix a problem which I can't see.
I can't read minds nor magically get information about your board.

If anybody want me to help, they need to provide some basic information:

- phpBB version
- Spoiler version used
- Style name and version in case it's not prosilver
- URL where I can see a spoiler in action

Read the Customatization guide.
Some of my phpBB extensions:
Image Imgur | :chart_with_upwards_trend: SEO Metadata | Image Markdown | :lock: Auto-lock Topics
:trophy: Check out all my validated extensions :trophy:

:penguin: Arch Linux user :penguin:
User avatar
AbaddonOrmuz
Recognised Extension Developer
Posts: 984
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo
Contact:

Re: Spoiler button not working

by tstarnes » Tue Nov 27, 2018 7:51 pm

Sorry, I switched to something else since it wasn't working. But that other option doesn't work well either..

Example of a not working button is here: https://cmro.travis-starnes.com/forums/ ... 61#p173861

Spoiler Version: 1.3.0
PHPBB: 3.2.4
Style: Legacy
tstarnes
Registered User
Posts: 3
Joined: Wed Oct 31, 2018 1:48 pm
Contact:

Re: Spoiler button not working

by AbaddonOrmuz » Tue Nov 27, 2018 8:16 pm

tstarnes wrote:Sorry, I switched to something else since it wasn't working. But that other option doesn't work well either..

Example of a not working button is here: https://cmro.travis-starnes.com/forums/ ... 61#p173861

Spoiler Version: 1.3.0
PHPBB: 3.2.4
Style: Legacy
You didn't provide your style version (legacy), so I used the version 1.2.2 which is only for phpBB 3.2.2

That style is missing the {$SCRIPTS} template variable in the overall_footer.html file, which is essential for any extension that adds JavaScript code, not just mine.

https://github.com/phpbb/phpbb/blob/3.2 ... r.html#L43

The problem is your style, not the extension, and in that case I can't fix it from the extension.
Some of my phpBB extensions:
Image Imgur | :chart_with_upwards_trend: SEO Metadata | Image Markdown | :lock: Auto-lock Topics
:trophy: Check out all my validated extensions :trophy:

:penguin: Arch Linux user :penguin:
User avatar
AbaddonOrmuz
Recognised Extension Developer
Posts: 984
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo
Contact:

Re: Spoiler button not working

by tstarnes » Tue Nov 27, 2018 10:21 pm

Got it. Now that you pointed me in the right direction, I was able to figure it out and get it working. I knew it probably had to do with the outdated style being forced to work with the newer version, but I wasn't sure where to look. Thanks for the pointers (actual thanks, not sarcastic thanks, since it's hard to read tone in forums)
tstarnes
Registered User
Posts: 3
Joined: Wed Oct 31, 2018 1:48 pm
Contact: