Simple Spoiler BBCode

Doesn't work with 3.3? - Simple Spoiler BBCode

Doesn't work with 3.3?

by Dysphoria » Fri Feb 07, 2020 10:58 am

I think this extension doesn't work with 3.3, unless I did something wrong.
When I switch the extension on, I can't go to my forum index anymore until I switch the extension back off.
Dysphoria
Registered User
Posts: 17
Joined: Fri Feb 07, 2020 10:54 am
Contact:

Re: Doesn't work with 3.3?

by AbaddonOrmuz » Fri Feb 07, 2020 4:11 pm

It does work with phpBB 3.3.0
Some of my phpBB extensions:
Image Imgur | :chart_with_upwards_trend: SEO Metadata | Image Markdown | :lock: Auto-lock Topics
:trophy: Check out all my validated extensions :trophy:

:penguin: Arch Linux user :penguin:
User avatar
AbaddonOrmuz
Recognised Extension Developer
Posts: 1003
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo
Contact:

Re: Doesn't work with 3.3?

by Dysphoria » Fri Feb 07, 2020 4:46 pm

Weird, because I can't use it without getting an error on my forum index when I try to switch the extension on.
Dysphoria
Registered User
Posts: 17
Joined: Fri Feb 07, 2020 10:54 am
Contact:

Re: Doesn't work with 3.3?

by AbaddonOrmuz » Fri Feb 07, 2020 10:08 pm

Yes, really weird because it's being used on multiple live boards (phpBB 3.3.0) without errors.

But since you don't share that error message, I can't really do anything.
Some of my phpBB extensions:
Image Imgur | :chart_with_upwards_trend: SEO Metadata | Image Markdown | :lock: Auto-lock Topics
:trophy: Check out all my validated extensions :trophy:

:penguin: Arch Linux user :penguin:
User avatar
AbaddonOrmuz
Recognised Extension Developer
Posts: 1003
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo
Contact:

Re: Doesn't work with 3.3?

by Gwyneth Llewelyn » Sat Mar 07, 2020 6:04 pm

I have no problem whatsoever using this extension with phpBB 3.3.0 running under nginx + PHP 7.3.15 + Ubuntu 16.04.6.
I'm just a virtual girl in a virtual world...

Image
User avatar
Gwyneth Llewelyn
Registered User
Posts: 24
Joined: Thu Aug 06, 2009 11:34 pm
Location: Neufreistadt, Confederation of the Democratic Simulators, Second Life
Name: Gwyneth Llewelyn
Contact:

Re: Doesn't work with 3.3?

by Ancient Viking » Wed Aug 05, 2020 8:34 pm

I can't install this extension and that includes your other extension, despite for showning phpBB 3.3.0 in ACP.

However, I think I know why and that could be what I did here plus I don't think I meet the requirement for your two extensions. Which are the only two extensions I cannot install the latest version on my forum, so I had to install older versions which works as far I can tell.
My local forum: egetforum.nu - Offline Forum Online!
User avatar
Ancient Viking
Registered User
Posts: 550
Joined: Sun Jan 15, 2012 11:43 pm
Contact:

Re: Doesn't work with 3.3?

by AbaddonOrmuz » Wed Aug 05, 2020 11:40 pm

Ancient Viking wrote: I can't install this extension and that includes your other extension, despite for showning phpBB 3.3.0 in ACP.
Well there's a mismatch in the version between your database and files, that's a problem of your board, not the extension.
Ancient Viking wrote: However, I think I know why and that could be what I did here plus I don't think I meet the requirement for your two extensions. Which are the only two extensions I cannot install the latest version on my forum, so I had to install older versions which works as far I can tell.
Then you can't blame the extension.

I don't know which other extension you are talking about, but you will have the same "problem" with any extension that enforces a phpBB version equal or greater than 3.3.0 using the core function phpbb_version_compare(), which is the only requirement that is checked before installing.

Besides, there's a more update version for 3.2.x in this topic:

https://www.phpbb.com/customise/db/exte ... pic/208501
Some of my phpBB extensions:
Image Imgur | :chart_with_upwards_trend: SEO Metadata | Image Markdown | :lock: Auto-lock Topics
:trophy: Check out all my validated extensions :trophy:

:penguin: Arch Linux user :penguin:
User avatar
AbaddonOrmuz
Recognised Extension Developer
Posts: 1003
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo
Contact:

Re: Doesn't work with 3.3?

by Ancient Viking » Thu Aug 06, 2020 1:35 am

Then why are your extensions the only one I cannot install.

I can install all the other extensions and some was actually activated during the update due for being already compatible with phpBB 3.3.0.
My local forum: egetforum.nu - Offline Forum Online!
User avatar
Ancient Viking
Registered User
Posts: 550
Joined: Sun Jan 15, 2012 11:43 pm
Contact:

Re: Doesn't work with 3.3?

by AbaddonOrmuz » Thu Aug 06, 2020 1:56 am

Ancient Viking wrote: Then why are your extensions the only one I cannot install.
Because you have a broken installation (of phpBB):
Ancient Viking wrote: ↑
Sun Aug 02, 2020 9:00 am
[...] I downloaded phpBB 3.2.9 [...]
However, once in ACP I notice that my forum is now phpBB 3.3.0! How is that even possible? :?
You need to fix your installation by properly upgrade to 3.3.0, or find out why the constant PHPBB_VERSION is not equal or grater than 3.3.0 on your board.

As I said, it uses phpBB core functions to compare its internal version, so if anything is to blame, is phpBB itself.
Ancient Viking wrote: I can install all the other extensions and some was actually activated during the update due for being already compatible with phpBB 3.3.0.
This extension was already compatible with 3.3.0, no changes were even needed.

If it had not worked with 3.3.0, the version 2.1.0 would not have been approved ;)

One of the requirements to pass validation is that the extension must work on the latest stable version, and it was tested by multiple users.
Some of my phpBB extensions:
Image Imgur | :chart_with_upwards_trend: SEO Metadata | Image Markdown | :lock: Auto-lock Topics
:trophy: Check out all my validated extensions :trophy:

:penguin: Arch Linux user :penguin:
User avatar
AbaddonOrmuz
Recognised Extension Developer
Posts: 1003
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo
Contact:

Re: Doesn't work with 3.3?

by Ancient Viking » Thu Aug 06, 2020 5:42 pm

How can my forum be broken when I thought I could update directly from phpBB 3.2.5 to 3.3.0?

Once I found out I couldn't get access to neither the main index or ACP during the update process, I realized that I cannot update my forum without first updating my forum from 3.2.5 to 3.2.9 then updating it to phpBB 3.3.0.
My local forum: egetforum.nu - Offline Forum Online!
User avatar
Ancient Viking
Registered User
Posts: 550
Joined: Sun Jan 15, 2012 11:43 pm
Contact:

Re: Doesn't work with 3.3?

by 3Di » Thu Aug 06, 2020 6:22 pm

Again, your update/upgrade went bad. Fix it.
To request support for our extensions you can also contact me here: phpBB Studio

Please PM me only to request paid works. Thx. Want to compensate me for my interest? Donate
My development's activity ΒΊ PhpStorm's proud user ΒΊ Extensions, Scripts, MOD porting, Update/Upgrades
πŸš€ Looking for a specific feature or alternative option? We will rock you! πŸš€
User avatar
3Di
Former Team Member
Posts: 16039
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Doesn't work with 3.3?

by AbaddonOrmuz » Thu Aug 06, 2020 8:01 pm

Ancient Viking wrote: How can my forum be broken when I thought I could update directly from phpBB 3.2.5 to 3.3.0?
And you can, that's what I've been doing for years.
Ancient Viking wrote: I realized that I cannot update my forum without first updating my forum from 3.2.5 to 3.2.9 then updating it to phpBB 3.3.0

I've been upgrading many, many boards from 3.0 to 3.3.0, directly... for years! So what ever the upgrade process you followed, it went wrong at some point.
3Di wrote:Again, your update/upgrade went bad. Fix it.
Right?!

Patience my friend, patience :lol:

At some point he will realize... I hope.
Some of my phpBB extensions:
Image Imgur | :chart_with_upwards_trend: SEO Metadata | Image Markdown | :lock: Auto-lock Topics
:trophy: Check out all my validated extensions :trophy:

:penguin: Arch Linux user :penguin:
User avatar
AbaddonOrmuz
Recognised Extension Developer
Posts: 1003
Joined: Wed Dec 25, 2013 9:06 pm
Location: /dev/null
Name: Alfredo
Contact:

Re: Doesn't work with 3.3?

by 3Di » Thu Aug 06, 2020 8:08 pm

AbaddonOrmuz wrote: Right?!

Patience my friend, patience
Ofcourse. :)

Sorry, but I just can't resist. I have to be explicit from experience. :|
To request support for our extensions you can also contact me here: phpBB Studio

Please PM me only to request paid works. Thx. Want to compensate me for my interest? Donate
My development's activity ΒΊ PhpStorm's proud user ΒΊ Extensions, Scripts, MOD porting, Update/Upgrades
πŸš€ Looking for a specific feature or alternative option? We will rock you! πŸš€
User avatar
3Di
Former Team Member
Posts: 16039
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact: