Simple WYSIWYG

Adding Images as Attachments - Simple WYSIWYG

Adding Images as Attachments

by lavalamp213 » Sat Sep 14, 2019 1:49 pm

Hi,

I'm finding that if I want to add more than one image, I have to toggle to source code. In WYSIWYG mode when I click "Place inline" on the second image it just changes the first image to the second one, etc.
So I can only "place inline" one image. The rest attach to the bottom of the post.

In a related issue, I seem to be unable to continue typing after placing an image in the post. I'm unable to place the cursor after the last image posted.

Again this is remedied by toggling to source, but it would be nice to not have to instruct everyone to do all that.

And if I may, raise a third attachment-related issue, I lost the drag-n-drop ability for attaching files. They now have to be added by selecting them manually in the "attachments" tab. Not the end of the world, but...

Thanks!
User avatar
lavalamp213
Registered User
Posts: 237
Joined: Fri Apr 20, 2018 12:48 pm
Contact:

Re: Adding Images as Attachments

by lavalamp213 » Sat Sep 14, 2019 4:00 pm

I would like to add to the above issues, when someone uses the "quote text" feature to reply to a post, the cursor stays in the quote box. Again the only fix is to toggle to "source".
User avatar
lavalamp213
Registered User
Posts: 237
Joined: Fri Apr 20, 2018 12:48 pm
Contact:

Re: Adding Images as Attachments

by Senky » Wed Oct 30, 2019 1:36 pm

Hi lavalamp213,
I am not sure I can reproduce the issue you are having. I can place multiple attachments inline without problem. Could you please write down a step-by-step instructions on how to achieve the problematic state?
Senky
Extension Customisations
Extension Customisations
Posts: 2167
Joined: Thu Apr 30, 2009 8:49 pm
Name: Jakub
Contact:

Re: Adding Images as Attachments

by lavalamp213 » Wed Oct 30, 2019 1:46 pm

Hi- This was several weeks ago and I just deactivated it.

There isn#t much to tell about how I achieved the problematic state. By the way, everyone On my forum experienced the same issues.

It's really just as I describe, just trying to use the function normally, i.e. drag and drop, quote text and placing images. I did nothing unusual or differently than always.

Sorry I'm not much help, maybe if you had replied sooner I could be more help, but I've moved on.

Would still love to have this feature if it were not so problematic.

I am still running version 3.2.2. Maybe that is the issue?

Thanks.
User avatar
lavalamp213
Registered User
Posts: 237
Joined: Fri Apr 20, 2018 12:48 pm
Contact:

Re: Adding Images as Attachments

by Senky » Wed Oct 30, 2019 1:52 pm

lavalamp213,
oh I see. I fixed another bug which also solved this issue. That's why I wasn't able to reproduce it (on a new code). As soon as new version is out, you will be able to add multiple inline attachments as well as quote and write the reaction without switching to the source.
Senky
Extension Customisations
Extension Customisations
Posts: 2167
Joined: Thu Apr 30, 2009 8:49 pm
Name: Jakub
Contact:

Re: Adding Images as Attachments

by lavalamp213 » Wed Oct 30, 2019 6:07 pm

great. I look forward to it. Thanks.
User avatar
lavalamp213
Registered User
Posts: 237
Joined: Fri Apr 20, 2018 12:48 pm
Contact: