Steam Status

Steam Login Image - Steam Status

Steam Login Image

by sgp59 » Mon Oct 22, 2018 3:46 pm

I don't know if anyone encounter with a problem like this, but at the profile page where you link your steam profile, there's no image. Its just a broken image icon with a login link.

And after I've meddled with files i found out that it was coding side problem. After changing lines below with new ones, it works again.

Changing original line:

Code: Select all

<main_module.php>
Line 106/Column 49
$image_path = $config['script_path'] . '/ext/stevotvr/steamstatus/styles/all/theme/images/' . $image_lang . '/sits.png';
with a new line:

Code: Select all

<main_module.php>
Line 106/Column 49
$image_path = $config['script_path'] . 'ext/stevotvr/steamstatus/styles/all/theme/images/' . $image_lang . '/sits.png';
Putting it here in case someone encounter the same problem.

-

Also, I don't know why but it seems extension doesn't work on my forum site. After I've tried to link my steam account on, it just redirects to the login screen on forum site. Anyone else has the same problem and fix for it?
sgp59
Registered User
Posts: 4
Joined: Mon Oct 22, 2018 3:37 pm
Contact:

Re: Steam Login Image

by StevoTVR » Mon Oct 22, 2018 6:08 pm

Thanks. I'll remove that extra slash.

As for your other problem, could you send me a PM with the link that the sign in image is linking to?
User avatar
StevoTVR
Registered User
Posts: 160
Joined: Thu Jul 13, 2006 6:23 pm
Name: Steve Guidetti
Contact:

Re: Steam Login Image

by sgp59 » Mon Oct 22, 2018 6:19 pm

I cannot PM, since I do not have enough number of posts. ^^

But the problem is not that it doesnt redirect to steam, its afterwards. After u login into steam, steam redirects to the login page. And after it redirects, it doesnt save steam information onto the profile which means u gotta link again. Its a loop-like situation. Not sure if its a cookie problem or something so.
sgp59
Registered User
Posts: 4
Joined: Mon Oct 22, 2018 3:37 pm
Contact:

Re: Steam Login Image

by StevoTVR » Mon Oct 22, 2018 6:29 pm

The URL contains the URL that it sends you back to. If your board isn't using cookies, it should include the session ID. It sounds like that might not be working properly.
User avatar
StevoTVR
Registered User
Posts: 160
Joined: Thu Jul 13, 2006 6:23 pm
Name: Steve Guidetti
Contact:

Re: Steam Login Image

by sgp59 » Mon Oct 22, 2018 6:40 pm

Probably its session ID problem, just like you mentioned. Because I had cookies problem and changed some stuff on tables. I couldn't login after logout, was redirecting back to login page and couldn't gone further. Then changed tables with some advices I've found on phpbb forums.

But now that might be affecting extension, right now. 'Cuz even though it saves the session, doesnt recognize same session URL sends back to and wants you to login again. It keeps repeating as you try to link Steam account with forum account.

you can try that out at: <link removed>
sgp59
Registered User
Posts: 4
Joined: Mon Oct 22, 2018 3:37 pm
Contact: