Thanks for posts

Error after enable 2.1.0 - Thanks for posts

Error after enable 2.1.0

by peyman974 » Thu Jun 13, 2024 11:13 pm

When activating the ext
It gives an error message:

Something went wrong during the request and an exception was thrown. The changes made before the error occurred were reversed to the best of our abilities, but you should check the board for errors.

The config setting "thanks_reput_image" unexpectedly does not exist.
Last edited by peyman974 on Mon Jun 17, 2024 3:30 pm
User avatar
peyman974
Registered User
Posts: 77
Joined: Tue Sep 18, 2012 11:58 pm
Location: instagram:c64persian

Re: error after enable 2.1.0

by rxu » Fri Jun 14, 2024 3:32 am

Are you upgrading from previous extension version?
rxu
Extensions Development Team
Posts: 3804
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation

Re: error after enable 2.1.0

by peyman974 » Fri Jun 14, 2024 8:15 am

I installed another extension of the thankspost (naguissa) that didn't work
Then installed this extension and get this error message
Last edited by peyman974 on Sat Jun 15, 2024 2:41 pm
User avatar
peyman974
Registered User
Posts: 77
Joined: Tue Sep 18, 2012 11:58 pm
Location: instagram:c64persian

Re: error after enable 2.1.0

by rxu » Fri Jun 14, 2024 8:36 am

That extension is a modified fork of this one, so it can cause issues with original extension. You'd need to completely purge naguissa's ext before installing this.
rxu
Extensions Development Team
Posts: 3804
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation

Re: error after enable 2.1.0

by peyman974 » Fri Jun 14, 2024 2:03 pm

completely purged naguissa's ext

but problem still remain and show this message when enabling this ext

The config setting "thanks_reput_image" unexpectedly does not exist.

once purged all info about this ext and then upload and enable show error message
User avatar
peyman974
Registered User
Posts: 77
Joined: Tue Sep 18, 2012 11:58 pm
Location: instagram:c64persian

Re: error after enable 2.1.0

by rxu » Fri Jun 14, 2024 2:18 pm

Couldn't reproduce it installing the extension from scratch. Probably there're some leftovers in the database causing this.
If you purge this extension data and try installing again, will the error persist?
rxu
Extensions Development Team
Posts: 3804
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation

Re: error after enable 2.1.0

by peyman974 » Fri Jun 14, 2024 7:10 pm

rxu wrote:Couldn't reproduce it installing the extension from scratch. Probably there're some leftovers in the database causing this.
If you purge this extension data and try installing again, will the error persist?

yes persist
User avatar
peyman974
Registered User
Posts: 77
Joined: Tue Sep 18, 2012 11:58 pm
Location: instagram:c64persian

Re: error after enable 2.1.0

by rxu » Sat Jun 15, 2024 6:06 am

Are you able to check if any parts of the fork extension are still there directly in the database? For example, if any entries started with thanks_ exist yet in phpbb_config table.
rxu
Extensions Development Team
Posts: 3804
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation

Re: error after enable 2.1.0

by peyman974 » Sat Jun 15, 2024 10:36 am

I deleted all the entries started with thanks_ in database


now after enabling the ext show this error message:

SQL ERROR [ mysqli ]

Duplicate entry 'gfksx/thanksforposts' for key 'ext_name' [1062]

SQL

INSERT INTO forum_ext (ext_name, ext_active, ext_state) VALUES ('gfksx/thanksforposts', 0, 's:13:\"notifications\";')

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 1031
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 202
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 353
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/phpbb/extension/manager.php
LINE: 179
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/phpbb/extension/manager.php
LINE: 241
CALL: phpbb\extension\manager->update_state()

FILE: [ROOT]/includes/acp/acp_extensions.php
LINE: 209
CALL: phpbb\extension\manager->enable_step()

FILE: [ROOT]/includes/functions_module.php
LINE: 676
CALL: acp_extensions->main()

FILE: [ROOT]/adm/index.php
LINE: 81
CALL: p_master->load_active()
User avatar
peyman974
Registered User
Posts: 77
Joined: Tue Sep 18, 2012 11:58 pm
Location: instagram:c64persian

Re: error after enable 2.1.0

by peyman974 » Sat Jun 15, 2024 10:59 am

It shows a different error message each time

Now it does not show the error message in previous post
And show again the error message of the first post

need to Delete the naguissa extension files?
I renamed the folder of naguissa
Last edited by peyman974 on Sun Jun 16, 2024 9:08 am
User avatar
peyman974
Registered User
Posts: 77
Joined: Tue Sep 18, 2012 11:58 pm
Location: instagram:c64persian

Re: error after enable 2.1.0

by rxu » Sat Jun 15, 2024 11:11 am

Naguissa files shouldn't be an issue if extension data was deleted, did you delete the extension data via ACP after all?
rxu
Extensions Development Team
Posts: 3804
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation

Re: error after enable 2.1.0

by peyman974 » Sat Jun 15, 2024 11:14 am

rxu wrote:Naguissa files shouldn't be an issue if extension data was deleted, did you delete the extension data via ACP after all?
yes naguissa ext data deleted via ACP and there is not in the list of extension in acp

for now only show this error message in acp :

The config setting "thanks_reput_image" unexpectedly does not exist.
Last edited by peyman974 on Sat Jun 15, 2024 11:28 am
User avatar
peyman974
Registered User
Posts: 77
Joined: Tue Sep 18, 2012 11:58 pm
Location: instagram:c64persian

Re: error after enable 2.1.0

by rxu » Sat Jun 15, 2024 11:27 am

Try deleting data of this extension, and then checking again _config, _ext, _migrations database tables for any "thanks" leftovers, and also checking if there're any "thanks" ACP modules via ACP modules management.
rxu
Extensions Development Team
Posts: 3804
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation

Re: error after enable 2.1.0

by peyman974 » Sat Jun 15, 2024 12:32 pm

rxu wrote:Try deleting data of this extension, and then checking again _config, _ext, _migrations database tables for any "thanks" leftovers, and also checking if there're any "thanks" ACP modules via ACP modules management.
after deleting data of this extension show this error message:

Something went wrong during the request and an exception was thrown. The changes made before the error occurred were reversed to the best of our abilities, but you should check the board for errors.

A module already exists: ACP_THANKS

deleting ACP_THANKS in acp module solve the problem :)

To appreciate you I will be happy to translate this ext to Farsi where to upload after translate?

Thank you very much rxu
Last edited by peyman974 on Sun Jun 16, 2024 9:09 am
User avatar
peyman974
Registered User
Posts: 77
Joined: Tue Sep 18, 2012 11:58 pm
Location: instagram:c64persian

Re: error after enable 2.1.0

by rxu » Sat Jun 15, 2024 1:03 pm

Feel free to upload translation here https://www.phpbb.com/customise/db/exte ... pic/195066
rxu
Extensions Development Team
Posts: 3804
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation