Search found 3 matches: mchat

Go to advanced search

mChat

phpBB mChat extension

Add-on extensions
See here for some advanced add-on extensions.


Requirements - FAQ with version compatibility matrix
  • mChat 2.1.0 and later:
    • PHP >= 5.4.7
    • phpBB >= 3.2.0
  • mChat 2.0.3 and earlier:
    • PHP >= 5.3.3
    • phpBB >= 3.1.8-RC1

Installation

Installing, updating and uninstalling extensions: https://www.phpbb.com/extensions/installing/
Extension install path: ext/dmzx/mchat


Changelog mChat 2.1.3 - changelogs for previous versions can be found at GitHub
  • New features
    • Added flood messages option for better spam control. This option allows an admin to set a number of messages a user can send _consecutively_ before another user is required to post in the chat.
  • Bug fixes & improvements
    • Relaxed flood time limit from 1 minute to 1 hour
    • Fixed wrong escaping in smiley codes
    • Remove tags from hidden username string
    • Enable autocomplete and spellcheck on textarea
    • Removed unused parser dependency from functions service
    • Fixed typo in disallowed BBCodes setting
by kasimi
Sun Jan 13, 2019 11:50 am

Recent Topics

Extension for phpBB 3.2 to display recently posted topics.
Based on NV Recent Topics for phpBB 3.0, by Joas Schilling (nickvergessen)

Version Requirements
phpBB 3.1.x, 3.2.x

Features:
  • Adds a list of recent (or unread) topics to the index page.
  • UCP permissions and settings so users can choose their own preferences to override ACP.
  • can view all recent topics on a special page /app.php/rt (as of 2.2.7)
  • ACP / UCP Options:
    • Screen location : Top, bottom or Right.
    • Number of topics to show per page (as of 2.2.7)
    • Sort by topic start time, instead of last post time
    • Only show unread topics
    • Number of topics and pages to show
  • ACP Options
    • Show all recent topic pages
    • max. number of pages or all
    • set minimum topic type level to display (normal/sticky/announcement/global)
    • topic exclusion by ID
    • display parent forums in topic rows
  • Compatible with
    • "Pre:fixed" Extension from imkingdavid
    • “Topic Prefix“ Extension from Stathis.
    • official extension "phpbb/topicprefixes"
    • Mchat 2.0.1 (as of 2.2.3)
    • Collapsible Categories (as of 2.2.6)
Languages: ar, cs, de, de_x_sie, en, es, es_x_tu, fr, nl, ru

Installation:
  • Download and unzip the current release.
  • Copy the paybas/recenttopics folder to /ext/paybas/recenttopics.
  • Navigate in the ACP to Customise -> Manage extensions.
  • Look for "Recent Topics" under the Disabled Extensions list, and click the "Enable" link.
  • Set up and configure the Recent Topics extension by navigating in the ACP to Extensions -> Recent Topics.
  • Manage Recent Topics permissions under Group Permissions -> Misc
Development: https://github.com/Sajaki/RecentTopics
by Sajaki
Sat Apr 28, 2018 12:44 pm

Imgur

Click on the Imgur posting button and select the image(s) you want to upload.

If the upload is successful it will add the image in the topic, private message or signature content. You can choose in the Administration Control Panel to show the uploaded image as plan text or with BBCode as URL, image (default) or thumbnail.

Note: The same Imgur account will be used to upload all the images.

Features:
  • Change Imgur API data through ACP
  • Optionally, set an album where all the images will be uploaded to.
  • Compatibility with ABBC3 extension (since version 1.0.4)
  • CSRF protection (since version 1.1.0)
  • Administrator log on configuration changes (since version 1.1.0)
  • Insert BBCode/text at cursor position (since version 1.1.0)
  • Album download link in the ACP for backup (since version 1.1.0)
  • Upload progress bar (since version 1.2.0)
  • Compatibility with QuickReply Reloaded extension (since 1.2.0)
  • Compatibility with mChat extension (since 1.2.0)
  • Drop-down menu in posting box button (since 1.3.0)
  • Imgur tab in posting box options (since 1.3.0)
  • Save some user preferences using localStorage and sessionStorage (since 1.3.0)
Requirements:
  • PHP 5.6 or greater
  • phpBB 3.2 or greater
  • Imgur API data (client_id and client_secret)
Translations:
  • Spanish (Formal Honorifics) [es]
  • Spanish (Casual Honorifics) [es_x_tu]
by AbaddonOrmuz
Wed Apr 10, 2019 7:34 pm